This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-01-01 14:31
Elapsed3m31s
Revision
Buildergke-prow-ssd-pool-1a225945-zjpx
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/16bf37ad-811c-4220-9372-7a622b81bfa3/targets/test'}}
pod402cd2c8-2ca3-11ea-a07b-c6eb1bf16817
resultstorehttps://source.cloud.google.com/results/invocations/16bf37ad-811c-4220-9372-7a622b81bfa3/targets/test
infra-commit35a960fa0
job-versionv1.18.0-alpha.1.279+09cb73a554d321
pod402cd2c8-2ca3-11ea-a07b-c6eb1bf16817
revisionv1.18.0-alpha.1.279+09cb73a554d321

Test Failures


Up 1m37s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-08 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.279+09cb73a554d321 bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0101 14:31:08.300] process 47 exited with code 0 after 0.0m
I0101 14:31:08.300] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0101 14:31:08.301] Root: /workspace
I0101 14:31:08.301] cd to /workspace
I0101 14:31:08.301] Configure environment...
I0101 14:31:08.301] Call:  git show -s --format=format:%ct HEAD
W0101 14:31:08.306] fatal: not a git repository (or any of the parent directories): .git
I0101 14:31:08.308] process 60 exited with code 128 after 0.0m
W0101 14:31:08.308] Unable to print commit date for HEAD
I0101 14:31:08.308] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0101 14:31:08.873] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0101 14:31:09.194] process 61 exited with code 0 after 0.0m
I0101 14:31:09.195] Call:  gcloud config get-value account
... skipping 426 lines ...
W0101 14:33:39.954] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W0101 14:33:39.955] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W0101 14:33:39.956] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W0101 14:33:39.957] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0101 14:33:39.957] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0101 14:33:39.958] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W0101 14:34:27.063] ERROR: (gcloud.container.clusters.create) ResponseError: code=500, message=Internal error encountered.
W0101 14:34:27.116] 2020/01/01 14:34:27 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-08 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.279+09cb73a554d321 bootstrap-e2e' finished in 47.531405264s
W0101 14:34:28.670] 2020/01/01 14:34:28 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0101 14:34:31.981] 2020/01/01 14:34:31 main.go:319: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-08 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.279+09cb73a554d321 bootstrap-e2e: exit status 1
W0101 14:34:31.983] Traceback (most recent call last):
W0101 14:34:31.983]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W0101 14:34:31.983]     main(parse_args())
W0101 14:34:31.984]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W0101 14:34:31.984]     mode.start(runner_args)
W0101 14:34:31.984]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0101 14:34:31.984]     check_env(env, self.command, *args)
W0101 14:34:31.984]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0101 14:34:31.984]     subprocess.check_call(cmd, env=env)
W0101 14:34:31.984]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0101 14:34:31.985]     raise CalledProcessError(retcode, cmd)
W0101 14:34:31.985] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/latest', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-b', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-p100,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E0101 14:34:31.993] Command failed
I0101 14:34:31.993] process 268 exited with code 1 after 3.4m
E0101 14:34:31.993] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-p100
I0101 14:34:31.993] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0101 14:34:32.488] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0101 14:34:32.536] process 1387 exited with code 0 after 0.0m
I0101 14:34:32.536] Call:  gcloud config get-value account
I0101 14:34:32.850] process 1400 exited with code 0 after 0.0m
I0101 14:34:32.851] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0101 14:34:32.851] Upload result and artifacts...
I0101 14:34:32.851] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/1212380679795380224
I0101 14:34:32.852] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/1212380679795380224/artifacts
W0101 14:34:33.697] CommandException: One or more URLs matched no objects.
E0101 14:34:33.809] Command failed
I0101 14:34:33.809] process 1413 exited with code 1 after 0.0m
W0101 14:34:33.810] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/1212380679795380224/artifacts not exist yet
I0101 14:34:33.810] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/1212380679795380224/artifacts
I0101 14:34:35.278] process 1558 exited with code 0 after 0.0m
I0101 14:34:35.278] Call:  git rev-parse HEAD
W0101 14:34:35.282] fatal: not a git repository (or any of the parent directories): .git
E0101 14:34:35.283] Command failed
I0101 14:34:35.283] process 2085 exited with code 128 after 0.0m
I0101 14:34:35.283] Call:  git rev-parse HEAD
I0101 14:34:35.287] process 2086 exited with code 0 after 0.0m
I0101 14:34:35.288] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/jobResultsCache.json
I0101 14:34:36.237] process 2087 exited with code 0 after 0.0m
I0101 14:34:36.237] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/jobResultsCache.json#1577846094602673'
... skipping 8 lines ...