This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-01-02 02:31
Elapsed4m23s
Revision
Buildergke-prow-ssd-pool-1a225945-0v43
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/75fc2252-dcf3-4c18-80aa-1e224f20d749/targets/test'}}
podd59ac5b0-2d07-11ea-a07b-c6eb1bf16817
resultstorehttps://source.cloud.google.com/results/invocations/75fc2252-dcf3-4c18-80aa-1e224f20d749/targets/test
infra-commit35a960fa0
job-versionv1.18.0-alpha.1.279+09cb73a554d321
podd59ac5b0-2d07-11ea-a07b-c6eb1bf16817
revisionv1.18.0-alpha.1.279+09cb73a554d321

Test Failures


Up 1m41s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-02 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.279+09cb73a554d321 bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0102 02:31:20.606] process 47 exited with code 0 after 0.0m
I0102 02:31:20.607] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0102 02:31:20.607] Root: /workspace
I0102 02:31:20.607] cd to /workspace
I0102 02:31:20.607] Configure environment...
I0102 02:31:20.608] Call:  git show -s --format=format:%ct HEAD
W0102 02:31:20.613] fatal: not a git repository (or any of the parent directories): .git
I0102 02:31:20.614] process 60 exited with code 128 after 0.0m
W0102 02:31:20.614] Unable to print commit date for HEAD
I0102 02:31:20.615] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0102 02:31:21.248] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0102 02:31:21.577] process 61 exited with code 0 after 0.0m
I0102 02:31:21.578] Call:  gcloud config get-value account
... skipping 426 lines ...
W0102 02:34:39.749] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W0102 02:34:39.749] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W0102 02:34:39.750] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W0102 02:34:39.751] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0102 02:34:39.751] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0102 02:34:39.752] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W0102 02:35:24.720] ERROR: (gcloud.container.clusters.create) ResponseError: code=500, message=Internal error encountered.
W0102 02:35:24.770] 2020/01/02 02:35:24 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-02 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.279+09cb73a554d321 bootstrap-e2e' finished in 45.426785258s
W0102 02:35:26.260] 2020/01/02 02:35:26 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0102 02:35:35.557] 2020/01/02 02:35:35 main.go:319: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-02 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.279+09cb73a554d321 bootstrap-e2e: exit status 1
W0102 02:35:35.563] Traceback (most recent call last):
W0102 02:35:35.563]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W0102 02:35:35.563]     main(parse_args())
W0102 02:35:35.564]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W0102 02:35:35.564]     mode.start(runner_args)
W0102 02:35:35.564]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0102 02:35:35.564]     check_env(env, self.command, *args)
W0102 02:35:35.564]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0102 02:35:35.564]     subprocess.check_call(cmd, env=env)
W0102 02:35:35.565]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0102 02:35:35.565]     raise CalledProcessError(retcode, cmd)
W0102 02:35:35.565] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/latest', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-b', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-p100,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E0102 02:35:35.571] Command failed
I0102 02:35:35.571] process 268 exited with code 1 after 4.2m
E0102 02:35:35.571] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-p100
I0102 02:35:35.571] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0102 02:35:36.072] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0102 02:35:36.120] process 1391 exited with code 0 after 0.0m
I0102 02:35:36.121] Call:  gcloud config get-value account
I0102 02:35:36.457] process 1404 exited with code 0 after 0.0m
I0102 02:35:36.457] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0102 02:35:36.458] Upload result and artifacts...
I0102 02:35:36.458] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/1212561877511442432
I0102 02:35:36.458] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/1212561877511442432/artifacts
W0102 02:35:37.370] CommandException: One or more URLs matched no objects.
E0102 02:35:37.508] Command failed
I0102 02:35:37.509] process 1417 exited with code 1 after 0.0m
W0102 02:35:37.509] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/1212561877511442432/artifacts not exist yet
I0102 02:35:37.509] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/1212561877511442432/artifacts
I0102 02:35:39.044] process 1562 exited with code 0 after 0.0m
I0102 02:35:39.044] Call:  git rev-parse HEAD
W0102 02:35:39.050] fatal: not a git repository (or any of the parent directories): .git
E0102 02:35:39.051] Command failed
I0102 02:35:39.051] process 2089 exited with code 128 after 0.0m
I0102 02:35:39.051] Call:  git rev-parse HEAD
I0102 02:35:39.055] process 2090 exited with code 0 after 0.0m
I0102 02:35:39.055] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/jobResultsCache.json
I0102 02:35:39.997] process 2091 exited with code 0 after 0.0m
I0102 02:35:39.998] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/jobResultsCache.json#1577889278311413'
... skipping 8 lines ...