This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-01-02 14:31
Elapsed4m3s
Revision
Buildergke-prow-ssd-pool-1a225945-kp0f
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/b3ea5ede-babb-4558-a0b3-60b492dc625a/targets/test'}}
pod6b6e2cb4-2d6c-11ea-a07b-c6eb1bf16817
resultstorehttps://source.cloud.google.com/results/invocations/b3ea5ede-babb-4558-a0b3-60b492dc625a/targets/test
infra-commit21941a80c
job-versionv1.18.0-alpha.1.279+09cb73a554d321
pod6b6e2cb4-2d6c-11ea-a07b-c6eb1bf16817
revisionv1.18.0-alpha.1.279+09cb73a554d321

Test Failures


Up 1m38s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-06 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.279+09cb73a554d321 bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0102 14:31:16.568] process 48 exited with code 0 after 0.0m
I0102 14:31:16.568] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0102 14:31:16.569] Root: /workspace
I0102 14:31:16.569] cd to /workspace
I0102 14:31:16.569] Configure environment...
I0102 14:31:16.569] Call:  git show -s --format=format:%ct HEAD
W0102 14:31:16.574] fatal: not a git repository (or any of the parent directories): .git
I0102 14:31:16.574] process 61 exited with code 128 after 0.0m
W0102 14:31:16.575] Unable to print commit date for HEAD
I0102 14:31:16.575] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0102 14:31:17.122] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0102 14:31:17.464] process 62 exited with code 0 after 0.0m
I0102 14:31:17.464] Call:  gcloud config get-value account
... skipping 426 lines ...
W0102 14:34:16.860] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W0102 14:34:16.861] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W0102 14:34:16.862] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W0102 14:34:16.863] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0102 14:34:16.863] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0102 14:34:16.864] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W0102 14:35:03.205] ERROR: (gcloud.container.clusters.create) ResponseError: code=500, message=Internal error encountered.
W0102 14:35:03.255] 2020/01/02 14:35:03 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-06 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.279+09cb73a554d321 bootstrap-e2e' finished in 47.158411877s
W0102 14:35:04.961] 2020/01/02 14:35:04 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0102 14:35:10.673] 2020/01/02 14:35:10 main.go:319: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-06 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.279+09cb73a554d321 bootstrap-e2e: exit status 1
W0102 14:35:10.677] Traceback (most recent call last):
W0102 14:35:10.677]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W0102 14:35:10.678]     main(parse_args())
W0102 14:35:10.678]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W0102 14:35:10.678]     mode.start(runner_args)
W0102 14:35:10.678]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0102 14:35:10.678]     check_env(env, self.command, *args)
W0102 14:35:10.679]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0102 14:35:10.679]     subprocess.check_call(cmd, env=env)
W0102 14:35:10.679]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0102 14:35:10.679]     raise CalledProcessError(retcode, cmd)
W0102 14:35:10.680] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/latest', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-b', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-p100,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E0102 14:35:10.690] Command failed
I0102 14:35:10.690] process 269 exited with code 1 after 3.9m
E0102 14:35:10.690] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-p100
I0102 14:35:10.690] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0102 14:35:11.337] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0102 14:35:11.391] process 1392 exited with code 0 after 0.0m
I0102 14:35:11.391] Call:  gcloud config get-value account
I0102 14:35:11.823] process 1405 exited with code 0 after 0.0m
I0102 14:35:11.823] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0102 14:35:11.823] Upload result and artifacts...
I0102 14:35:11.823] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/1212743080713654273
I0102 14:35:11.824] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/1212743080713654273/artifacts
W0102 14:35:12.969] CommandException: One or more URLs matched no objects.
E0102 14:35:13.108] Command failed
I0102 14:35:13.109] process 1418 exited with code 1 after 0.0m
W0102 14:35:13.109] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/1212743080713654273/artifacts not exist yet
I0102 14:35:13.109] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/1212743080713654273/artifacts
I0102 14:35:15.105] process 1563 exited with code 0 after 0.0m
I0102 14:35:15.106] Call:  git rev-parse HEAD
W0102 14:35:15.111] fatal: not a git repository (or any of the parent directories): .git
E0102 14:35:15.112] Command failed
I0102 14:35:15.113] process 2090 exited with code 128 after 0.0m
I0102 14:35:15.113] Call:  git rev-parse HEAD
I0102 14:35:15.118] process 2091 exited with code 0 after 0.0m
I0102 14:35:15.118] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/jobResultsCache.json
I0102 14:35:16.302] process 2092 exited with code 0 after 0.0m
I0102 14:35:16.303] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/jobResultsCache.json#1577932542330367'
... skipping 8 lines ...