This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-01-03 02:31
Elapsed4m58s
Revision
Buildergke-prow-ssd-pool-1a225945-8w66
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/eec5f62d-3896-4f63-99d6-41d4d69f849d/targets/test'}}
pod017c294f-2dd1-11ea-a07b-c6eb1bf16817
resultstorehttps://source.cloud.google.com/results/invocations/eec5f62d-3896-4f63-99d6-41d4d69f849d/targets/test
infra-commitd58556ac6
job-versionv1.18.0-alpha.1.286+57707f16cbeaa6
pod017c294f-2dd1-11ea-a07b-c6eb1bf16817
revisionv1.18.0-alpha.1.286+57707f16cbeaa6

Test Failures


Up 1m43s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-03 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.286+57707f16cbeaa6 bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0103 02:31:25.395] process 47 exited with code 0 after 0.0m
I0103 02:31:25.395] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0103 02:31:25.396] Root: /workspace
I0103 02:31:25.396] cd to /workspace
I0103 02:31:25.397] Configure environment...
I0103 02:31:25.397] Call:  git show -s --format=format:%ct HEAD
W0103 02:31:25.402] fatal: not a git repository (or any of the parent directories): .git
I0103 02:31:25.403] process 60 exited with code 128 after 0.0m
W0103 02:31:25.403] Unable to print commit date for HEAD
I0103 02:31:25.403] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0103 02:31:25.997] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0103 02:31:26.385] process 61 exited with code 0 after 0.0m
I0103 02:31:26.385] Call:  gcloud config get-value account
... skipping 426 lines ...
W0103 02:35:21.267] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W0103 02:35:21.268] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W0103 02:35:21.269] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W0103 02:35:21.274] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0103 02:35:21.275] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0103 02:35:21.276] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W0103 02:36:09.164] ERROR: (gcloud.container.clusters.create) ResponseError: code=500, message=Internal error encountered.
W0103 02:36:09.231] 2020/01/03 02:36:09 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-03 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.286+57707f16cbeaa6 bootstrap-e2e' finished in 48.437849354s
W0103 02:36:10.906] 2020/01/03 02:36:10 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0103 02:36:12.888] 2020/01/03 02:36:12 main.go:319: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-03 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.286+57707f16cbeaa6 bootstrap-e2e: exit status 1
W0103 02:36:12.892] Traceback (most recent call last):
W0103 02:36:12.892]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W0103 02:36:12.892]     main(parse_args())
W0103 02:36:12.893]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W0103 02:36:12.893]     mode.start(runner_args)
W0103 02:36:12.893]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0103 02:36:12.893]     check_env(env, self.command, *args)
W0103 02:36:12.893]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0103 02:36:12.893]     subprocess.check_call(cmd, env=env)
W0103 02:36:12.894]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0103 02:36:12.894]     raise CalledProcessError(retcode, cmd)
W0103 02:36:12.894] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/latest', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-b', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-p100,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E0103 02:36:12.903] Command failed
I0103 02:36:12.904] process 268 exited with code 1 after 4.7m
E0103 02:36:12.904] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-p100
I0103 02:36:12.904] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0103 02:36:13.413] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0103 02:36:13.473] process 1388 exited with code 0 after 0.0m
I0103 02:36:13.474] Call:  gcloud config get-value account
I0103 02:36:13.866] process 1401 exited with code 0 after 0.0m
I0103 02:36:13.866] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0103 02:36:13.866] Upload result and artifacts...
I0103 02:36:13.867] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/1212924285660696577
I0103 02:36:13.867] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/1212924285660696577/artifacts
W0103 02:36:14.944] CommandException: One or more URLs matched no objects.
E0103 02:36:15.088] Command failed
I0103 02:36:15.089] process 1414 exited with code 1 after 0.0m
W0103 02:36:15.089] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/1212924285660696577/artifacts not exist yet
I0103 02:36:15.089] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/1212924285660696577/artifacts
I0103 02:36:17.328] process 1559 exited with code 0 after 0.0m
I0103 02:36:17.329] Call:  git rev-parse HEAD
W0103 02:36:17.337] fatal: not a git repository (or any of the parent directories): .git
E0103 02:36:17.337] Command failed
I0103 02:36:17.339] process 2086 exited with code 128 after 0.0m
I0103 02:36:17.340] Call:  git rev-parse HEAD
I0103 02:36:17.350] process 2087 exited with code 0 after 0.0m
I0103 02:36:17.351] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/jobResultsCache.json
I0103 02:36:18.855] process 2088 exited with code 0 after 0.0m
I0103 02:36:18.856] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/jobResultsCache.json#1577975718754567'
... skipping 8 lines ...