This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-01-03 14:31
Elapsed3m49s
Revision
Buildergke-prow-ssd-pool-1a225945-kp0f
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/da44e3e9-f18b-4829-803b-64786355b809/targets/test'}}
pod97c36b4e-2e35-11ea-a07b-c6eb1bf16817
resultstorehttps://source.cloud.google.com/results/invocations/da44e3e9-f18b-4829-803b-64786355b809/targets/test
infra-commit830f0cf43
job-versionv1.18.0-alpha.1.307+180e1c9f5159a2
pod97c36b4e-2e35-11ea-a07b-c6eb1bf16817
revisionv1.18.0-alpha.1.307+180e1c9f5159a2

Test Failures


Up 1m33s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-08 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.307+180e1c9f5159a2 bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0103 14:31:20.181] process 47 exited with code 0 after 0.0m
I0103 14:31:20.181] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0103 14:31:20.182] Root: /workspace
I0103 14:31:20.182] cd to /workspace
I0103 14:31:20.182] Configure environment...
I0103 14:31:20.182] Call:  git show -s --format=format:%ct HEAD
W0103 14:31:20.187] fatal: not a git repository (or any of the parent directories): .git
I0103 14:31:20.187] process 60 exited with code 128 after 0.0m
W0103 14:31:20.188] Unable to print commit date for HEAD
I0103 14:31:20.188] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0103 14:31:20.756] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0103 14:31:21.076] process 61 exited with code 0 after 0.0m
I0103 14:31:21.077] Call:  gcloud config get-value account
... skipping 426 lines ...
W0103 14:34:08.696] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W0103 14:34:08.697] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W0103 14:34:08.698] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W0103 14:34:08.699] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0103 14:34:08.699] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0103 14:34:08.699] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W0103 14:34:56.969] ERROR: (gcloud.container.clusters.create) ResponseError: code=500, message=Internal error encountered.
W0103 14:34:57.019] 2020/01/03 14:34:57 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-08 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.307+180e1c9f5159a2 bootstrap-e2e' finished in 48.757697099s
W0103 14:34:58.563] 2020/01/03 14:34:58 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0103 14:35:01.445] 2020/01/03 14:35:01 main.go:319: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-08 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.307+180e1c9f5159a2 bootstrap-e2e: exit status 1
W0103 14:35:01.446] Traceback (most recent call last):
W0103 14:35:01.446]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W0103 14:35:01.446]     main(parse_args())
W0103 14:35:01.446]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W0103 14:35:01.446]     mode.start(runner_args)
W0103 14:35:01.447]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0103 14:35:01.447]     check_env(env, self.command, *args)
W0103 14:35:01.447]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0103 14:35:01.447]     subprocess.check_call(cmd, env=env)
W0103 14:35:01.447]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0103 14:35:01.448]     raise CalledProcessError(retcode, cmd)
W0103 14:35:01.448] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/latest', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-b', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-p100,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E0103 14:35:01.454] Command failed
I0103 14:35:01.454] process 268 exited with code 1 after 3.6m
E0103 14:35:01.455] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-p100
I0103 14:35:01.455] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0103 14:35:01.980] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0103 14:35:02.038] process 1387 exited with code 0 after 0.0m
I0103 14:35:02.038] Call:  gcloud config get-value account
I0103 14:35:02.376] process 1400 exited with code 0 after 0.0m
I0103 14:35:02.377] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0103 14:35:02.377] Upload result and artifacts...
I0103 14:35:02.377] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/1213105491522097153
I0103 14:35:02.377] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/1213105491522097153/artifacts
W0103 14:35:03.268] CommandException: One or more URLs matched no objects.
E0103 14:35:03.379] Command failed
I0103 14:35:03.380] process 1413 exited with code 1 after 0.0m
W0103 14:35:03.380] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/1213105491522097153/artifacts not exist yet
I0103 14:35:03.380] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/1213105491522097153/artifacts
I0103 14:35:04.947] process 1558 exited with code 0 after 0.0m
I0103 14:35:04.947] Call:  git rev-parse HEAD
W0103 14:35:04.951] fatal: not a git repository (or any of the parent directories): .git
E0103 14:35:04.952] Command failed
I0103 14:35:04.952] process 2085 exited with code 128 after 0.0m
I0103 14:35:04.952] Call:  git rev-parse HEAD
I0103 14:35:04.957] process 2086 exited with code 0 after 0.0m
I0103 14:35:04.957] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/jobResultsCache.json
I0103 14:35:05.887] process 2087 exited with code 0 after 0.0m
I0103 14:35:05.888] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/jobResultsCache.json#1578018982438812'
... skipping 8 lines ...