This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-01-04 02:31
Elapsed4m21s
Revision
Buildergke-prow-ssd-pool-1a225945-fqsc
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/c2ef32a5-e43d-4ebd-959c-7090cdf9602e/targets/test'}}
pod2de08866-2e9a-11ea-a07b-c6eb1bf16817
resultstorehttps://source.cloud.google.com/results/invocations/c2ef32a5-e43d-4ebd-959c-7090cdf9602e/targets/test
infra-commitb0e571d31
job-versionv1.18.0-alpha.1.315+135ddf1ccccf37
pod2de08866-2e9a-11ea-a07b-c6eb1bf16817
revisionv1.18.0-alpha.1.315+135ddf1ccccf37

Test Failures


Up 1m30s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-06 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.315+135ddf1ccccf37 bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0104 02:31:29.959] process 47 exited with code 0 after 0.0m
I0104 02:31:29.960] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0104 02:31:29.960] Root: /workspace
I0104 02:31:29.960] cd to /workspace
I0104 02:31:29.961] Configure environment...
I0104 02:31:29.961] Call:  git show -s --format=format:%ct HEAD
W0104 02:31:29.967] fatal: not a git repository (or any of the parent directories): .git
I0104 02:31:29.968] process 60 exited with code 128 after 0.0m
W0104 02:31:29.968] Unable to print commit date for HEAD
I0104 02:31:29.969] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0104 02:31:30.801] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0104 02:31:31.168] process 61 exited with code 0 after 0.0m
I0104 02:31:31.168] Call:  gcloud config get-value account
... skipping 426 lines ...
W0104 02:34:50.905] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W0104 02:34:50.906] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W0104 02:34:50.908] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W0104 02:34:50.908] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0104 02:34:50.909] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0104 02:34:50.910] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W0104 02:35:30.079] ERROR: (gcloud.container.clusters.create) ResponseError: code=500, message=Internal error encountered.
W0104 02:35:30.131] 2020/01/04 02:35:30 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-06 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.315+135ddf1ccccf37 bootstrap-e2e' finished in 39.844318704s
W0104 02:35:31.892] 2020/01/04 02:35:31 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0104 02:35:40.970] 2020/01/04 02:35:40 main.go:319: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-06 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.315+135ddf1ccccf37 bootstrap-e2e: exit status 1
W0104 02:35:40.978] Traceback (most recent call last):
W0104 02:35:40.978]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W0104 02:35:40.978]     main(parse_args())
W0104 02:35:40.978]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W0104 02:35:40.978]     mode.start(runner_args)
W0104 02:35:40.979]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0104 02:35:40.979]     check_env(env, self.command, *args)
W0104 02:35:40.979]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0104 02:35:40.979]     subprocess.check_call(cmd, env=env)
W0104 02:35:40.979]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0104 02:35:40.979]     raise CalledProcessError(retcode, cmd)
W0104 02:35:40.980] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/latest', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-b', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-p100,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E0104 02:35:40.987] Command failed
I0104 02:35:40.987] process 268 exited with code 1 after 4.1m
E0104 02:35:40.987] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-p100
I0104 02:35:40.988] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0104 02:35:41.598] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0104 02:35:41.664] process 1388 exited with code 0 after 0.0m
I0104 02:35:41.665] Call:  gcloud config get-value account
I0104 02:35:42.067] process 1401 exited with code 0 after 0.0m
I0104 02:35:42.068] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0104 02:35:42.068] Upload result and artifacts...
I0104 02:35:42.068] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/1213286696649494528
I0104 02:35:42.069] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/1213286696649494528/artifacts
W0104 02:35:43.064] CommandException: One or more URLs matched no objects.
E0104 02:35:43.201] Command failed
I0104 02:35:43.202] process 1414 exited with code 1 after 0.0m
W0104 02:35:43.202] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/1213286696649494528/artifacts not exist yet
I0104 02:35:43.202] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/1213286696649494528/artifacts
I0104 02:35:45.158] process 1559 exited with code 0 after 0.0m
I0104 02:35:45.159] Call:  git rev-parse HEAD
W0104 02:35:45.165] fatal: not a git repository (or any of the parent directories): .git
E0104 02:35:45.165] Command failed
I0104 02:35:45.166] process 2086 exited with code 128 after 0.0m
I0104 02:35:45.166] Call:  git rev-parse HEAD
I0104 02:35:45.172] process 2087 exited with code 0 after 0.0m
I0104 02:35:45.172] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/jobResultsCache.json
I0104 02:35:46.294] process 2088 exited with code 0 after 0.0m
I0104 02:35:46.295] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/jobResultsCache.json#1578062108067269'
... skipping 8 lines ...