This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-01-04 14:31
Elapsed3m37s
Revision
Buildergke-prow-ssd-pool-1a225945-f0q6
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/8c07453e-aa8b-4526-bef3-ff5b5bcc5096/targets/test'}}
podc3535c4b-2efe-11ea-a07b-c6eb1bf16817
resultstorehttps://source.cloud.google.com/results/invocations/8c07453e-aa8b-4526-bef3-ff5b5bcc5096/targets/test
infra-commitf6d82f412
job-versionv1.18.0-alpha.1.322+124a49ca5f3bfc
podc3535c4b-2efe-11ea-a07b-c6eb1bf16817
revisionv1.18.0-alpha.1.322+124a49ca5f3bfc

Test Failures


Up 1m26s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-jkns-e2e-gce-gpus-beta --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.322+124a49ca5f3bfc bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0104 14:31:23.827] process 53 exited with code 0 after 0.0m
I0104 14:31:23.827] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0104 14:31:23.827] Root: /workspace
I0104 14:31:23.828] cd to /workspace
I0104 14:31:23.828] Configure environment...
I0104 14:31:23.828] Call:  git show -s --format=format:%ct HEAD
W0104 14:31:23.833] fatal: not a git repository (or any of the parent directories): .git
I0104 14:31:23.834] process 66 exited with code 128 after 0.0m
W0104 14:31:23.834] Unable to print commit date for HEAD
I0104 14:31:23.834] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0104 14:31:24.364] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0104 14:31:24.686] process 67 exited with code 0 after 0.0m
I0104 14:31:24.687] Call:  gcloud config get-value account
... skipping 426 lines ...
W0104 14:33:52.277] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W0104 14:33:52.278] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W0104 14:33:52.280] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W0104 14:33:52.280] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0104 14:33:52.281] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0104 14:33:52.282] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W0104 14:34:33.122] ERROR: (gcloud.container.clusters.create) ResponseError: code=500, message=Internal error encountered.
W0104 14:34:33.172] 2020/01/04 14:34:33 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-jkns-e2e-gce-gpus-beta --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.322+124a49ca5f3bfc bootstrap-e2e' finished in 41.318433837s
W0104 14:34:34.747] 2020/01/04 14:34:34 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0104 14:34:52.121] 2020/01/04 14:34:52 main.go:319: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-jkns-e2e-gce-gpus-beta --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.322+124a49ca5f3bfc bootstrap-e2e: exit status 1
W0104 14:34:52.122] Traceback (most recent call last):
W0104 14:34:52.123]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W0104 14:34:52.123]     main(parse_args())
W0104 14:34:52.123]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W0104 14:34:52.123]     mode.start(runner_args)
W0104 14:34:52.123]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0104 14:34:52.124]     check_env(env, self.command, *args)
W0104 14:34:52.124]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0104 14:34:52.124]     subprocess.check_call(cmd, env=env)
W0104 14:34:52.124]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0104 14:34:52.124]     raise CalledProcessError(retcode, cmd)
W0104 14:34:52.125] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/latest', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-b', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-p100,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E0104 14:34:52.133] Command failed
I0104 14:34:52.133] process 274 exited with code 1 after 3.4m
E0104 14:34:52.133] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-p100
I0104 14:34:52.133] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0104 14:34:52.713] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0104 14:34:52.770] process 1395 exited with code 0 after 0.0m
I0104 14:34:52.770] Call:  gcloud config get-value account
I0104 14:34:53.123] process 1408 exited with code 0 after 0.0m
I0104 14:34:53.124] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0104 14:34:53.124] Upload result and artifacts...
I0104 14:34:53.124] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/1213467900413743106
I0104 14:34:53.125] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/1213467900413743106/artifacts
W0104 14:34:54.074] CommandException: One or more URLs matched no objects.
E0104 14:34:54.203] Command failed
I0104 14:34:54.204] process 1421 exited with code 1 after 0.0m
W0104 14:34:54.204] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/1213467900413743106/artifacts not exist yet
I0104 14:34:54.204] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/1213467900413743106/artifacts
I0104 14:34:55.834] process 1566 exited with code 0 after 0.0m
I0104 14:34:55.835] Call:  git rev-parse HEAD
W0104 14:34:55.840] fatal: not a git repository (or any of the parent directories): .git
E0104 14:34:55.840] Command failed
I0104 14:34:55.841] process 2093 exited with code 128 after 0.0m
I0104 14:34:55.841] Call:  git rev-parse HEAD
I0104 14:34:55.846] process 2094 exited with code 0 after 0.0m
I0104 14:34:55.847] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/jobResultsCache.json
I0104 14:34:56.834] process 2095 exited with code 0 after 0.0m
I0104 14:34:56.834] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/jobResultsCache.json#1578105348797228'
... skipping 8 lines ...