This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-01-05 14:31
Elapsed8m15s
Revision
Buildergke-prow-ssd-pool-1a225945-z5n1
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/113a64fa-c254-4ab6-b0cb-a777f5f63b06/targets/test'}}
podedfb5d63-2fc7-11ea-a07b-c6eb1bf16817
resultstorehttps://source.cloud.google.com/results/invocations/113a64fa-c254-4ab6-b0cb-a777f5f63b06/targets/test
infra-commit235805981
job-versionv1.18.0-alpha.1.333+94fa017ee234df
podedfb5d63-2fc7-11ea-a07b-c6eb1bf16817
revisionv1.18.0-alpha.1.333+94fa017ee234df

Test Failures


Up 1m38s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-06 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.333+94fa017ee234df bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0105 14:31:34.593] process 47 exited with code 0 after 0.0m
I0105 14:31:34.593] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0105 14:31:34.594] Root: /workspace
I0105 14:31:34.594] cd to /workspace
I0105 14:31:34.594] Configure environment...
I0105 14:31:34.594] Call:  git show -s --format=format:%ct HEAD
W0105 14:31:34.599] fatal: not a git repository (or any of the parent directories): .git
I0105 14:31:34.600] process 60 exited with code 128 after 0.0m
W0105 14:31:34.601] Unable to print commit date for HEAD
I0105 14:31:34.601] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0105 14:31:35.443] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0105 14:31:35.593] process 61 exited with code 0 after 0.0m
I0105 14:31:35.593] Call:  gcloud config get-value account
... skipping 426 lines ...
W0105 14:38:43.269] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W0105 14:38:43.270] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W0105 14:38:43.271] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W0105 14:38:43.272] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0105 14:38:43.272] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0105 14:38:43.273] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W0105 14:39:31.236] ERROR: (gcloud.container.clusters.create) ResponseError: code=500, message=Internal error encountered.
W0105 14:39:31.289] 2020/01/05 14:39:31 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-06 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.333+94fa017ee234df bootstrap-e2e' finished in 48.491636957s
W0105 14:39:32.912] 2020/01/05 14:39:32 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0105 14:39:40.610] 2020/01/05 14:39:40 main.go:319: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-06 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.333+94fa017ee234df bootstrap-e2e: exit status 1
W0105 14:39:40.614] Traceback (most recent call last):
W0105 14:39:40.615]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W0105 14:39:40.615]     main(parse_args())
W0105 14:39:40.615]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W0105 14:39:40.615]     mode.start(runner_args)
W0105 14:39:40.615]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0105 14:39:40.616]     check_env(env, self.command, *args)
W0105 14:39:40.616]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0105 14:39:40.616]     subprocess.check_call(cmd, env=env)
W0105 14:39:40.616]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0105 14:39:40.616]     raise CalledProcessError(retcode, cmd)
W0105 14:39:40.617] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/latest', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-b', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-p100,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E0105 14:39:40.625] Command failed
I0105 14:39:40.625] process 268 exited with code 1 after 8.0m
E0105 14:39:40.625] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-p100
I0105 14:39:40.626] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0105 14:39:41.160] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0105 14:39:41.220] process 1387 exited with code 0 after 0.0m
I0105 14:39:41.220] Call:  gcloud config get-value account
I0105 14:39:41.617] process 1400 exited with code 0 after 0.0m
I0105 14:39:41.618] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0105 14:39:41.618] Upload result and artifacts...
I0105 14:39:41.618] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/1213830298593136640
I0105 14:39:41.618] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/1213830298593136640/artifacts
W0105 14:39:42.588] CommandException: One or more URLs matched no objects.
E0105 14:39:42.723] Command failed
I0105 14:39:42.723] process 1413 exited with code 1 after 0.0m
W0105 14:39:42.723] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/1213830298593136640/artifacts not exist yet
I0105 14:39:42.723] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/1213830298593136640/artifacts
I0105 14:39:44.460] process 1558 exited with code 0 after 0.0m
I0105 14:39:44.461] Call:  git rev-parse HEAD
W0105 14:39:44.466] fatal: not a git repository (or any of the parent directories): .git
E0105 14:39:44.467] Command failed
I0105 14:39:44.467] process 2085 exited with code 128 after 0.0m
I0105 14:39:44.468] Call:  git rev-parse HEAD
I0105 14:39:44.473] process 2086 exited with code 0 after 0.0m
I0105 14:39:44.473] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/jobResultsCache.json
I0105 14:39:45.576] process 2087 exited with code 0 after 0.0m
I0105 14:39:45.577] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/jobResultsCache.json#1578191733691795'
... skipping 8 lines ...