This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-01-06 14:31
Elapsed4m0s
Revision
Buildergke-prow-ssd-pool-1a225945-j9hk
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/2a490ab5-e583-4ee5-945f-ea44d90e0ae5/targets/test'}}
pod19506922-3091-11ea-a07b-c6eb1bf16817
resultstorehttps://source.cloud.google.com/results/invocations/2a490ab5-e583-4ee5-945f-ea44d90e0ae5/targets/test
infra-commit6b50e8c07
job-versionv1.18.0-alpha.1.345+e7eed1ad2c0362
pod19506922-3091-11ea-a07b-c6eb1bf16817
revisionv1.18.0-alpha.1.345+e7eed1ad2c0362

Test Failures


Up 1m23s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-jkns-e2e-gce-plugin-gpus --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.345+e7eed1ad2c0362 bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0106 14:31:37.124] process 51 exited with code 0 after 0.0m
I0106 14:31:37.125] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0106 14:31:37.125] Root: /workspace
I0106 14:31:37.125] cd to /workspace
I0106 14:31:37.125] Configure environment...
I0106 14:31:37.126] Call:  git show -s --format=format:%ct HEAD
W0106 14:31:37.135] fatal: not a git repository (or any of the parent directories): .git
I0106 14:31:37.137] process 64 exited with code 128 after 0.0m
W0106 14:31:37.137] Unable to print commit date for HEAD
I0106 14:31:37.139] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0106 14:31:37.807] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0106 14:31:37.964] process 65 exited with code 0 after 0.0m
I0106 14:31:37.965] Call:  gcloud config get-value account
... skipping 426 lines ...
W0106 14:34:36.932] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W0106 14:34:36.933] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W0106 14:34:36.934] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W0106 14:34:36.934] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0106 14:34:36.935] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0106 14:34:36.936] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W0106 14:35:20.546] ERROR: (gcloud.container.clusters.create) ResponseError: code=500, message=Internal error encountered.
W0106 14:35:20.598] 2020/01/06 14:35:20 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-jkns-e2e-gce-plugin-gpus --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.345+e7eed1ad2c0362 bootstrap-e2e' finished in 44.299685388s
W0106 14:35:22.255] 2020/01/06 14:35:22 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0106 14:35:27.553] 2020/01/06 14:35:27 main.go:319: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-jkns-e2e-gce-plugin-gpus --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.345+e7eed1ad2c0362 bootstrap-e2e: exit status 1
W0106 14:35:27.556] Traceback (most recent call last):
W0106 14:35:27.557]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W0106 14:35:27.557]     main(parse_args())
W0106 14:35:27.557]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W0106 14:35:27.558]     mode.start(runner_args)
W0106 14:35:27.558]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0106 14:35:27.558]     check_env(env, self.command, *args)
W0106 14:35:27.558]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0106 14:35:27.558]     subprocess.check_call(cmd, env=env)
W0106 14:35:27.559]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0106 14:35:27.559]     raise CalledProcessError(retcode, cmd)
W0106 14:35:27.560] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/latest', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-b', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-p100,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E0106 14:35:27.565] Command failed
I0106 14:35:27.565] process 272 exited with code 1 after 3.8m
E0106 14:35:27.565] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-p100
I0106 14:35:27.566] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0106 14:35:28.167] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0106 14:35:28.227] process 1395 exited with code 0 after 0.0m
I0106 14:35:28.227] Call:  gcloud config get-value account
I0106 14:35:28.596] process 1408 exited with code 0 after 0.0m
I0106 14:35:28.596] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0106 14:35:28.597] Upload result and artifacts...
I0106 14:35:28.597] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/1214192704146116609
I0106 14:35:28.597] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/1214192704146116609/artifacts
W0106 14:35:29.551] CommandException: One or more URLs matched no objects.
E0106 14:35:29.674] Command failed
I0106 14:35:29.674] process 1421 exited with code 1 after 0.0m
W0106 14:35:29.674] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/1214192704146116609/artifacts not exist yet
I0106 14:35:29.675] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/1214192704146116609/artifacts
I0106 14:35:31.475] process 1566 exited with code 0 after 0.0m
I0106 14:35:31.476] Call:  git rev-parse HEAD
W0106 14:35:31.481] fatal: not a git repository (or any of the parent directories): .git
E0106 14:35:31.481] Command failed
I0106 14:35:31.481] process 2093 exited with code 128 after 0.0m
I0106 14:35:31.482] Call:  git rev-parse HEAD
I0106 14:35:31.486] process 2094 exited with code 0 after 0.0m
I0106 14:35:31.486] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/jobResultsCache.json
I0106 14:35:32.567] process 2095 exited with code 0 after 0.0m
I0106 14:35:32.568] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/jobResultsCache.json#1578278202910490'
... skipping 8 lines ...