This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-01-07 02:31
Elapsed3m32s
Revision
Buildergke-prow-default-pool-cf4891d4-x2jl
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/4c6e67bc-c462-471c-9f8e-80cfbbeb1c75/targets/test'}}
podabe58a95-30f5-11ea-bef5-ca9a35e1927f
resultstorehttps://source.cloud.google.com/results/invocations/4c6e67bc-c462-471c-9f8e-80cfbbeb1c75/targets/test
infra-commit4b65569ab
job-versionv1.18.0-alpha.1.361+d6412b856f2d51
podabe58a95-30f5-11ea-bef5-ca9a35e1927f
revisionv1.18.0-alpha.1.361+d6412b856f2d51

Test Failures


Up 1m32s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-jkns-e2e-gke-gpus-1-7 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.361+d6412b856f2d51 bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0107 02:31:11.299] process 47 exited with code 0 after 0.0m
I0107 02:31:11.300] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0107 02:31:11.300] Root: /workspace
I0107 02:31:11.300] cd to /workspace
I0107 02:31:11.300] Configure environment...
I0107 02:31:11.301] Call:  git show -s --format=format:%ct HEAD
W0107 02:31:11.304] fatal: not a git repository (or any of the parent directories): .git
I0107 02:31:11.304] process 60 exited with code 128 after 0.0m
W0107 02:31:11.304] Unable to print commit date for HEAD
I0107 02:31:11.304] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0107 02:31:11.768] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0107 02:31:12.070] process 61 exited with code 0 after 0.0m
I0107 02:31:12.070] Call:  gcloud config get-value account
... skipping 422 lines ...
W0107 02:33:41.455] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W0107 02:33:41.456] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W0107 02:33:41.456] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W0107 02:33:41.456] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0107 02:33:41.457] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0107 02:33:41.457] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W0107 02:34:22.891] ERROR: (gcloud.container.clusters.create) ResponseError: code=500, message=Internal error encountered.
W0107 02:34:22.971] 2020/01/07 02:34:22 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-jkns-e2e-gke-gpus-1-7 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.361+d6412b856f2d51 bootstrap-e2e' finished in 42.182373953s
W0107 02:34:25.115] 2020/01/07 02:34:25 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0107 02:34:30.414] 2020/01/07 02:34:30 main.go:319: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-jkns-e2e-gke-gpus-1-7 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.361+d6412b856f2d51 bootstrap-e2e: exit status 1
W0107 02:34:30.423] Traceback (most recent call last):
W0107 02:34:30.423]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W0107 02:34:30.423]     main(parse_args())
W0107 02:34:30.424]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W0107 02:34:30.424]     mode.start(runner_args)
W0107 02:34:30.424]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0107 02:34:30.424]     check_env(env, self.command, *args)
W0107 02:34:30.424]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0107 02:34:30.424]     subprocess.check_call(cmd, env=env)
W0107 02:34:30.424]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0107 02:34:30.425]     raise CalledProcessError(retcode, cmd)
W0107 02:34:30.425] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/latest', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-b', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-p100,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E0107 02:34:30.435] Command failed
I0107 02:34:30.435] process 268 exited with code 1 after 3.3m
E0107 02:34:30.435] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-p100
I0107 02:34:30.436] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0107 02:34:31.323] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0107 02:34:31.380] process 1378 exited with code 0 after 0.0m
I0107 02:34:31.381] Call:  gcloud config get-value account
I0107 02:34:31.839] process 1391 exited with code 0 after 0.0m
I0107 02:34:31.839] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0107 02:34:31.840] Upload result and artifacts...
I0107 02:34:31.840] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/1214373766960779268
I0107 02:34:31.840] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/1214373766960779268/artifacts
W0107 02:34:33.366] CommandException: One or more URLs matched no objects.
E0107 02:34:33.580] Command failed
I0107 02:34:33.580] process 1404 exited with code 1 after 0.0m
W0107 02:34:33.580] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/1214373766960779268/artifacts not exist yet
I0107 02:34:33.580] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/1214373766960779268/artifacts
I0107 02:34:36.327] process 1549 exited with code 0 after 0.0m
I0107 02:34:36.328] Call:  git rev-parse HEAD
W0107 02:34:36.335] fatal: not a git repository (or any of the parent directories): .git
E0107 02:34:36.336] Command failed
I0107 02:34:36.336] process 2076 exited with code 128 after 0.0m
I0107 02:34:36.336] Call:  git rev-parse HEAD
I0107 02:34:36.346] process 2077 exited with code 0 after 0.0m
I0107 02:34:36.347] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/jobResultsCache.json
I0107 02:34:38.251] process 2078 exited with code 0 after 0.0m
I0107 02:34:38.252] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/jobResultsCache.json#1578321334892872'
... skipping 8 lines ...