This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-01-07 14:31
Elapsed4m51s
Revision
Buildergke-prow-default-pool-cf4891d4-77hz
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/25676bab-4c43-4413-8a3f-b7e1581c8d28/targets/test'}}
pod41b26849-315a-11ea-bef5-ca9a35e1927f
resultstorehttps://source.cloud.google.com/results/invocations/25676bab-4c43-4413-8a3f-b7e1581c8d28/targets/test
infra-commita8c31a850
job-versionv1.18.0-alpha.1.409+f3df7a2fdb16dd
pod41b26849-315a-11ea-bef5-ca9a35e1927f
revisionv1.18.0-alpha.1.409+f3df7a2fdb16dd

Test Failures


Up 1m38s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-08 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.409+f3df7a2fdb16dd bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0107 14:31:09.601] process 47 exited with code 0 after 0.0m
I0107 14:31:09.601] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0107 14:31:09.601] Root: /workspace
I0107 14:31:09.601] cd to /workspace
I0107 14:31:09.601] Configure environment...
I0107 14:31:09.602] Call:  git show -s --format=format:%ct HEAD
W0107 14:31:09.606] fatal: not a git repository (or any of the parent directories): .git
I0107 14:31:09.606] process 60 exited with code 128 after 0.0m
W0107 14:31:09.606] Unable to print commit date for HEAD
I0107 14:31:09.606] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0107 14:31:10.143] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0107 14:31:10.478] process 61 exited with code 0 after 0.0m
I0107 14:31:10.478] Call:  gcloud config get-value account
... skipping 426 lines ...
W0107 14:34:56.037] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W0107 14:34:56.037] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W0107 14:34:56.038] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W0107 14:34:56.038] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0107 14:34:56.039] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0107 14:34:56.039] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W0107 14:35:42.678] ERROR: (gcloud.container.clusters.create) ResponseError: code=500, message=Internal error encountered.
W0107 14:35:42.726] 2020/01/07 14:35:42 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-08 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.409+f3df7a2fdb16dd bootstrap-e2e' finished in 47.451736646s
W0107 14:35:44.550] 2020/01/07 14:35:44 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0107 14:35:49.655] 2020/01/07 14:35:49 main.go:319: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-08 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.409+f3df7a2fdb16dd bootstrap-e2e: exit status 1
W0107 14:35:49.668] Traceback (most recent call last):
W0107 14:35:49.668]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W0107 14:35:49.669]     main(parse_args())
W0107 14:35:49.669]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W0107 14:35:49.669]     mode.start(runner_args)
W0107 14:35:49.669]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0107 14:35:49.669]     check_env(env, self.command, *args)
W0107 14:35:49.669]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0107 14:35:49.670]     subprocess.check_call(cmd, env=env)
W0107 14:35:49.670]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0107 14:35:49.670]     raise CalledProcessError(retcode, cmd)
W0107 14:35:49.671] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/latest', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-b', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-p100,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E0107 14:35:49.672] Command failed
I0107 14:35:49.672] process 268 exited with code 1 after 4.6m
E0107 14:35:49.673] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-p100
I0107 14:35:49.673] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0107 14:35:50.374] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0107 14:35:50.427] process 1389 exited with code 0 after 0.0m
I0107 14:35:50.428] Call:  gcloud config get-value account
I0107 14:35:50.833] process 1402 exited with code 0 after 0.0m
I0107 14:35:50.834] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0107 14:35:50.834] Upload result and artifacts...
I0107 14:35:50.834] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/1214554962315448324
I0107 14:35:50.835] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/1214554962315448324/artifacts
W0107 14:35:52.181] CommandException: One or more URLs matched no objects.
E0107 14:35:52.394] Command failed
I0107 14:35:52.395] process 1415 exited with code 1 after 0.0m
W0107 14:35:52.395] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/1214554962315448324/artifacts not exist yet
I0107 14:35:52.395] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/1214554962315448324/artifacts
I0107 14:35:54.576] process 1560 exited with code 0 after 0.0m
I0107 14:35:54.577] Call:  git rev-parse HEAD
W0107 14:35:54.586] fatal: not a git repository (or any of the parent directories): .git
E0107 14:35:54.586] Command failed
I0107 14:35:54.586] process 2087 exited with code 128 after 0.0m
I0107 14:35:54.586] Call:  git rev-parse HEAD
I0107 14:35:54.593] process 2088 exited with code 0 after 0.0m
I0107 14:35:54.593] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/jobResultsCache.json
I0107 14:35:56.046] process 2089 exited with code 0 after 0.0m
I0107 14:35:56.047] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/jobResultsCache.json#1578364481937421'
... skipping 8 lines ...