This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-01-08 14:31
Elapsed3m54s
Revision
Buildergke-prow-default-pool-cf4891d4-k4p5
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/a121d47f-044b-410a-9825-b2afb2f9d557/targets/test'}}
pod61c5f8f9-3223-11ea-9709-02f27a93e62e
resultstorehttps://source.cloud.google.com/results/invocations/a121d47f-044b-410a-9825-b2afb2f9d557/targets/test
infra-commit99c2f9ae2
job-versionv1.18.0-alpha.1.469+db1990f48b92d6
pod61c5f8f9-3223-11ea-9709-02f27a93e62e
revisionv1.18.0-alpha.1.469+db1990f48b92d6

Test Failures


Up 1m28s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-04 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.469+db1990f48b92d6 bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0108 14:31:03.365] process 48 exited with code 0 after 0.0m
I0108 14:31:03.365] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0108 14:31:03.365] Root: /workspace
I0108 14:31:03.365] cd to /workspace
I0108 14:31:03.366] Configure environment...
I0108 14:31:03.366] Call:  git show -s --format=format:%ct HEAD
W0108 14:31:03.369] fatal: not a git repository (or any of the parent directories): .git
I0108 14:31:03.370] process 61 exited with code 128 after 0.0m
W0108 14:31:03.370] Unable to print commit date for HEAD
I0108 14:31:03.370] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0108 14:31:03.987] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0108 14:31:04.311] process 62 exited with code 0 after 0.0m
I0108 14:31:04.312] Call:  gcloud config get-value account
... skipping 426 lines ...
W0108 14:33:51.727] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W0108 14:33:51.728] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W0108 14:33:51.729] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W0108 14:33:51.730] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0108 14:33:51.731] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0108 14:33:51.731] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W0108 14:34:34.635] ERROR: (gcloud.container.clusters.create) ResponseError: code=500, message=Internal error encountered.
W0108 14:34:34.693] 2020/01/08 14:34:34 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-04 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.469+db1990f48b92d6 bootstrap-e2e' finished in 43.648780799s
W0108 14:34:36.769] 2020/01/08 14:34:36 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0108 14:34:44.029] 2020/01/08 14:34:44 main.go:316: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-04 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.469+db1990f48b92d6 bootstrap-e2e: exit status 1
W0108 14:34:44.032] Traceback (most recent call last):
W0108 14:34:44.032]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W0108 14:34:44.032]     main(parse_args())
W0108 14:34:44.032]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W0108 14:34:44.032]     mode.start(runner_args)
W0108 14:34:44.033]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0108 14:34:44.033]     check_env(env, self.command, *args)
W0108 14:34:44.033]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0108 14:34:44.033]     subprocess.check_call(cmd, env=env)
W0108 14:34:44.033]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0108 14:34:44.034]     raise CalledProcessError(retcode, cmd)
W0108 14:34:44.034] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/latest', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-b', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-p100,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E0108 14:34:44.047] Command failed
I0108 14:34:44.047] process 269 exited with code 1 after 3.6m
E0108 14:34:44.047] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-p100
I0108 14:34:44.047] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0108 14:34:44.784] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0108 14:34:44.841] process 1390 exited with code 0 after 0.0m
I0108 14:34:44.842] Call:  gcloud config get-value account
I0108 14:34:45.492] process 1403 exited with code 0 after 0.0m
I0108 14:34:45.493] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0108 14:34:45.493] Upload result and artifacts...
I0108 14:34:45.493] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/1214917372394082304
I0108 14:34:45.494] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/1214917372394082304/artifacts
W0108 14:34:46.920] CommandException: One or more URLs matched no objects.
E0108 14:34:47.156] Command failed
I0108 14:34:47.156] process 1416 exited with code 1 after 0.0m
W0108 14:34:47.156] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/1214917372394082304/artifacts not exist yet
I0108 14:34:47.157] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/1214917372394082304/artifacts
I0108 14:34:49.921] process 1561 exited with code 0 after 0.0m
I0108 14:34:49.921] Call:  git rev-parse HEAD
W0108 14:34:49.929] fatal: not a git repository (or any of the parent directories): .git
E0108 14:34:49.929] Command failed
I0108 14:34:49.929] process 2088 exited with code 128 after 0.0m
I0108 14:34:49.929] Call:  git rev-parse HEAD
I0108 14:34:49.950] process 2089 exited with code 0 after 0.0m
I0108 14:34:49.950] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/jobResultsCache.json
I0108 14:34:51.864] process 2090 exited with code 0 after 0.0m
I0108 14:34:51.865] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/jobResultsCache.json#1578450866633717'
... skipping 8 lines ...