This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-01-09 02:31
Elapsed4m15s
Revision
Buildergke-prow-default-pool-cf4891d4-dz93
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/7342a572-3414-41be-976f-500a374c53ab/targets/test'}}
podf6b02abb-3287-11ea-9709-02f27a93e62e
resultstorehttps://source.cloud.google.com/results/invocations/7342a572-3414-41be-976f-500a374c53ab/targets/test
infra-commit2ba537aec
job-versionv1.18.0-alpha.1.495+2bd9f5737a6cd9
podf6b02abb-3287-11ea-9709-02f27a93e62e
revisionv1.18.0-alpha.1.495+2bd9f5737a6cd9

Test Failures


Up 1m28s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-jkns-e2e-gke-gpus --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.495+2bd9f5737a6cd9 bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0109 02:31:30.813] process 47 exited with code 0 after 0.0m
I0109 02:31:30.813] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0109 02:31:30.814] Root: /workspace
I0109 02:31:30.814] cd to /workspace
I0109 02:31:30.814] Configure environment...
I0109 02:31:30.814] Call:  git show -s --format=format:%ct HEAD
W0109 02:31:30.819] fatal: not a git repository (or any of the parent directories): .git
I0109 02:31:30.819] process 60 exited with code 128 after 0.0m
W0109 02:31:30.819] Unable to print commit date for HEAD
I0109 02:31:30.820] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0109 02:31:31.534] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0109 02:31:31.909] process 61 exited with code 0 after 0.0m
I0109 02:31:31.910] Call:  gcloud config get-value account
... skipping 422 lines ...
W0109 02:34:31.652] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W0109 02:34:31.652] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W0109 02:34:31.653] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W0109 02:34:31.653] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0109 02:34:31.653] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0109 02:34:31.654] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W0109 02:35:13.478] ERROR: (gcloud.container.clusters.create) ResponseError: code=500, message=Internal error encountered.
W0109 02:35:13.539] 2020/01/09 02:35:13 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-jkns-e2e-gke-gpus --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.495+2bd9f5737a6cd9 bootstrap-e2e' finished in 42.463426461s
W0109 02:35:15.403] 2020/01/09 02:35:15 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0109 02:35:36.116] 2020/01/09 02:35:36 main.go:316: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-jkns-e2e-gke-gpus --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.495+2bd9f5737a6cd9 bootstrap-e2e: exit status 1
W0109 02:35:36.124] Traceback (most recent call last):
W0109 02:35:36.125]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W0109 02:35:36.125]     main(parse_args())
W0109 02:35:36.125]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W0109 02:35:36.125]     mode.start(runner_args)
W0109 02:35:36.126]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0109 02:35:36.126]     check_env(env, self.command, *args)
W0109 02:35:36.126]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0109 02:35:36.126]     subprocess.check_call(cmd, env=env)
W0109 02:35:36.126]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0109 02:35:36.126]     raise CalledProcessError(retcode, cmd)
W0109 02:35:36.127] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/latest', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-b', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-p100,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E0109 02:35:36.138] Command failed
I0109 02:35:36.138] process 268 exited with code 1 after 4.0m
E0109 02:35:36.139] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-p100
I0109 02:35:36.139] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0109 02:35:36.748] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0109 02:35:36.809] process 1378 exited with code 0 after 0.0m
I0109 02:35:36.810] Call:  gcloud config get-value account
I0109 02:35:37.222] process 1391 exited with code 0 after 0.0m
I0109 02:35:37.223] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0109 02:35:37.223] Upload result and artifacts...
I0109 02:35:37.223] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/1215098568256262150
I0109 02:35:37.224] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/1215098568256262150/artifacts
W0109 02:35:38.291] CommandException: One or more URLs matched no objects.
E0109 02:35:38.441] Command failed
I0109 02:35:38.441] process 1404 exited with code 1 after 0.0m
W0109 02:35:38.441] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/1215098568256262150/artifacts not exist yet
I0109 02:35:38.442] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/1215098568256262150/artifacts
I0109 02:35:40.511] process 1549 exited with code 0 after 0.0m
I0109 02:35:40.512] Call:  git rev-parse HEAD
W0109 02:35:40.519] fatal: not a git repository (or any of the parent directories): .git
E0109 02:35:40.519] Command failed
I0109 02:35:40.519] process 2076 exited with code 128 after 0.0m
I0109 02:35:40.520] Call:  git rev-parse HEAD
I0109 02:35:40.528] process 2077 exited with code 0 after 0.0m
I0109 02:35:40.528] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/jobResultsCache.json
I0109 02:35:41.785] process 2078 exited with code 0 after 0.0m
I0109 02:35:41.786] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/jobResultsCache.json#1578494095995647'
... skipping 8 lines ...