This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-01-10 02:31
Elapsed4m21s
Revision
Buildergke-prow-default-pool-cf4891d4-k4p5
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/7b5ed5d3-8297-4e41-988f-edd794f86016/targets/test'}}
pod336e062e-3351-11ea-a4dc-8213d962824c
resultstorehttps://source.cloud.google.com/results/invocations/7b5ed5d3-8297-4e41-988f-edd794f86016/targets/test
infra-commit305f42b93
job-versionv1.18.0-alpha.1.554+da9fdc933b3ac3
pod336e062e-3351-11ea-a4dc-8213d962824c
revisionv1.18.0-alpha.1.554+da9fdc933b3ac3

Test Failures


Up 1m26s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-07 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.554+da9fdc933b3ac3 bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0110 02:31:36.875] process 47 exited with code 0 after 0.0m
I0110 02:31:36.875] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0110 02:31:36.875] Root: /workspace
I0110 02:31:36.875] cd to /workspace
I0110 02:31:36.876] Configure environment...
I0110 02:31:36.876] Call:  git show -s --format=format:%ct HEAD
W0110 02:31:36.879] fatal: not a git repository (or any of the parent directories): .git
I0110 02:31:36.880] process 60 exited with code 128 after 0.0m
W0110 02:31:36.880] Unable to print commit date for HEAD
I0110 02:31:36.880] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0110 02:31:37.367] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0110 02:31:37.698] process 61 exited with code 0 after 0.0m
I0110 02:31:37.698] Call:  gcloud config get-value account
... skipping 426 lines ...
W0110 02:34:48.460] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W0110 02:34:48.461] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W0110 02:34:48.461] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W0110 02:34:48.462] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0110 02:34:48.462] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0110 02:34:48.462] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W0110 02:35:34.435] ERROR: (gcloud.container.clusters.create) ResponseError: code=500, message=Internal error encountered.
W0110 02:35:34.476] 2020/01/10 02:35:34 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-07 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.554+da9fdc933b3ac3 bootstrap-e2e' finished in 46.423499957s
W0110 02:35:35.969] 2020/01/10 02:35:35 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0110 02:35:50.592] 2020/01/10 02:35:50 main.go:316: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-07 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.554+da9fdc933b3ac3 bootstrap-e2e: exit status 1
W0110 02:35:50.595] Traceback (most recent call last):
W0110 02:35:50.596]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W0110 02:35:50.597]     main(parse_args())
W0110 02:35:50.597]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W0110 02:35:50.597]     mode.start(runner_args)
W0110 02:35:50.597]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0110 02:35:50.597]     check_env(env, self.command, *args)
W0110 02:35:50.597]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0110 02:35:50.598]     subprocess.check_call(cmd, env=env)
W0110 02:35:50.598]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0110 02:35:50.598]     raise CalledProcessError(retcode, cmd)
W0110 02:35:50.599] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/latest', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-b', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-p100,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E0110 02:35:50.611] Command failed
I0110 02:35:50.611] process 268 exited with code 1 after 4.2m
E0110 02:35:50.611] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-p100
I0110 02:35:50.611] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0110 02:35:51.259] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0110 02:35:51.311] process 1390 exited with code 0 after 0.0m
I0110 02:35:51.312] Call:  gcloud config get-value account
I0110 02:35:51.661] process 1403 exited with code 0 after 0.0m
I0110 02:35:51.661] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0110 02:35:51.661] Upload result and artifacts...
I0110 02:35:51.662] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/1215461092772286468
I0110 02:35:51.662] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/1215461092772286468/artifacts
W0110 02:35:52.551] CommandException: One or more URLs matched no objects.
E0110 02:35:52.664] Command failed
I0110 02:35:52.664] process 1416 exited with code 1 after 0.0m
W0110 02:35:52.665] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/1215461092772286468/artifacts not exist yet
I0110 02:35:52.665] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/1215461092772286468/artifacts
I0110 02:35:54.229] process 1561 exited with code 0 after 0.0m
I0110 02:35:54.229] Call:  git rev-parse HEAD
W0110 02:35:54.233] fatal: not a git repository (or any of the parent directories): .git
E0110 02:35:54.233] Command failed
I0110 02:35:54.233] process 2088 exited with code 128 after 0.0m
I0110 02:35:54.234] Call:  git rev-parse HEAD
I0110 02:35:54.240] process 2089 exited with code 0 after 0.0m
I0110 02:35:54.240] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/jobResultsCache.json
I0110 02:35:55.128] process 2090 exited with code 0 after 0.0m
I0110 02:35:55.129] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/jobResultsCache.json#1578580501844295'
... skipping 8 lines ...