This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-01-10 14:31
Elapsed3m41s
Revision
Buildergke-prow-default-pool-cf4891d4-nq59
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/97b53f61-da2f-4da4-ac71-b2f8d111ac30/targets/test'}}
podc96d821e-33b5-11ea-a4dc-8213d962824c
resultstorehttps://source.cloud.google.com/results/invocations/97b53f61-da2f-4da4-ac71-b2f8d111ac30/targets/test
infra-commit348fdc86a
job-versionv1.18.0-alpha.1.570+e3f90df767aefd
podc96d821e-33b5-11ea-a4dc-8213d962824c
revisionv1.18.0-alpha.1.570+e3f90df767aefd

Test Failures


Up 1m13s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-10 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.570+e3f90df767aefd bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0110 14:31:36.696] process 47 exited with code 0 after 0.0m
I0110 14:31:36.697] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0110 14:31:36.697] Root: /workspace
I0110 14:31:36.697] cd to /workspace
I0110 14:31:36.697] Configure environment...
I0110 14:31:36.698] Call:  git show -s --format=format:%ct HEAD
W0110 14:31:36.702] fatal: not a git repository (or any of the parent directories): .git
I0110 14:31:36.703] process 60 exited with code 128 after 0.0m
W0110 14:31:36.703] Unable to print commit date for HEAD
I0110 14:31:36.703] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0110 14:31:37.257] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0110 14:31:37.583] process 61 exited with code 0 after 0.0m
I0110 14:31:37.584] Call:  gcloud config get-value account
... skipping 426 lines ...
W0110 14:34:09.126] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W0110 14:34:09.126] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W0110 14:34:09.127] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W0110 14:34:09.127] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0110 14:34:09.127] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0110 14:34:09.127] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W0110 14:34:48.463] ERROR: (gcloud.container.clusters.create) ResponseError: code=500, message=Internal error encountered.
W0110 14:34:48.517] 2020/01/10 14:34:48 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-10 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.570+e3f90df767aefd bootstrap-e2e' finished in 39.893958334s
W0110 14:34:50.191] 2020/01/10 14:34:50 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0110 14:35:08.384] 2020/01/10 14:35:08 main.go:316: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-10 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.570+e3f90df767aefd bootstrap-e2e: exit status 1
W0110 14:35:08.393] Traceback (most recent call last):
W0110 14:35:08.393]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W0110 14:35:08.394]     main(parse_args())
W0110 14:35:08.394]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W0110 14:35:08.394]     mode.start(runner_args)
W0110 14:35:08.394]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0110 14:35:08.395]     check_env(env, self.command, *args)
W0110 14:35:08.395]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0110 14:35:08.395]     subprocess.check_call(cmd, env=env)
W0110 14:35:08.395]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0110 14:35:08.395]     raise CalledProcessError(retcode, cmd)
W0110 14:35:08.396] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/latest', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-b', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-p100,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E0110 14:35:08.405] Command failed
I0110 14:35:08.406] process 268 exited with code 1 after 3.5m
E0110 14:35:08.406] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-p100
I0110 14:35:08.406] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0110 14:35:09.018] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0110 14:35:09.088] process 1391 exited with code 0 after 0.0m
I0110 14:35:09.088] Call:  gcloud config get-value account
I0110 14:35:09.460] process 1404 exited with code 0 after 0.0m
I0110 14:35:09.460] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0110 14:35:09.460] Upload result and artifacts...
I0110 14:35:09.460] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/1215642287795605512
I0110 14:35:09.461] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/1215642287795605512/artifacts
W0110 14:35:10.517] CommandException: One or more URLs matched no objects.
E0110 14:35:10.662] Command failed
I0110 14:35:10.662] process 1417 exited with code 1 after 0.0m
W0110 14:35:10.662] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/1215642287795605512/artifacts not exist yet
I0110 14:35:10.663] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/1215642287795605512/artifacts
I0110 14:35:12.443] process 1562 exited with code 0 after 0.0m
I0110 14:35:12.444] Call:  git rev-parse HEAD
W0110 14:35:12.448] fatal: not a git repository (or any of the parent directories): .git
E0110 14:35:12.449] Command failed
I0110 14:35:12.449] process 2089 exited with code 128 after 0.0m
I0110 14:35:12.449] Call:  git rev-parse HEAD
I0110 14:35:12.454] process 2090 exited with code 0 after 0.0m
I0110 14:35:12.455] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/jobResultsCache.json
I0110 14:35:13.515] process 2091 exited with code 0 after 0.0m
I0110 14:35:13.516] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/jobResultsCache.json#1578623756976634'
... skipping 8 lines ...