This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-01-11 14:31
Elapsed3m40s
Revision
Buildergke-prow-default-pool-cf4891d4-j0wd
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/202f4d81-2176-4ca5-b3fb-8567953aa3a9/targets/test'}}
podeb0b9dbe-347e-11ea-9fef-d200904e1a96
resultstorehttps://source.cloud.google.com/results/invocations/202f4d81-2176-4ca5-b3fb-8567953aa3a9/targets/test
infra-commitb82ca85d5
job-versionv1.18.0-alpha.1.624+7f2128757b1aa2
podeb0b9dbe-347e-11ea-9fef-d200904e1a96
revisionv1.18.0-alpha.1.624+7f2128757b1aa2

Test Failures


Up 1m50s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-03 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.624+7f2128757b1aa2 bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0111 14:31:10.488] process 47 exited with code 0 after 0.0m
I0111 14:31:10.488] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0111 14:31:10.489] Root: /workspace
I0111 14:31:10.489] cd to /workspace
I0111 14:31:10.489] Configure environment...
I0111 14:31:10.489] Call:  git show -s --format=format:%ct HEAD
W0111 14:31:10.494] fatal: not a git repository (or any of the parent directories): .git
I0111 14:31:10.494] process 60 exited with code 128 after 0.0m
W0111 14:31:10.494] Unable to print commit date for HEAD
I0111 14:31:10.495] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0111 14:31:11.053] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0111 14:31:11.373] process 61 exited with code 0 after 0.0m
I0111 14:31:11.373] Call:  gcloud config get-value account
... skipping 426 lines ...
W0111 14:33:55.443] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W0111 14:33:55.443] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W0111 14:33:55.444] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W0111 14:33:55.444] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0111 14:33:55.444] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0111 14:33:55.444] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W0111 14:34:39.831] ERROR: (gcloud.container.clusters.create) ResponseError: code=500, message=Internal error encountered.
W0111 14:34:39.878] 2020/01/11 14:34:39 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-03 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.624+7f2128757b1aa2 bootstrap-e2e' finished in 44.874875695s
W0111 14:34:41.499] 2020/01/11 14:34:41 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0111 14:34:42.890] 2020/01/11 14:34:42 main.go:316: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-03 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.624+7f2128757b1aa2 bootstrap-e2e: exit status 1
W0111 14:34:42.897] Traceback (most recent call last):
W0111 14:34:42.897]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W0111 14:34:42.897]     main(parse_args())
W0111 14:34:42.897]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W0111 14:34:42.898]     mode.start(runner_args)
W0111 14:34:42.898]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0111 14:34:42.898]     check_env(env, self.command, *args)
W0111 14:34:42.898]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0111 14:34:42.898]     subprocess.check_call(cmd, env=env)
W0111 14:34:42.898]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0111 14:34:42.898]     raise CalledProcessError(retcode, cmd)
W0111 14:34:42.899] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/latest', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-b', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-p100,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E0111 14:34:42.908] Command failed
I0111 14:34:42.908] process 268 exited with code 1 after 3.5m
E0111 14:34:42.908] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-p100
I0111 14:34:42.908] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0111 14:34:43.423] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0111 14:34:43.476] process 1392 exited with code 0 after 0.0m
I0111 14:34:43.476] Call:  gcloud config get-value account
I0111 14:34:43.779] process 1405 exited with code 0 after 0.0m
I0111 14:34:43.779] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0111 14:34:43.779] Upload result and artifacts...
I0111 14:34:43.779] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/1216004569968939010
I0111 14:34:43.780] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/1216004569968939010/artifacts
W0111 14:34:44.588] CommandException: One or more URLs matched no objects.
E0111 14:34:44.701] Command failed
I0111 14:34:44.702] process 1418 exited with code 1 after 0.0m
W0111 14:34:44.702] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/1216004569968939010/artifacts not exist yet
I0111 14:34:44.702] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/1216004569968939010/artifacts
I0111 14:34:46.157] process 1563 exited with code 0 after 0.0m
I0111 14:34:46.158] Call:  git rev-parse HEAD
W0111 14:34:46.162] fatal: not a git repository (or any of the parent directories): .git
E0111 14:34:46.162] Command failed
I0111 14:34:46.162] process 2090 exited with code 128 after 0.0m
I0111 14:34:46.163] Call:  git rev-parse HEAD
I0111 14:34:46.167] process 2091 exited with code 0 after 0.0m
I0111 14:34:46.167] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/jobResultsCache.json
I0111 14:34:47.100] process 2092 exited with code 0 after 0.0m
I0111 14:34:47.101] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/jobResultsCache.json#1578710157262136'
... skipping 8 lines ...