This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-01-12 14:31
Elapsed3m9s
Revision
Buildergke-prow-default-pool-cf4891d4-f13q
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/64e453d2-6e84-442f-9e2e-22f45597fe88/targets/test'}}
pod141509fd-3548-11ea-9fef-d200904e1a96
resultstorehttps://source.cloud.google.com/results/invocations/64e453d2-6e84-442f-9e2e-22f45597fe88/targets/test
infra-commitd4d25daf0
job-versionv1.18.0-alpha.1.631+4a55a5557ec380
pod141509fd-3548-11ea-9fef-d200904e1a96
revisionv1.18.0-alpha.1.631+4a55a5557ec380

Test Failures


Up 1m28s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-jkns-e2e-gce-gpus --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.631+4a55a5557ec380 bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0112 14:31:07.687] process 47 exited with code 0 after 0.0m
I0112 14:31:07.687] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0112 14:31:07.688] Root: /workspace
I0112 14:31:07.688] cd to /workspace
I0112 14:31:07.688] Configure environment...
I0112 14:31:07.688] Call:  git show -s --format=format:%ct HEAD
W0112 14:31:07.692] fatal: not a git repository (or any of the parent directories): .git
I0112 14:31:07.692] process 60 exited with code 128 after 0.0m
W0112 14:31:07.692] Unable to print commit date for HEAD
I0112 14:31:07.693] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0112 14:31:08.148] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0112 14:31:08.456] process 61 exited with code 0 after 0.0m
I0112 14:31:08.456] Call:  gcloud config get-value account
... skipping 426 lines ...
W0112 14:33:16.184] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W0112 14:33:16.185] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W0112 14:33:16.185] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W0112 14:33:16.185] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0112 14:33:16.186] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0112 14:33:16.186] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W0112 14:34:04.727] ERROR: (gcloud.container.clusters.create) ResponseError: code=500, message=Internal error encountered.
W0112 14:34:04.774] 2020/01/12 14:34:04 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-jkns-e2e-gce-gpus --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.631+4a55a5557ec380 bootstrap-e2e' finished in 49.007968602s
W0112 14:34:06.217] 2020/01/12 14:34:06 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0112 14:34:09.443] 2020/01/12 14:34:09 main.go:316: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-jkns-e2e-gce-gpus --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.631+4a55a5557ec380 bootstrap-e2e: exit status 1
W0112 14:34:09.450] Traceback (most recent call last):
W0112 14:34:09.450]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W0112 14:34:09.450]     main(parse_args())
W0112 14:34:09.451]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W0112 14:34:09.451]     mode.start(runner_args)
W0112 14:34:09.451]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0112 14:34:09.451]     check_env(env, self.command, *args)
W0112 14:34:09.451]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0112 14:34:09.452]     subprocess.check_call(cmd, env=env)
W0112 14:34:09.452]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0112 14:34:09.452]     raise CalledProcessError(retcode, cmd)
W0112 14:34:09.453] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/latest', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-b', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-p100,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E0112 14:34:09.461] Command failed
I0112 14:34:09.462] process 268 exited with code 1 after 3.0m
E0112 14:34:09.462] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-p100
I0112 14:34:09.462] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0112 14:34:09.930] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0112 14:34:09.977] process 1391 exited with code 0 after 0.0m
I0112 14:34:09.977] Call:  gcloud config get-value account
I0112 14:34:10.271] process 1404 exited with code 0 after 0.0m
I0112 14:34:10.272] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0112 14:34:10.272] Upload result and artifacts...
I0112 14:34:10.272] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/1216366949001334790
I0112 14:34:10.272] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/1216366949001334790/artifacts
W0112 14:34:11.066] CommandException: One or more URLs matched no objects.
E0112 14:34:11.175] Command failed
I0112 14:34:11.176] process 1417 exited with code 1 after 0.0m
W0112 14:34:11.176] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/1216366949001334790/artifacts not exist yet
I0112 14:34:11.176] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/1216366949001334790/artifacts
I0112 14:34:12.554] process 1562 exited with code 0 after 0.0m
I0112 14:34:12.554] Call:  git rev-parse HEAD
W0112 14:34:12.559] fatal: not a git repository (or any of the parent directories): .git
E0112 14:34:12.559] Command failed
I0112 14:34:12.559] process 2089 exited with code 128 after 0.0m
I0112 14:34:12.559] Call:  git rev-parse HEAD
I0112 14:34:12.563] process 2090 exited with code 0 after 0.0m
I0112 14:34:12.563] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/jobResultsCache.json
I0112 14:34:13.414] process 2091 exited with code 0 after 0.0m
I0112 14:34:13.415] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/jobResultsCache.json#1578796474842099'
... skipping 8 lines ...