This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-01-13 02:31
Elapsed3m34s
Revision
Buildergke-prow-default-pool-cf4891d4-q50p
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/282dd915-4169-4d93-b6fe-02b9e819a004/targets/test'}}
poda912d489-35ac-11ea-9fef-d200904e1a96
resultstorehttps://source.cloud.google.com/results/invocations/282dd915-4169-4d93-b6fe-02b9e819a004/targets/test
infra-commit5b37d6c80
job-versionv1.18.0-alpha.1.634+36e40fb8502930
poda912d489-35ac-11ea-9fef-d200904e1a96
revisionv1.18.0-alpha.1.634+36e40fb8502930

Test Failures


Up 1m38s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-03 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.634+36e40fb8502930 bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0113 02:31:10.782] process 47 exited with code 0 after 0.0m
I0113 02:31:10.782] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0113 02:31:10.783] Root: /workspace
I0113 02:31:10.783] cd to /workspace
I0113 02:31:10.783] Configure environment...
I0113 02:31:10.784] Call:  git show -s --format=format:%ct HEAD
W0113 02:31:10.789] fatal: not a git repository (or any of the parent directories): .git
I0113 02:31:10.789] process 60 exited with code 128 after 0.0m
W0113 02:31:10.790] Unable to print commit date for HEAD
I0113 02:31:10.790] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0113 02:31:11.376] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0113 02:31:11.736] process 61 exited with code 0 after 0.0m
I0113 02:31:11.736] Call:  gcloud config get-value account
... skipping 426 lines ...
W0113 02:33:39.786] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W0113 02:33:39.786] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W0113 02:33:39.787] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W0113 02:33:39.787] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0113 02:33:39.787] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0113 02:33:39.788] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W0113 02:34:27.204] ERROR: (gcloud.container.clusters.create) ResponseError: code=500, message=Internal error encountered.
W0113 02:34:27.318] 2020/01/13 02:34:27 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-03 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.634+36e40fb8502930 bootstrap-e2e' finished in 48.023957132s
W0113 02:34:30.047] 2020/01/13 02:34:30 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0113 02:34:35.126] 2020/01/13 02:34:35 main.go:316: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-03 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.634+36e40fb8502930 bootstrap-e2e: exit status 1
W0113 02:34:35.131] Traceback (most recent call last):
W0113 02:34:35.131]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W0113 02:34:35.132]     main(parse_args())
W0113 02:34:35.132]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W0113 02:34:35.132]     mode.start(runner_args)
W0113 02:34:35.132]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0113 02:34:35.133]     check_env(env, self.command, *args)
W0113 02:34:35.133]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0113 02:34:35.133]     subprocess.check_call(cmd, env=env)
W0113 02:34:35.133]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0113 02:34:35.133]     raise CalledProcessError(retcode, cmd)
W0113 02:34:35.134] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/latest', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-b', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-p100,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E0113 02:34:35.145] Command failed
I0113 02:34:35.145] process 268 exited with code 1 after 3.4m
E0113 02:34:35.145] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-p100
I0113 02:34:35.146] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0113 02:34:35.758] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0113 02:34:35.825] process 1391 exited with code 0 after 0.0m
I0113 02:34:35.825] Call:  gcloud config get-value account
I0113 02:34:36.218] process 1404 exited with code 0 after 0.0m
I0113 02:34:36.219] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0113 02:34:36.219] Upload result and artifacts...
I0113 02:34:36.219] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/1216548139935207424
I0113 02:34:36.220] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/1216548139935207424/artifacts
W0113 02:34:37.191] CommandException: One or more URLs matched no objects.
E0113 02:34:37.317] Command failed
I0113 02:34:37.318] process 1417 exited with code 1 after 0.0m
W0113 02:34:37.318] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/1216548139935207424/artifacts not exist yet
I0113 02:34:37.318] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/1216548139935207424/artifacts
I0113 02:34:39.079] process 1562 exited with code 0 after 0.0m
I0113 02:34:39.080] Call:  git rev-parse HEAD
W0113 02:34:39.085] fatal: not a git repository (or any of the parent directories): .git
E0113 02:34:39.085] Command failed
I0113 02:34:39.085] process 2089 exited with code 128 after 0.0m
I0113 02:34:39.086] Call:  git rev-parse HEAD
I0113 02:34:39.090] process 2090 exited with code 0 after 0.0m
I0113 02:34:39.091] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/jobResultsCache.json
I0113 02:34:40.254] process 2091 exited with code 0 after 0.0m
I0113 02:34:40.255] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/jobResultsCache.json#1578839655356088'
... skipping 8 lines ...