This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-01-14 14:31
Elapsed3m53s
Revision
Buildergke-prow-default-pool-cf4891d4-k31k
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/1e80324c-f67a-4818-b8d8-0d3c0295d73d/targets/test'}}
pod6cd0e0ee-36da-11ea-9f20-3687633bf296
resultstorehttps://source.cloud.google.com/results/invocations/1e80324c-f67a-4818-b8d8-0d3c0295d73d/targets/test
infra-commitcdb2ca604
job-versionv1.18.0-alpha.1.675+be26fbc638ff5e
pod6cd0e0ee-36da-11ea-9f20-3687633bf296
revisionv1.18.0-alpha.1.675+be26fbc638ff5e

Test Failures


Up 1m24s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-05 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.675+be26fbc638ff5e bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0114 14:31:23.350] process 47 exited with code 0 after 0.0m
I0114 14:31:23.351] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0114 14:31:23.351] Root: /workspace
I0114 14:31:23.351] cd to /workspace
I0114 14:31:23.351] Configure environment...
I0114 14:31:23.352] Call:  git show -s --format=format:%ct HEAD
W0114 14:31:23.356] fatal: not a git repository (or any of the parent directories): .git
I0114 14:31:23.356] process 60 exited with code 128 after 0.0m
W0114 14:31:23.356] Unable to print commit date for HEAD
I0114 14:31:23.357] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0114 14:31:23.920] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0114 14:31:24.269] process 61 exited with code 0 after 0.0m
I0114 14:31:24.269] Call:  gcloud config get-value account
... skipping 426 lines ...
W0114 14:34:13.599] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W0114 14:34:13.600] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W0114 14:34:13.600] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W0114 14:34:13.600] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0114 14:34:13.601] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0114 14:34:13.601] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W0114 14:34:57.793] ERROR: (gcloud.container.clusters.create) ResponseError: code=500, message=Internal error encountered.
W0114 14:34:57.853] 2020/01/14 14:34:57 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-05 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.675+be26fbc638ff5e bootstrap-e2e' finished in 44.720803627s
W0114 14:34:59.496] 2020/01/14 14:34:59 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0114 14:35:07.366] 2020/01/14 14:35:07 main.go:316: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-05 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.675+be26fbc638ff5e bootstrap-e2e: exit status 1
W0114 14:35:07.372] Traceback (most recent call last):
W0114 14:35:07.372]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W0114 14:35:07.372]     main(parse_args())
W0114 14:35:07.372]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W0114 14:35:07.372]     mode.start(runner_args)
W0114 14:35:07.373]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0114 14:35:07.373]     check_env(env, self.command, *args)
W0114 14:35:07.373]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0114 14:35:07.373]     subprocess.check_call(cmd, env=env)
W0114 14:35:07.373]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0114 14:35:07.373]     raise CalledProcessError(retcode, cmd)
W0114 14:35:07.374] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/latest', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-b', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-p100,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E0114 14:35:07.383] Command failed
I0114 14:35:07.384] process 268 exited with code 1 after 3.7m
E0114 14:35:07.384] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-p100
I0114 14:35:07.384] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0114 14:35:07.926] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0114 14:35:07.981] process 1391 exited with code 0 after 0.0m
I0114 14:35:07.981] Call:  gcloud config get-value account
I0114 14:35:08.326] process 1404 exited with code 0 after 0.0m
I0114 14:35:08.327] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0114 14:35:08.327] Upload result and artifacts...
I0114 14:35:08.327] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/1217091746974928908
I0114 14:35:08.327] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/1217091746974928908/artifacts
W0114 14:35:09.282] CommandException: One or more URLs matched no objects.
E0114 14:35:09.419] Command failed
I0114 14:35:09.420] process 1417 exited with code 1 after 0.0m
W0114 14:35:09.420] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/1217091746974928908/artifacts not exist yet
I0114 14:35:09.420] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/1217091746974928908/artifacts
I0114 14:35:11.355] process 1562 exited with code 0 after 0.0m
I0114 14:35:11.355] Call:  git rev-parse HEAD
W0114 14:35:11.360] fatal: not a git repository (or any of the parent directories): .git
E0114 14:35:11.361] Command failed
I0114 14:35:11.361] process 2089 exited with code 128 after 0.0m
I0114 14:35:11.361] Call:  git rev-parse HEAD
I0114 14:35:11.366] process 2090 exited with code 0 after 0.0m
I0114 14:35:11.366] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/jobResultsCache.json
I0114 14:35:12.436] process 2091 exited with code 0 after 0.0m
I0114 14:35:12.437] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/jobResultsCache.json#1578969369428508'
... skipping 8 lines ...