This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-01-16 02:30
Elapsed3m30s
Revision
Buildergke-prow-default-pool-cf4891d4-7vfm
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/394508b3-5b47-4ec4-8917-abca9dd329b2/targets/test'}}
pod1c796ad4-3808-11ea-8f3e-66e48c863062
resultstorehttps://source.cloud.google.com/results/invocations/394508b3-5b47-4ec4-8917-abca9dd329b2/targets/test
infra-commit70a5174aa
job-versionv1.18.0-alpha.1.789+5d1c3016103d83
pod1c796ad4-3808-11ea-8f3e-66e48c863062
revisionv1.18.0-alpha.1.789+5d1c3016103d83

Test Failures


Up 40s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-10 --zone=us-west1-c --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.789+5d1c3016103d83 bootstrap-e2e: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0116 02:30:50.808] process 47 exited with code 0 after 0.0m
I0116 02:30:50.809] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0116 02:30:50.809] Root: /workspace
I0116 02:30:50.809] cd to /workspace
I0116 02:30:50.809] Configure environment...
I0116 02:30:50.810] Call:  git show -s --format=format:%ct HEAD
W0116 02:30:50.816] fatal: not a git repository (or any of the parent directories): .git
I0116 02:30:50.817] process 60 exited with code 128 after 0.0m
W0116 02:30:50.817] Unable to print commit date for HEAD
I0116 02:30:50.817] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0116 02:30:51.677] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0116 02:30:52.033] process 61 exited with code 0 after 0.0m
I0116 02:30:52.034] Call:  gcloud config get-value account
... skipping 426 lines ...
W0116 02:33:58.926] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W0116 02:33:58.926] WARNING: Newly created clusters and node-pools will have node auto-upgrade enabled by default. This can be disabled using the `--no-enable-autoupgrade` flag.
W0116 02:33:58.927] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W0116 02:33:58.927] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0116 02:33:58.927] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0116 02:33:58.927] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W0116 02:33:59.052] ERROR: (gcloud.container.clusters.create) ResponseError: code=400, message=Location "us-west1-c" does not exist.
W0116 02:33:59.129] 2020/01/16 02:33:59 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-10 --zone=us-west1-c --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.789+5d1c3016103d83 bootstrap-e2e' finished in 984.055869ms
W0116 02:34:00.861] 2020/01/16 02:34:00 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0116 02:34:05.920] 2020/01/16 02:34:05 main.go:316: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-p100,count=2 --project=k8s-gke-gpu-boskos-10 --zone=us-west1-c --machine-type=n1-standard-2 --image-type=gci --num-nodes=3 --network=bootstrap-e2e --cluster-version=1.18.0-alpha.1.789+5d1c3016103d83 bootstrap-e2e: exit status 1
W0116 02:34:05.923] Traceback (most recent call last):
W0116 02:34:05.924]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W0116 02:34:05.924]     main(parse_args())
W0116 02:34:05.924]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W0116 02:34:05.924]     mode.start(runner_args)
W0116 02:34:05.924]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0116 02:34:05.925]     check_env(env, self.command, *args)
W0116 02:34:05.925]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0116 02:34:05.925]     subprocess.check_call(cmd, env=env)
W0116 02:34:05.925]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0116 02:34:05.925]     raise CalledProcessError(retcode, cmd)
W0116 02:34:05.926] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--check-leaked-resources', '--extract=ci/latest', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gcp-node-image=gci', '--gcp-project-type=gpu-project', '--gcp-zone=us-west1-c', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-p100,count=2', '--gke-environment=test', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--timeout=180m')' returned non-zero exit status 1
E0116 02:34:05.933] Command failed
I0116 02:34:05.933] process 268 exited with code 1 after 3.2m
E0116 02:34:05.934] FAIL: ci-kubernetes-e2e-gke-device-plugin-gpu-p100
I0116 02:34:05.934] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0116 02:34:06.744] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0116 02:34:06.804] process 1389 exited with code 0 after 0.0m
I0116 02:34:06.812] Call:  gcloud config get-value account
I0116 02:34:07.451] process 1402 exited with code 0 after 0.0m
I0116 02:34:07.451] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0116 02:34:07.452] Upload result and artifacts...
I0116 02:34:07.452] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/1217635223739568130
I0116 02:34:07.452] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/1217635223739568130/artifacts
W0116 02:34:09.164] CommandException: One or more URLs matched no objects.
E0116 02:34:09.440] Command failed
I0116 02:34:09.441] process 1415 exited with code 1 after 0.0m
W0116 02:34:09.441] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/1217635223739568130/artifacts not exist yet
I0116 02:34:09.441] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/1217635223739568130/artifacts
I0116 02:34:12.465] process 1560 exited with code 0 after 0.1m
I0116 02:34:12.465] Call:  git rev-parse HEAD
W0116 02:34:12.480] fatal: not a git repository (or any of the parent directories): .git
E0116 02:34:12.481] Command failed
I0116 02:34:12.481] process 2087 exited with code 128 after 0.0m
I0116 02:34:12.481] Call:  git rev-parse HEAD
I0116 02:34:12.493] process 2088 exited with code 0 after 0.0m
I0116 02:34:12.493] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/jobResultsCache.json
I0116 02:34:14.438] process 2089 exited with code 0 after 0.0m
I0116 02:34:14.439] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-device-plugin-gpu-p100/jobResultsCache.json#1579098853042588'
... skipping 8 lines ...