This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-04-02 13:59
Elapsed4m23s
Revision
Builder10681c3b-74ea-11ea-9640-beab5e722989
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/440a8172-a915-4067-917c-21336f967d92/targets/test'}}
resultstorehttps://source.cloud.google.com/results/invocations/440a8172-a915-4067-917c-21336f967d92/targets/test
infra-commitd8a9dd12a
job-versionv1.18.1-beta.0.14+ff809a5d953ba7
revisionv1.18.1-beta.0.14+ff809a5d953ba7

Test Failures


Up 39s

error creating cluster: error during gcloud container clusters create --quiet --project=gke-gci-upg-1-3-1-4-ctl-skew --zone=us-west1-c --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-cb9e7587b0 --image-family=pipeline-1 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.18.1-beta.0.14+ff809a5d953ba7 test-cb9e7587b0: exit status 1
				from junit_runner.xml

Filter through log files


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0402 13:59:26.251] process 49 exited with code 0 after 0.0m
I0402 13:59:26.251] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0402 13:59:26.251] Root: /workspace
I0402 13:59:26.251] cd to /workspace
I0402 13:59:26.251] Configure environment...
I0402 13:59:26.252] Call:  git show -s --format=format:%ct HEAD
W0402 13:59:26.256] fatal: not a git repository (or any of the parent directories): .git
I0402 13:59:26.257] process 63 exited with code 128 after 0.0m
W0402 13:59:26.257] Unable to print commit date for HEAD
I0402 13:59:26.257] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0402 13:59:26.945] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0402 13:59:27.111] process 64 exited with code 0 after 0.0m
I0402 13:59:27.111] Call:  gcloud config get-value account
... skipping 426 lines ...
W0402 14:03:36.447] 2020/04/02 14:03:36 process.go:155: Step 'gcloud compute networks create test-cb9e7587b0 --project=gke-gci-upg-1-3-1-4-ctl-skew --subnet-mode=auto' finished in 37.712908291s
W0402 14:03:36.447] 2020/04/02 14:03:36 process.go:153: Running: gcloud container clusters create --quiet --project=gke-gci-upg-1-3-1-4-ctl-skew --zone=us-west1-c --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-cb9e7587b0 --image-family=pipeline-1 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.18.1-beta.0.14+ff809a5d953ba7 test-cb9e7587b0
W0402 14:03:36.979] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W0402 14:03:36.981] WARNING: Starting with version 1.18, clusters will have shielded GKE nodes by default.
W0402 14:03:36.981] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0402 14:03:36.981] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0402 14:03:37.070] ERROR: (gcloud.container.clusters.create) ResponseError: code=400, message=Location "us-west1-c" does not exist.
W0402 14:03:37.131] 2020/04/02 14:03:37 process.go:155: Step 'gcloud container clusters create --quiet --project=gke-gci-upg-1-3-1-4-ctl-skew --zone=us-west1-c --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-cb9e7587b0 --image-family=pipeline-1 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.18.1-beta.0.14+ff809a5d953ba7 test-cb9e7587b0' finished in 695.300491ms
W0402 14:03:38.370] 2020/04/02 14:03:38 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0402 14:03:38.378] 2020/04/02 14:03:38 main.go:317: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --quiet --project=gke-gci-upg-1-3-1-4-ctl-skew --zone=us-west1-c --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-cb9e7587b0 --image-family=pipeline-1 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.18.1-beta.0.14+ff809a5d953ba7 test-cb9e7587b0: exit status 1
W0402 14:03:38.383] Traceback (most recent call last):
W0402 14:03:38.383]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 779, in <module>
W0402 14:03:38.383]     main(parse_args())
W0402 14:03:38.384]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 627, in main
W0402 14:03:38.384]     mode.start(runner_args)
W0402 14:03:38.384]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0402 14:03:38.384]     check_env(env, self.command, *args)
W0402 14:03:38.384]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0402 14:03:38.384]     subprocess.check_call(cmd, env=env)
W0402 14:03:38.384]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0402 14:03:38.384]     raise CalledProcessError(retcode, cmd)
W0402 14:03:38.385] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=test-cb9e7587b0', '--gcp-network=test-cb9e7587b0', '--check-leaked-resources', '--gcp-zone=us-west1-c', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gke-environment=test', '--image-family=pipeline-1', '--image-project=ubuntu-os-gke-cloud-devel', '--gcp-node-image=custom', '--extract=ci/latest-1.18', '--timeout=660m', '--test_args=--ginkgo.focus=\\[Serial\\]|\\[Disruptive\\] --ginkgo.skip=\\[Flaky\\]|\\[Feature:.+\\] --minStartupPods=8', '--ginkgo-parallel=1')' returned non-zero exit status 1
E0402 14:03:38.393] Command failed
I0402 14:03:38.394] process 274 exited with code 1 after 4.1m
E0402 14:03:38.394] FAIL: ci-kubernetes-e2e-gke-ubuntu1-k8sbeta-serial
I0402 14:03:38.394] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0402 14:03:38.997] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0402 14:03:39.064] process 1446 exited with code 0 after 0.0m
I0402 14:03:39.064] Call:  gcloud config get-value account
I0402 14:03:39.614] process 1460 exited with code 0 after 0.0m
I0402 14:03:39.615] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0402 14:03:39.615] Upload result and artifacts...
I0402 14:03:39.615] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu1-k8sbeta-serial/1245712350539943943
I0402 14:03:39.616] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu1-k8sbeta-serial/1245712350539943943/artifacts
W0402 14:03:40.729] CommandException: One or more URLs matched no objects.
E0402 14:03:40.899] Command failed
I0402 14:03:40.900] process 1474 exited with code 1 after 0.0m
W0402 14:03:40.900] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu1-k8sbeta-serial/1245712350539943943/artifacts not exist yet
I0402 14:03:40.900] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu1-k8sbeta-serial/1245712350539943943/artifacts
I0402 14:03:43.056] process 1620 exited with code 0 after 0.0m
I0402 14:03:43.057] Call:  git rev-parse HEAD
W0402 14:03:43.062] fatal: not a git repository (or any of the parent directories): .git
E0402 14:03:43.062] Command failed
I0402 14:03:43.062] process 2148 exited with code 128 after 0.0m
I0402 14:03:43.063] Call:  git rev-parse HEAD
I0402 14:03:43.067] process 2149 exited with code 0 after 0.0m
I0402 14:03:43.068] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu1-k8sbeta-serial/jobResultsCache.json
I0402 14:03:44.546] process 2150 exited with code 0 after 0.0m
I0402 14:03:44.547] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu1-k8sbeta-serial/jobResultsCache.json#1585828908055105'
... skipping 8 lines ...