This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-04-02 16:00
Elapsed3m20s
Revision
Builderf7e10965-74fa-11ea-9640-beab5e722989
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/96abf8da-a21a-4390-b420-94e8a2e347ac/targets/test'}}
resultstorehttps://source.cloud.google.com/results/invocations/96abf8da-a21a-4390-b420-94e8a2e347ac/targets/test
infra-commita8225ac13
job-versionv1.18.1-beta.0.14+ff809a5d953ba7
revisionv1.18.1-beta.0.14+ff809a5d953ba7

Test Failures


Up 47s

error creating cluster: error during gcloud container clusters create --quiet --project=gke-up-c1-4-c1-5-up-clu-n --zone=us-west1-c --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-cb9e7587b0 --image-family=pipeline-1 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.18.1-beta.0.14+ff809a5d953ba7 test-cb9e7587b0: exit status 1
				from junit_runner.xml

Filter through log files


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0402 16:00:21.074] process 50 exited with code 0 after 0.0m
I0402 16:00:21.075] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0402 16:00:21.075] Root: /workspace
I0402 16:00:21.075] cd to /workspace
I0402 16:00:21.075] Configure environment...
I0402 16:00:21.076] Call:  git show -s --format=format:%ct HEAD
W0402 16:00:21.080] fatal: not a git repository (or any of the parent directories): .git
I0402 16:00:21.081] process 64 exited with code 128 after 0.0m
W0402 16:00:21.081] Unable to print commit date for HEAD
I0402 16:00:21.081] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0402 16:00:21.796] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0402 16:00:21.949] process 65 exited with code 0 after 0.0m
I0402 16:00:21.949] Call:  gcloud config get-value account
... skipping 426 lines ...
W0402 16:03:20.585] 2020/04/02 16:03:20 process.go:155: Step 'gcloud compute networks create test-cb9e7587b0 --project=gke-up-c1-4-c1-5-up-clu-n --subnet-mode=auto' finished in 44.877656622s
W0402 16:03:20.586] 2020/04/02 16:03:20 process.go:153: Running: gcloud container clusters create --quiet --project=gke-up-c1-4-c1-5-up-clu-n --zone=us-west1-c --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-cb9e7587b0 --image-family=pipeline-1 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.18.1-beta.0.14+ff809a5d953ba7 test-cb9e7587b0
W0402 16:03:21.503] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W0402 16:03:21.504] WARNING: Starting with version 1.18, clusters will have shielded GKE nodes by default.
W0402 16:03:21.505] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0402 16:03:21.505] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0402 16:03:21.607] ERROR: (gcloud.container.clusters.create) ResponseError: code=400, message=Location "us-west1-c" does not exist.
W0402 16:03:21.695] 2020/04/02 16:03:21 process.go:155: Step 'gcloud container clusters create --quiet --project=gke-up-c1-4-c1-5-up-clu-n --zone=us-west1-c --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-cb9e7587b0 --image-family=pipeline-1 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.18.1-beta.0.14+ff809a5d953ba7 test-cb9e7587b0' finished in 1.109934296s
W0402 16:03:23.900] 2020/04/02 16:03:23 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0402 16:03:23.907] 2020/04/02 16:03:23 main.go:317: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --quiet --project=gke-up-c1-4-c1-5-up-clu-n --zone=us-west1-c --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-cb9e7587b0 --image-family=pipeline-1 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.18.1-beta.0.14+ff809a5d953ba7 test-cb9e7587b0: exit status 1
W0402 16:03:23.917] Traceback (most recent call last):
W0402 16:03:23.917]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 779, in <module>
W0402 16:03:23.917]     main(parse_args())
W0402 16:03:23.917]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 627, in main
W0402 16:03:23.917]     mode.start(runner_args)
W0402 16:03:23.918]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0402 16:03:23.918]     check_env(env, self.command, *args)
W0402 16:03:23.918]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0402 16:03:23.918]     subprocess.check_call(cmd, env=env)
W0402 16:03:23.918]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0402 16:03:23.935]     raise CalledProcessError(retcode, cmd)
W0402 16:03:23.936] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=test-cb9e7587b0', '--gcp-network=test-cb9e7587b0', '--check-leaked-resources', '--gcp-zone=us-west1-c', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gke-environment=test', '--image-family=pipeline-1', '--image-project=ubuntu-os-gke-cloud-devel', '--gcp-node-image=custom', '--extract=ci/latest-1.18', '--timeout=660m', '--test_args=--ginkgo.focus=\\[Serial\\]|\\[Disruptive\\] --ginkgo.skip=\\[Flaky\\]|\\[Feature:.+\\] --minStartupPods=8', '--ginkgo-parallel=1')' returned non-zero exit status 1
E0402 16:03:23.948] Command failed
I0402 16:03:23.948] process 275 exited with code 1 after 3.0m
E0402 16:03:23.948] FAIL: ci-kubernetes-e2e-gke-ubuntu1-k8sbeta-serial
I0402 16:03:23.948] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0402 16:03:24.967] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0402 16:03:25.089] process 1447 exited with code 0 after 0.0m
I0402 16:03:25.089] Call:  gcloud config get-value account
I0402 16:03:25.969] process 1461 exited with code 0 after 0.0m
I0402 16:03:25.969] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0402 16:03:25.970] Upload result and artifacts...
I0402 16:03:25.970] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu1-k8sbeta-serial/1245742800578809860
I0402 16:03:25.970] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu1-k8sbeta-serial/1245742800578809860/artifacts
W0402 16:03:27.859] CommandException: One or more URLs matched no objects.
E0402 16:03:28.159] Command failed
I0402 16:03:28.160] process 1475 exited with code 1 after 0.0m
W0402 16:03:28.160] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu1-k8sbeta-serial/1245742800578809860/artifacts not exist yet
I0402 16:03:28.160] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu1-k8sbeta-serial/1245742800578809860/artifacts
I0402 16:03:31.395] process 1621 exited with code 0 after 0.1m
I0402 16:03:31.396] Call:  git rev-parse HEAD
W0402 16:03:31.407] fatal: not a git repository (or any of the parent directories): .git
E0402 16:03:31.408] Command failed
I0402 16:03:31.408] process 2149 exited with code 128 after 0.0m
I0402 16:03:31.408] Call:  git rev-parse HEAD
I0402 16:03:31.420] process 2150 exited with code 0 after 0.0m
I0402 16:03:31.421] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu1-k8sbeta-serial/jobResultsCache.json
I0402 16:03:33.771] process 2151 exited with code 0 after 0.0m
I0402 16:03:33.772] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu1-k8sbeta-serial/jobResultsCache.json#1585836227648249'
... skipping 8 lines ...