This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-04-03 10:08
Elapsed3m35s
Revision
Builder0441fb09-7593-11ea-acd4-5e70229ba2cd
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/ec3cd4e9-7f79-4e06-b350-4cd4e530e8a6/targets/test'}}
resultstorehttps://source.cloud.google.com/results/invocations/ec3cd4e9-7f79-4e06-b350-4cd4e530e8a6/targets/test
infra-commit2db75efeb
job-versionv1.18.1-beta.0.14+ff809a5d953ba7
revisionv1.18.1-beta.0.14+ff809a5d953ba7

Test Failures


Up 43s

error creating cluster: error during gcloud container clusters create --quiet --project=k8s-gke-upg-c1-4-c1-6-up-clu --zone=us-west1-c --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-cb9e7587b0 --image-family=pipeline-1 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.18.1-beta.0.14+ff809a5d953ba7 test-cb9e7587b0: exit status 1
				from junit_runner.xml

Filter through log files


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0403 10:08:43.240] process 50 exited with code 0 after 0.0m
I0403 10:08:43.240] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0403 10:08:43.240] Root: /workspace
I0403 10:08:43.240] cd to /workspace
I0403 10:08:43.241] Configure environment...
I0403 10:08:43.241] Call:  git show -s --format=format:%ct HEAD
W0403 10:08:43.245] fatal: not a git repository (or any of the parent directories): .git
I0403 10:08:43.246] process 64 exited with code 128 after 0.0m
W0403 10:08:43.246] Unable to print commit date for HEAD
I0403 10:08:43.246] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0403 10:08:43.885] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0403 10:08:44.208] process 65 exited with code 0 after 0.0m
I0403 10:08:44.209] Call:  gcloud config get-value account
... skipping 426 lines ...
W0403 10:12:02.995] 2020/04/03 10:12:02 process.go:155: Step 'gcloud compute networks create test-cb9e7587b0 --project=k8s-gke-upg-c1-4-c1-6-up-clu --subnet-mode=auto' finished in 41.843909116s
W0403 10:12:02.996] 2020/04/03 10:12:02 process.go:153: Running: gcloud container clusters create --quiet --project=k8s-gke-upg-c1-4-c1-6-up-clu --zone=us-west1-c --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-cb9e7587b0 --image-family=pipeline-1 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.18.1-beta.0.14+ff809a5d953ba7 test-cb9e7587b0
W0403 10:12:03.601] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W0403 10:12:03.601] WARNING: Starting with version 1.18, clusters will have shielded GKE nodes by default.
W0403 10:12:03.601] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0403 10:12:03.601] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0403 10:12:03.700] ERROR: (gcloud.container.clusters.create) ResponseError: code=400, message=Location "us-west1-c" does not exist.
W0403 10:12:03.756] 2020/04/03 10:12:03 process.go:155: Step 'gcloud container clusters create --quiet --project=k8s-gke-upg-c1-4-c1-6-up-clu --zone=us-west1-c --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-cb9e7587b0 --image-family=pipeline-1 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.18.1-beta.0.14+ff809a5d953ba7 test-cb9e7587b0' finished in 770.804389ms
W0403 10:12:05.332] 2020/04/03 10:12:05 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0403 10:12:05.340] 2020/04/03 10:12:05 main.go:314: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --quiet --project=k8s-gke-upg-c1-4-c1-6-up-clu --zone=us-west1-c --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-cb9e7587b0 --image-family=pipeline-1 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.18.1-beta.0.14+ff809a5d953ba7 test-cb9e7587b0: exit status 1
W0403 10:12:05.345] Traceback (most recent call last):
W0403 10:12:05.346]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 779, in <module>
W0403 10:12:05.346]     main(parse_args())
W0403 10:12:05.346]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 627, in main
W0403 10:12:05.346]     mode.start(runner_args)
W0403 10:12:05.346]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0403 10:12:05.346]     check_env(env, self.command, *args)
W0403 10:12:05.347]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0403 10:12:05.347]     subprocess.check_call(cmd, env=env)
W0403 10:12:05.347]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0403 10:12:05.347]     raise CalledProcessError(retcode, cmd)
W0403 10:12:05.348] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=test-cb9e7587b0', '--gcp-network=test-cb9e7587b0', '--check-leaked-resources', '--gcp-zone=us-west1-c', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gke-environment=test', '--image-family=pipeline-1', '--image-project=ubuntu-os-gke-cloud-devel', '--gcp-node-image=custom', '--extract=ci/latest-1.18', '--timeout=660m', '--test_args=--ginkgo.focus=\\[Serial\\]|\\[Disruptive\\] --ginkgo.skip=\\[Flaky\\]|\\[Feature:.+\\] --minStartupPods=8', '--ginkgo-parallel=1')' returned non-zero exit status 1
E0403 10:12:05.356] Command failed
I0403 10:12:05.356] process 275 exited with code 1 after 3.3m
E0403 10:12:05.356] FAIL: ci-kubernetes-e2e-gke-ubuntu1-k8sbeta-serial
I0403 10:12:05.357] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0403 10:12:06.097] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0403 10:12:06.159] process 1447 exited with code 0 after 0.0m
I0403 10:12:06.160] Call:  gcloud config get-value account
I0403 10:12:06.810] process 1461 exited with code 0 after 0.0m
I0403 10:12:06.811] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0403 10:12:06.811] Upload result and artifacts...
I0403 10:12:06.811] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu1-k8sbeta-serial/1246016695722577927
I0403 10:12:06.812] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu1-k8sbeta-serial/1246016695722577927/artifacts
W0403 10:12:08.383] CommandException: One or more URLs matched no objects.
E0403 10:12:08.570] Command failed
I0403 10:12:08.570] process 1475 exited with code 1 after 0.0m
W0403 10:12:08.571] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu1-k8sbeta-serial/1246016695722577927/artifacts not exist yet
I0403 10:12:08.571] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu1-k8sbeta-serial/1246016695722577927/artifacts
I0403 10:12:11.068] process 1621 exited with code 0 after 0.0m
I0403 10:12:11.069] Call:  git rev-parse HEAD
W0403 10:12:11.076] fatal: not a git repository (or any of the parent directories): .git
E0403 10:12:11.077] Command failed
I0403 10:12:11.077] process 2149 exited with code 128 after 0.0m
I0403 10:12:11.077] Call:  git rev-parse HEAD
I0403 10:12:11.088] process 2150 exited with code 0 after 0.0m
I0403 10:12:11.089] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu1-k8sbeta-serial/jobResultsCache.json
I0403 10:12:12.525] process 2151 exited with code 0 after 0.0m
I0403 10:12:12.526] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu1-k8sbeta-serial/jobResultsCache.json#1585901415846751'
... skipping 8 lines ...