This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-04-04 14:22
Elapsed4m31s
Revision
Builderab01c7d4-767f-11ea-acd4-5e70229ba2cd
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/63bb0c4c-6de4-4760-b5ca-36e60a353cee/targets/test'}}
resultstorehttps://source.cloud.google.com/results/invocations/63bb0c4c-6de4-4760-b5ca-36e60a353cee/targets/test
infra-commit95833bbfd
job-versionv1.18.1-beta.0.20+fc9151c55c71f5
revisionv1.18.1-beta.0.20+fc9151c55c71f5

Test Failures


Up 1m9s

error creating cluster: error during gcloud container clusters create --quiet --project=k8s-jkns-e2e-gke-test --zone=us-west1-c --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-cb9e7587b0 --image-family=pipeline-1 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.18.1-beta.0.20+fc9151c55c71f5 test-cb9e7587b0: exit status 1
				from junit_runner.xml

Filter through log files


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0404 14:22:50.418] process 49 exited with code 0 after 0.0m
I0404 14:22:50.419] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0404 14:22:50.419] Root: /workspace
I0404 14:22:50.419] cd to /workspace
I0404 14:22:50.419] Configure environment...
I0404 14:22:50.419] Call:  git show -s --format=format:%ct HEAD
W0404 14:22:50.424] fatal: not a git repository (or any of the parent directories): .git
I0404 14:22:50.424] process 63 exited with code 128 after 0.0m
W0404 14:22:50.424] Unable to print commit date for HEAD
I0404 14:22:50.424] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0404 14:22:51.042] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0404 14:22:51.421] process 64 exited with code 0 after 0.0m
I0404 14:22:51.421] Call:  gcloud config get-value account
... skipping 426 lines ...
W0404 14:27:10.628] 2020/04/04 14:27:10 process.go:155: Step 'gcloud compute networks create test-cb9e7587b0 --project=k8s-jkns-e2e-gke-test --subnet-mode=auto' finished in 1m7.58995959s
W0404 14:27:10.628] 2020/04/04 14:27:10 process.go:153: Running: gcloud container clusters create --quiet --project=k8s-jkns-e2e-gke-test --zone=us-west1-c --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-cb9e7587b0 --image-family=pipeline-1 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.18.1-beta.0.20+fc9151c55c71f5 test-cb9e7587b0
W0404 14:27:11.110] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W0404 14:27:11.110] WARNING: Starting with version 1.18, clusters will have shielded GKE nodes by default.
W0404 14:27:11.110] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0404 14:27:11.111] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0404 14:27:11.184] ERROR: (gcloud.container.clusters.create) ResponseError: code=400, message=Location "us-west1-c" does not exist.
W0404 14:27:11.247] 2020/04/04 14:27:11 process.go:155: Step 'gcloud container clusters create --quiet --project=k8s-jkns-e2e-gke-test --zone=us-west1-c --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-cb9e7587b0 --image-family=pipeline-1 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.18.1-beta.0.20+fc9151c55c71f5 test-cb9e7587b0' finished in 640.853564ms
W0404 14:27:12.532] 2020/04/04 14:27:12 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0404 14:27:12.545] 2020/04/04 14:27:12 main.go:314: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --quiet --project=k8s-jkns-e2e-gke-test --zone=us-west1-c --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-cb9e7587b0 --image-family=pipeline-1 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.18.1-beta.0.20+fc9151c55c71f5 test-cb9e7587b0: exit status 1
W0404 14:27:12.549] Traceback (most recent call last):
W0404 14:27:12.549]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 779, in <module>
W0404 14:27:12.549]     main(parse_args())
W0404 14:27:12.549]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 627, in main
W0404 14:27:12.550]     mode.start(runner_args)
W0404 14:27:12.550]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0404 14:27:12.550]     check_env(env, self.command, *args)
W0404 14:27:12.550]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0404 14:27:12.550]     subprocess.check_call(cmd, env=env)
W0404 14:27:12.551]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0404 14:27:12.551]     raise CalledProcessError(retcode, cmd)
W0404 14:27:12.552] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=test-cb9e7587b0', '--gcp-network=test-cb9e7587b0', '--check-leaked-resources', '--gcp-zone=us-west1-c', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gke-environment=test', '--image-family=pipeline-1', '--image-project=ubuntu-os-gke-cloud-devel', '--gcp-node-image=custom', '--extract=ci/latest-1.18', '--timeout=660m', '--test_args=--ginkgo.focus=\\[Serial\\]|\\[Disruptive\\] --ginkgo.skip=\\[Flaky\\]|\\[Feature:.+\\] --minStartupPods=8', '--ginkgo-parallel=1')' returned non-zero exit status 1
E0404 14:27:12.560] Command failed
I0404 14:27:12.560] process 274 exited with code 1 after 4.3m
E0404 14:27:12.560] FAIL: ci-kubernetes-e2e-gke-ubuntu1-k8sbeta-serial
I0404 14:27:12.560] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0404 14:27:13.168] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0404 14:27:13.227] process 1446 exited with code 0 after 0.0m
I0404 14:27:13.227] Call:  gcloud config get-value account
I0404 14:27:13.707] process 1460 exited with code 0 after 0.0m
I0404 14:27:13.708] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0404 14:27:13.708] Upload result and artifacts...
I0404 14:27:13.708] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu1-k8sbeta-serial/1246443008178524160
I0404 14:27:13.709] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu1-k8sbeta-serial/1246443008178524160/artifacts
W0404 14:27:14.780] CommandException: One or more URLs matched no objects.
E0404 14:27:14.913] Command failed
I0404 14:27:14.913] process 1474 exited with code 1 after 0.0m
W0404 14:27:14.913] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu1-k8sbeta-serial/1246443008178524160/artifacts not exist yet
I0404 14:27:14.913] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu1-k8sbeta-serial/1246443008178524160/artifacts
I0404 14:27:16.760] process 1620 exited with code 0 after 0.0m
I0404 14:27:16.760] Call:  git rev-parse HEAD
W0404 14:27:16.765] fatal: not a git repository (or any of the parent directories): .git
E0404 14:27:16.765] Command failed
I0404 14:27:16.765] process 2148 exited with code 128 after 0.0m
I0404 14:27:16.765] Call:  git rev-parse HEAD
I0404 14:27:16.770] process 2149 exited with code 0 after 0.0m
I0404 14:27:16.770] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu1-k8sbeta-serial/jobResultsCache.json
I0404 14:27:18.001] process 2150 exited with code 0 after 0.0m
I0404 14:27:18.002] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu1-k8sbeta-serial/jobResultsCache.json#1586003048300410'
... skipping 8 lines ...