This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-04-04 16:23
Elapsed3m4s
Revision
Builder922889a9-7690-11ea-acd4-5e70229ba2cd
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/880c4f9a-d4b3-43ba-81b6-684531ee8a6b/targets/test'}}
resultstorehttps://source.cloud.google.com/results/invocations/880c4f9a-d4b3-43ba-81b6-684531ee8a6b/targets/test
infra-commit95833bbfd
job-versionv1.18.1-beta.0.26+bb07a1fa1f608d
revisionv1.18.1-beta.0.26+bb07a1fa1f608d

Test Failures


Up 47s

error creating cluster: error during gcloud container clusters create --quiet --project=k8s-jkns-gci-gke-slow-1-6 --zone=us-west1-c --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-cb9e7587b0 --image-family=pipeline-1 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.18.1-beta.0.26+bb07a1fa1f608d test-cb9e7587b0: exit status 1
				from junit_runner.xml

Filter through log files


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0404 16:23:41.645] process 49 exited with code 0 after 0.0m
I0404 16:23:41.645] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0404 16:23:41.646] Root: /workspace
I0404 16:23:41.646] cd to /workspace
I0404 16:23:41.646] Configure environment...
I0404 16:23:41.647] Call:  git show -s --format=format:%ct HEAD
W0404 16:23:41.654] fatal: not a git repository (or any of the parent directories): .git
I0404 16:23:41.654] process 63 exited with code 128 after 0.0m
W0404 16:23:41.654] Unable to print commit date for HEAD
I0404 16:23:41.655] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0404 16:23:42.376] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0404 16:23:42.724] process 64 exited with code 0 after 0.0m
I0404 16:23:42.724] Call:  gcloud config get-value account
... skipping 426 lines ...
W0404 16:26:32.654] 2020/04/04 16:26:32 process.go:155: Step 'gcloud compute networks create test-cb9e7587b0 --project=k8s-jkns-gci-gke-slow-1-6 --subnet-mode=auto' finished in 45.698461121s
W0404 16:26:32.654] 2020/04/04 16:26:32 process.go:153: Running: gcloud container clusters create --quiet --project=k8s-jkns-gci-gke-slow-1-6 --zone=us-west1-c --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-cb9e7587b0 --image-family=pipeline-1 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.18.1-beta.0.26+bb07a1fa1f608d test-cb9e7587b0
W0404 16:26:33.263] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W0404 16:26:33.263] WARNING: Starting with version 1.18, clusters will have shielded GKE nodes by default.
W0404 16:26:33.263] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0404 16:26:33.263] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0404 16:26:33.342] ERROR: (gcloud.container.clusters.create) ResponseError: code=400, message=Location "us-west1-c" does not exist.
W0404 16:26:33.430] 2020/04/04 16:26:33 process.go:155: Step 'gcloud container clusters create --quiet --project=k8s-jkns-gci-gke-slow-1-6 --zone=us-west1-c --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-cb9e7587b0 --image-family=pipeline-1 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.18.1-beta.0.26+bb07a1fa1f608d test-cb9e7587b0' finished in 775.842982ms
W0404 16:26:34.934] 2020/04/04 16:26:34 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0404 16:26:34.949] 2020/04/04 16:26:34 main.go:314: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --quiet --project=k8s-jkns-gci-gke-slow-1-6 --zone=us-west1-c --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-cb9e7587b0 --image-family=pipeline-1 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.18.1-beta.0.26+bb07a1fa1f608d test-cb9e7587b0: exit status 1
W0404 16:26:34.956] Traceback (most recent call last):
W0404 16:26:34.957]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 779, in <module>
W0404 16:26:34.957]     main(parse_args())
W0404 16:26:34.957]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 627, in main
W0404 16:26:34.957]     mode.start(runner_args)
W0404 16:26:34.957]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0404 16:26:34.957]     check_env(env, self.command, *args)
W0404 16:26:34.958]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0404 16:26:34.958]     subprocess.check_call(cmd, env=env)
W0404 16:26:34.958]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0404 16:26:34.958]     raise CalledProcessError(retcode, cmd)
W0404 16:26:34.959] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=test-cb9e7587b0', '--gcp-network=test-cb9e7587b0', '--check-leaked-resources', '--gcp-zone=us-west1-c', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gke-environment=test', '--image-family=pipeline-1', '--image-project=ubuntu-os-gke-cloud-devel', '--gcp-node-image=custom', '--extract=ci/latest-1.18', '--timeout=660m', '--test_args=--ginkgo.focus=\\[Serial\\]|\\[Disruptive\\] --ginkgo.skip=\\[Flaky\\]|\\[Feature:.+\\] --minStartupPods=8', '--ginkgo-parallel=1')' returned non-zero exit status 1
E0404 16:26:34.969] Command failed
I0404 16:26:34.969] process 274 exited with code 1 after 2.8m
E0404 16:26:34.969] FAIL: ci-kubernetes-e2e-gke-ubuntu1-k8sbeta-serial
I0404 16:26:34.970] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0404 16:26:35.637] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0404 16:26:35.711] process 1445 exited with code 0 after 0.0m
I0404 16:26:35.711] Call:  gcloud config get-value account
I0404 16:26:36.315] process 1459 exited with code 0 after 0.0m
I0404 16:26:36.316] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0404 16:26:36.316] Upload result and artifacts...
I0404 16:26:36.316] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu1-k8sbeta-serial/1246473455944077315
I0404 16:26:36.316] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu1-k8sbeta-serial/1246473455944077315/artifacts
W0404 16:26:37.491] CommandException: One or more URLs matched no objects.
E0404 16:26:37.657] Command failed
I0404 16:26:37.657] process 1473 exited with code 1 after 0.0m
W0404 16:26:37.658] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu1-k8sbeta-serial/1246473455944077315/artifacts not exist yet
I0404 16:26:37.658] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu1-k8sbeta-serial/1246473455944077315/artifacts
I0404 16:26:39.720] process 1619 exited with code 0 after 0.0m
I0404 16:26:39.721] Call:  git rev-parse HEAD
W0404 16:26:39.726] fatal: not a git repository (or any of the parent directories): .git
E0404 16:26:39.726] Command failed
I0404 16:26:39.727] process 2147 exited with code 128 after 0.0m
I0404 16:26:39.727] Call:  git rev-parse HEAD
I0404 16:26:39.731] process 2148 exited with code 0 after 0.0m
I0404 16:26:39.732] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu1-k8sbeta-serial/jobResultsCache.json
I0404 16:26:41.006] process 2149 exited with code 0 after 0.0m
I0404 16:26:41.007] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu1-k8sbeta-serial/jobResultsCache.json#1586010440449935'
... skipping 8 lines ...