This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-01-16 17:00
Elapsed3m33s
Revision
Buildergke-prow-default-pool-cf4891d4-dz93
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/c0a80aab-4294-4e8d-9112-c2786d849781/targets/test'}}
poda673f152-3881-11ea-8f3e-66e48c863062
resultstorehttps://source.cloud.google.com/results/invocations/c0a80aab-4294-4e8d-9112-c2786d849781/targets/test
infra-commit6592ba878
job-versionv1.17.2-beta.0
poda673f152-3881-11ea-8f3e-66e48c863062
revisionv1.17.2-beta.0

Test Failures


Up 1m7s

error creating cluster: error during gcloud container clusters create --quiet --project=gke-up-c1-3-g1-5-up-clu-n --zone=us-west1-c --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-007f724e53 --image-family=pipeline-1 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.17.2-beta.0 test-007f724e53: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0116 17:00:50.641] process 47 exited with code 0 after 0.0m
I0116 17:00:50.641] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0116 17:00:50.641] Root: /workspace
I0116 17:00:50.642] cd to /workspace
I0116 17:00:50.642] Configure environment...
I0116 17:00:50.642] Call:  git show -s --format=format:%ct HEAD
W0116 17:00:50.647] fatal: not a git repository (or any of the parent directories): .git
I0116 17:00:50.648] process 60 exited with code 128 after 0.0m
W0116 17:00:50.648] Unable to print commit date for HEAD
I0116 17:00:50.649] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0116 17:00:51.304] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0116 17:00:51.669] process 61 exited with code 0 after 0.0m
I0116 17:00:51.669] Call:  gcloud config get-value account
... skipping 420 lines ...
W0116 17:04:03.012] 2020/01/16 17:04:03 process.go:155: Step 'gcloud compute networks create test-007f724e53 --project=gke-up-c1-3-g1-5-up-clu-n --subnet-mode=auto' finished in 1m5.174619976s
W0116 17:04:03.012] 2020/01/16 17:04:03 process.go:153: Running: gcloud container clusters create --quiet --project=gke-up-c1-3-g1-5-up-clu-n --zone=us-west1-c --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-007f724e53 --image-family=pipeline-1 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.17.2-beta.0 test-007f724e53
W0116 17:04:03.577] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W0116 17:04:03.578] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W0116 17:04:03.578] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0116 17:04:03.578] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0116 17:04:03.695] ERROR: (gcloud.container.clusters.create) ResponseError: code=400, message=Location "us-west1-c" does not exist.
W0116 17:04:03.780] 2020/01/16 17:04:03 process.go:155: Step 'gcloud container clusters create --quiet --project=gke-up-c1-3-g1-5-up-clu-n --zone=us-west1-c --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-007f724e53 --image-family=pipeline-1 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.17.2-beta.0 test-007f724e53' finished in 772.811912ms
W0116 17:04:05.204] 2020/01/16 17:04:05 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0116 17:04:13.724] 2020/01/16 17:04:13 main.go:316: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --quiet --project=gke-up-c1-3-g1-5-up-clu-n --zone=us-west1-c --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-007f724e53 --image-family=pipeline-1 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.17.2-beta.0 test-007f724e53: exit status 1
W0116 17:04:13.731] Traceback (most recent call last):
W0116 17:04:13.731]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W0116 17:04:13.731]     main(parse_args())
W0116 17:04:13.731]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W0116 17:04:13.731]     mode.start(runner_args)
W0116 17:04:13.732]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0116 17:04:13.732]     check_env(env, self.command, *args)
W0116 17:04:13.732]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0116 17:04:13.732]     subprocess.check_call(cmd, env=env)
W0116 17:04:13.732]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0116 17:04:13.733]     raise CalledProcessError(retcode, cmd)
W0116 17:04:13.733] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=test-007f724e53', '--gcp-network=test-007f724e53', '--check-leaked-resources', '--gcp-zone=us-west1-c', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gke-environment=test', '--image-family=pipeline-1', '--image-project=ubuntu-os-gke-cloud-devel', '--gcp-node-image=custom', '--extract=ci/k8s-beta', '--timeout=150m', '--test_args=--ginkgo.focus=\\[Slow\\] --ginkgo.skip=\\[Serial\\]|\\[Disruptive\\]|\\[Flaky\\]|\\[Feature:.+\\] --minStartupPods=8', '--ginkgo-parallel=30')' returned non-zero exit status 1
E0116 17:04:13.749] Command failed
I0116 17:04:13.749] process 268 exited with code 1 after 3.3m
E0116 17:04:13.749] FAIL: ci-kubernetes-e2e-gke-ubuntu1-k8sbeta-slow
I0116 17:04:13.750] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0116 17:04:14.388] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0116 17:04:14.453] process 1378 exited with code 0 after 0.0m
I0116 17:04:14.454] Call:  gcloud config get-value account
I0116 17:04:14.843] process 1391 exited with code 0 after 0.0m
I0116 17:04:14.843] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0116 17:04:14.843] Upload result and artifacts...
I0116 17:04:14.843] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu1-k8sbeta-slow/1217854163845648385
I0116 17:04:14.844] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu1-k8sbeta-slow/1217854163845648385/artifacts
W0116 17:04:15.954] CommandException: One or more URLs matched no objects.
E0116 17:04:16.144] Command failed
I0116 17:04:16.144] process 1404 exited with code 1 after 0.0m
W0116 17:04:16.145] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu1-k8sbeta-slow/1217854163845648385/artifacts not exist yet
I0116 17:04:16.145] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu1-k8sbeta-slow/1217854163845648385/artifacts
I0116 17:04:18.106] process 1549 exited with code 0 after 0.0m
I0116 17:04:18.107] Call:  git rev-parse HEAD
W0116 17:04:18.115] fatal: not a git repository (or any of the parent directories): .git
E0116 17:04:18.115] Command failed
I0116 17:04:18.115] process 2076 exited with code 128 after 0.0m
I0116 17:04:18.115] Call:  git rev-parse HEAD
I0116 17:04:18.122] process 2077 exited with code 0 after 0.0m
I0116 17:04:18.123] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu1-k8sbeta-slow/jobResultsCache.json
I0116 17:04:19.293] process 2078 exited with code 0 after 0.0m
I0116 17:04:19.294] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu1-k8sbeta-slow/jobResultsCache.json#1579186993747815'
... skipping 8 lines ...