This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-01-17 07:08
Elapsed3m6s
Revision
Buildergke-prow-default-pool-cf4891d4-qhc1
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/683d0982-4c1e-4025-933a-906f85b09576/targets/test'}}
pod1211d271-38f8-11ea-8780-468616f72408
resultstorehttps://source.cloud.google.com/results/invocations/683d0982-4c1e-4025-933a-906f85b09576/targets/test
infra-commit573707797
job-versionv1.17.2-beta.0
pod1211d271-38f8-11ea-8780-468616f72408
revisionv1.17.2-beta.0

Test Failures


Up 45s

error creating cluster: error during gcloud container clusters create --quiet --project=k8s-gke-cvm-m-1-6-ctl-skw-srl --zone=us-west1-c --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-007f724e53 --image-family=pipeline-1 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.17.2-beta.0 test-007f724e53: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0117 07:08:39.331] process 47 exited with code 0 after 0.0m
I0117 07:08:39.331] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0117 07:08:39.332] Root: /workspace
I0117 07:08:39.332] cd to /workspace
I0117 07:08:39.332] Configure environment...
I0117 07:08:39.332] Call:  git show -s --format=format:%ct HEAD
W0117 07:08:39.337] fatal: not a git repository (or any of the parent directories): .git
I0117 07:08:39.337] process 60 exited with code 128 after 0.0m
W0117 07:08:39.338] Unable to print commit date for HEAD
I0117 07:08:39.338] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0117 07:08:39.910] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0117 07:08:40.294] process 61 exited with code 0 after 0.0m
I0117 07:08:40.295] Call:  gcloud config get-value account
... skipping 420 lines ...
W0117 07:11:29.668] 2020/01/17 07:11:29 process.go:155: Step 'gcloud compute networks create test-007f724e53 --project=k8s-gke-cvm-m-1-6-ctl-skw-srl --subnet-mode=auto' finished in 43.695847468s
W0117 07:11:29.668] 2020/01/17 07:11:29 process.go:153: Running: gcloud container clusters create --quiet --project=k8s-gke-cvm-m-1-6-ctl-skw-srl --zone=us-west1-c --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-007f724e53 --image-family=pipeline-1 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.17.2-beta.0 test-007f724e53
W0117 07:11:30.142] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W0117 07:11:30.142] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W0117 07:11:30.142] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0117 07:11:30.143] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0117 07:11:30.221] ERROR: (gcloud.container.clusters.create) ResponseError: code=400, message=Location "us-west1-c" does not exist.
W0117 07:11:30.278] 2020/01/17 07:11:30 process.go:155: Step 'gcloud container clusters create --quiet --project=k8s-gke-cvm-m-1-6-ctl-skw-srl --zone=us-west1-c --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-007f724e53 --image-family=pipeline-1 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.17.2-beta.0 test-007f724e53' finished in 622.675932ms
W0117 07:11:31.419] 2020/01/17 07:11:31 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0117 07:11:37.426] 2020/01/17 07:11:37 main.go:316: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --quiet --project=k8s-gke-cvm-m-1-6-ctl-skw-srl --zone=us-west1-c --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-007f724e53 --image-family=pipeline-1 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.17.2-beta.0 test-007f724e53: exit status 1
W0117 07:11:37.430] Traceback (most recent call last):
W0117 07:11:37.430]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W0117 07:11:37.430]     main(parse_args())
W0117 07:11:37.430]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W0117 07:11:37.430]     mode.start(runner_args)
W0117 07:11:37.431]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0117 07:11:37.431]     check_env(env, self.command, *args)
W0117 07:11:37.431]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0117 07:11:37.431]     subprocess.check_call(cmd, env=env)
W0117 07:11:37.431]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0117 07:11:37.431]     raise CalledProcessError(retcode, cmd)
W0117 07:11:37.432] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=test-007f724e53', '--gcp-network=test-007f724e53', '--check-leaked-resources', '--gcp-zone=us-west1-c', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gke-environment=test', '--image-family=pipeline-1', '--image-project=ubuntu-os-gke-cloud-devel', '--gcp-node-image=custom', '--extract=ci/k8s-beta', '--timeout=150m', '--test_args=--ginkgo.focus=\\[Slow\\] --ginkgo.skip=\\[Serial\\]|\\[Disruptive\\]|\\[Flaky\\]|\\[Feature:.+\\] --minStartupPods=8', '--ginkgo-parallel=30')' returned non-zero exit status 1
E0117 07:11:37.440] Command failed
I0117 07:11:37.440] process 268 exited with code 1 after 2.9m
E0117 07:11:37.440] FAIL: ci-kubernetes-e2e-gke-ubuntu1-k8sbeta-slow
I0117 07:11:37.441] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0117 07:11:37.953] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0117 07:11:38.010] process 1377 exited with code 0 after 0.0m
I0117 07:11:38.011] Call:  gcloud config get-value account
I0117 07:11:38.352] process 1390 exited with code 0 after 0.0m
I0117 07:11:38.352] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0117 07:11:38.352] Upload result and artifacts...
I0117 07:11:38.352] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu1-k8sbeta-slow/1218067525040869377
I0117 07:11:38.353] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu1-k8sbeta-slow/1218067525040869377/artifacts
W0117 07:11:39.348] CommandException: One or more URLs matched no objects.
E0117 07:11:39.474] Command failed
I0117 07:11:39.474] process 1403 exited with code 1 after 0.0m
W0117 07:11:39.475] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu1-k8sbeta-slow/1218067525040869377/artifacts not exist yet
I0117 07:11:39.475] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu1-k8sbeta-slow/1218067525040869377/artifacts
I0117 07:11:41.039] process 1548 exited with code 0 after 0.0m
I0117 07:11:41.040] Call:  git rev-parse HEAD
W0117 07:11:41.043] fatal: not a git repository (or any of the parent directories): .git
E0117 07:11:41.044] Command failed
I0117 07:11:41.044] process 2075 exited with code 128 after 0.0m
I0117 07:11:41.044] Call:  git rev-parse HEAD
I0117 07:11:41.048] process 2076 exited with code 0 after 0.0m
I0117 07:11:41.049] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu1-k8sbeta-slow/jobResultsCache.json
I0117 07:11:42.067] process 2077 exited with code 0 after 0.0m
I0117 07:11:42.068] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu1-k8sbeta-slow/jobResultsCache.json#1579237853755532'
... skipping 8 lines ...