This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-01-09 05:31
Elapsed2m59s
Revision
Buildergke-prow-default-pool-cf4891d4-33pg
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/50937d98-c532-4608-8c7f-48e027e266eb/targets/test'}}
pod1cf7ddad-32a1-11ea-9709-02f27a93e62e
resultstorehttps://source.cloud.google.com/results/invocations/50937d98-c532-4608-8c7f-48e027e266eb/targets/test
infra-commit4a88c259d
job-versionv1.15.8-beta.1.20+993e84935bc8c4
pod1cf7ddad-32a1-11ea-9709-02f27a93e62e
revisionv1.15.8-beta.1.20+993e84935bc8c4

Test Failures


Up 44s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-jkns-e2e-gke-gpus-beta --zone=us-west1-b --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-992e4c08ff --image-family=pipeline-1 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.15.8-beta.1.20+993e84935bc8c4 test-992e4c08ff: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0109 05:31:04.041] process 47 exited with code 0 after 0.0m
I0109 05:31:04.042] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0109 05:31:04.042] Root: /workspace
I0109 05:31:04.042] cd to /workspace
I0109 05:31:04.042] Configure environment...
I0109 05:31:04.043] Call:  git show -s --format=format:%ct HEAD
W0109 05:31:04.046] fatal: not a git repository (or any of the parent directories): .git
I0109 05:31:04.047] process 60 exited with code 128 after 0.0m
W0109 05:31:04.047] Unable to print commit date for HEAD
I0109 05:31:04.047] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0109 05:31:04.555] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0109 05:31:04.874] process 61 exited with code 0 after 0.0m
I0109 05:31:04.874] Call:  gcloud config get-value account
... skipping 426 lines ...
W0109 05:33:33.745] 2020/01/09 05:33:33 process.go:153: Running: gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-jkns-e2e-gke-gpus-beta --zone=us-west1-b --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-992e4c08ff --image-family=pipeline-1 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.15.8-beta.1.20+993e84935bc8c4 test-992e4c08ff
W0109 05:33:34.165] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W0109 05:33:34.166] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W0109 05:33:34.166] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0109 05:33:34.166] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0109 05:33:34.166] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W0109 05:33:38.450] ERROR: (gcloud.container.clusters.create) ResponseError: code=400, message=Failure in zone us-west1-b due to tight resource constraints. You can either try again later or create another node pool in another zone and migrate workloads. (See https://cloud.google.com/kubernetes-engine/docs/tutorials/migrating-node-pool) Recommended alternative zone: us-west1-a).
W0109 05:33:38.498] 2020/01/09 05:33:38 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-jkns-e2e-gke-gpus-beta --zone=us-west1-b --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-992e4c08ff --image-family=pipeline-1 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.15.8-beta.1.20+993e84935bc8c4 test-992e4c08ff' finished in 4.780919396s
W0109 05:33:40.034] 2020/01/09 05:33:40 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0109 05:33:56.214] 2020/01/09 05:33:56 main.go:316: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-jkns-e2e-gke-gpus-beta --zone=us-west1-b --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-992e4c08ff --image-family=pipeline-1 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.15.8-beta.1.20+993e84935bc8c4 test-992e4c08ff: exit status 1
W0109 05:33:56.219] Traceback (most recent call last):
W0109 05:33:56.219]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W0109 05:33:56.219]     main(parse_args())
W0109 05:33:56.220]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W0109 05:33:56.220]     mode.start(runner_args)
W0109 05:33:56.220]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0109 05:33:56.220]     check_env(env, self.command, *args)
W0109 05:33:56.221]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0109 05:33:56.221]     subprocess.check_call(cmd, env=env)
W0109 05:33:56.221]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0109 05:33:56.221]     raise CalledProcessError(retcode, cmd)
W0109 05:33:56.222] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=test-992e4c08ff', '--gcp-network=test-992e4c08ff', '--check-leaked-resources', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gke-environment=test', '--image-family=pipeline-1', '--image-project=ubuntu-os-gke-cloud-devel', '--gcp-node-image=custom', '--extract=ci/k8s-stable2', '--gcp-project-type=gpu-project', '--timeout=180m', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-k80,count=2', '--gcp-zone=us-west1-b')' returned non-zero exit status 1
E0109 05:33:56.234] Command failed
I0109 05:33:56.234] process 268 exited with code 1 after 2.8m
E0109 05:33:56.234] FAIL: ci-kubernetes-e2e-gke-ubuntu1-k8sstable2-gpu
I0109 05:33:56.235] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0109 05:33:56.755] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0109 05:33:56.804] process 1391 exited with code 0 after 0.0m
I0109 05:33:56.804] Call:  gcloud config get-value account
I0109 05:33:57.137] process 1404 exited with code 0 after 0.0m
I0109 05:33:57.137] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0109 05:33:57.137] Upload result and artifacts...
I0109 05:33:57.137] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu1-k8sstable2-gpu/1215143872372412418
I0109 05:33:57.138] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu1-k8sstable2-gpu/1215143872372412418/artifacts
W0109 05:33:57.981] CommandException: One or more URLs matched no objects.
E0109 05:33:58.090] Command failed
I0109 05:33:58.091] process 1417 exited with code 1 after 0.0m
W0109 05:33:58.091] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu1-k8sstable2-gpu/1215143872372412418/artifacts not exist yet
I0109 05:33:58.091] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu1-k8sstable2-gpu/1215143872372412418/artifacts
I0109 05:33:59.629] process 1562 exited with code 0 after 0.0m
I0109 05:33:59.630] Call:  git rev-parse HEAD
W0109 05:33:59.634] fatal: not a git repository (or any of the parent directories): .git
E0109 05:33:59.634] Command failed
I0109 05:33:59.634] process 2089 exited with code 128 after 0.0m
I0109 05:33:59.635] Call:  git rev-parse HEAD
I0109 05:33:59.639] process 2090 exited with code 0 after 0.0m
I0109 05:33:59.639] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu1-k8sstable2-gpu/jobResultsCache.json
I0109 05:34:00.548] process 2091 exited with code 0 after 0.0m
I0109 05:34:00.549] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu1-k8sstable2-gpu/jobResultsCache.json#1578526443157374'
... skipping 8 lines ...