This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-01-15 03:30
Elapsed2m58s
Revision
Buildergke-prow-default-pool-cf4891d4-wf4z
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/3f7bff85-c8a6-4052-b235-9d1d87f773da/targets/test'}}
pod5136d917-3747-11ea-8603-da2f7a5855b4
resultstorehttps://source.cloud.google.com/results/invocations/3f7bff85-c8a6-4052-b235-9d1d87f773da/targets/test
infra-commit29e07a334
job-versionv1.17.2-beta.0
pod5136d917-3747-11ea-8603-da2f7a5855b4
revisionv1.17.2-beta.0

Test Failures


Up 44s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-jkns-e2e-gke-gpus --zone=us-west1-b --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-f6cc3be82f --image-family=pipeline-2 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.17.2-beta.0 test-f6cc3be82f: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0115 03:30:53.205] process 47 exited with code 0 after 0.0m
I0115 03:30:53.205] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0115 03:30:53.206] Root: /workspace
I0115 03:30:53.206] cd to /workspace
I0115 03:30:53.206] Configure environment...
I0115 03:30:53.207] Call:  git show -s --format=format:%ct HEAD
W0115 03:30:53.211] fatal: not a git repository (or any of the parent directories): .git
I0115 03:30:53.212] process 60 exited with code 128 after 0.0m
W0115 03:30:53.212] Unable to print commit date for HEAD
I0115 03:30:53.212] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0115 03:30:53.755] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0115 03:30:53.908] process 61 exited with code 0 after 0.0m
I0115 03:30:53.908] Call:  gcloud config get-value account
... skipping 422 lines ...
W0115 03:33:29.394] 2020/01/15 03:33:29 process.go:153: Running: gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-jkns-e2e-gke-gpus --zone=us-west1-b --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-f6cc3be82f --image-family=pipeline-2 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.17.2-beta.0 test-f6cc3be82f
W0115 03:33:29.872] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W0115 03:33:29.873] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W0115 03:33:29.874] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0115 03:33:29.874] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0115 03:33:29.874] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W0115 03:33:34.024] ERROR: (gcloud.container.clusters.create) ResponseError: code=400, message=Failure in zone us-west1-b due to tight resource constraints. You can either try again later or create another node pool in another zone and migrate workloads. (See https://cloud.google.com/kubernetes-engine/docs/tutorials/migrating-node-pool) Recommended alternative zone: us-west1-a).
W0115 03:33:34.083] 2020/01/15 03:33:34 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-jkns-e2e-gke-gpus --zone=us-west1-b --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-f6cc3be82f --image-family=pipeline-2 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.17.2-beta.0 test-f6cc3be82f' finished in 4.70206153s
W0115 03:33:35.698] 2020/01/15 03:33:35 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0115 03:33:43.716] 2020/01/15 03:33:43 main.go:316: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-jkns-e2e-gke-gpus --zone=us-west1-b --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-f6cc3be82f --image-family=pipeline-2 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.17.2-beta.0 test-f6cc3be82f: exit status 1
W0115 03:33:43.722] Traceback (most recent call last):
W0115 03:33:43.722]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W0115 03:33:43.723]     main(parse_args())
W0115 03:33:43.723]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W0115 03:33:43.723]     mode.start(runner_args)
W0115 03:33:43.723]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0115 03:33:43.723]     check_env(env, self.command, *args)
W0115 03:33:43.724]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0115 03:33:43.724]     subprocess.check_call(cmd, env=env)
W0115 03:33:43.724]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0115 03:33:43.724]     raise CalledProcessError(retcode, cmd)
W0115 03:33:43.725] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=test-f6cc3be82f', '--gcp-network=test-f6cc3be82f', '--check-leaked-resources', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gke-environment=test', '--image-family=pipeline-2', '--image-project=ubuntu-os-gke-cloud-devel', '--gcp-node-image=custom', '--extract=ci/k8s-beta', '--gcp-project-type=gpu-project', '--timeout=180m', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-k80,count=2', '--gcp-zone=us-west1-b')' returned non-zero exit status 1
E0115 03:33:43.734] Command failed
I0115 03:33:43.735] process 268 exited with code 1 after 2.8m
E0115 03:33:43.735] FAIL: ci-kubernetes-e2e-gke-ubuntu2-k8sbeta-gpu
I0115 03:33:43.735] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0115 03:33:44.277] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0115 03:33:44.342] process 1377 exited with code 0 after 0.0m
I0115 03:33:44.342] Call:  gcloud config get-value account
I0115 03:33:44.692] process 1390 exited with code 0 after 0.0m
I0115 03:33:44.692] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0115 03:33:44.692] Upload result and artifacts...
I0115 03:33:44.693] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sbeta-gpu/1217287937482297344
I0115 03:33:44.693] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sbeta-gpu/1217287937482297344/artifacts
W0115 03:33:45.639] CommandException: One or more URLs matched no objects.
E0115 03:33:45.798] Command failed
I0115 03:33:45.798] process 1403 exited with code 1 after 0.0m
W0115 03:33:45.798] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sbeta-gpu/1217287937482297344/artifacts not exist yet
I0115 03:33:45.798] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sbeta-gpu/1217287937482297344/artifacts
I0115 03:33:47.415] process 1548 exited with code 0 after 0.0m
I0115 03:33:47.415] Call:  git rev-parse HEAD
W0115 03:33:47.426] fatal: not a git repository (or any of the parent directories): .git
E0115 03:33:47.426] Command failed
I0115 03:33:47.426] process 2075 exited with code 128 after 0.0m
I0115 03:33:47.427] Call:  git rev-parse HEAD
I0115 03:33:47.433] process 2076 exited with code 0 after 0.0m
I0115 03:33:47.433] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sbeta-gpu/jobResultsCache.json
I0115 03:33:48.430] process 2077 exited with code 0 after 0.0m
I0115 03:33:48.431] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sbeta-gpu/jobResultsCache.json#1579052030613823'
... skipping 8 lines ...