This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-01-15 09:30
Elapsed4m7s
Revision
Buildergke-prow-default-pool-cf4891d4-xlcs
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/2ba440d7-993b-49fd-a662-6617424df9a5/targets/test'}}
pod9c046a02-3779-11ea-8603-da2f7a5855b4
resultstorehttps://source.cloud.google.com/results/invocations/2ba440d7-993b-49fd-a662-6617424df9a5/targets/test
infra-commit055aa0643
job-versionv1.17.2-beta.0
pod9c046a02-3779-11ea-8603-da2f7a5855b4
revisionv1.17.2-beta.0

Test Failures


Up 56s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-gke-gpu-boskos-02 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-f6cc3be82f --image-family=pipeline-2 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.17.2-beta.0 test-f6cc3be82f: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0115 09:30:59.903] process 47 exited with code 0 after 0.0m
I0115 09:30:59.903] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0115 09:30:59.903] Root: /workspace
I0115 09:30:59.903] cd to /workspace
I0115 09:30:59.904] Configure environment...
I0115 09:30:59.904] Call:  git show -s --format=format:%ct HEAD
W0115 09:30:59.911] fatal: not a git repository (or any of the parent directories): .git
I0115 09:30:59.912] process 60 exited with code 128 after 0.0m
W0115 09:30:59.912] Unable to print commit date for HEAD
I0115 09:30:59.913] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0115 09:31:00.801] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0115 09:31:01.182] process 61 exited with code 0 after 0.0m
I0115 09:31:01.183] Call:  gcloud config get-value account
... skipping 426 lines ...
W0115 09:34:48.096] 2020/01/15 09:34:48 process.go:153: Running: gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-gke-gpu-boskos-02 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-f6cc3be82f --image-family=pipeline-2 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.17.2-beta.0 test-f6cc3be82f
W0115 09:34:48.699] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W0115 09:34:48.699] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W0115 09:34:48.700] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0115 09:34:48.701] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0115 09:34:48.702] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W0115 09:34:53.260] ERROR: (gcloud.container.clusters.create) ResponseError: code=400, message=Failure in zone us-west1-b due to tight resource constraints. You can either try again later or create another node pool in another zone and migrate workloads. (See https://cloud.google.com/kubernetes-engine/docs/tutorials/migrating-node-pool) Recommended alternative zone: us-west1-c).
W0115 09:34:53.324] 2020/01/15 09:34:53 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-gke-gpu-boskos-02 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-f6cc3be82f --image-family=pipeline-2 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.17.2-beta.0 test-f6cc3be82f' finished in 5.227925655s
W0115 09:34:55.153] 2020/01/15 09:34:55 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0115 09:34:56.353] 2020/01/15 09:34:56 main.go:316: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-gke-gpu-boskos-02 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-f6cc3be82f --image-family=pipeline-2 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.17.2-beta.0 test-f6cc3be82f: exit status 1
W0115 09:34:56.365] Traceback (most recent call last):
W0115 09:34:56.365]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W0115 09:34:56.365]     main(parse_args())
W0115 09:34:56.366]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W0115 09:34:56.366]     mode.start(runner_args)
W0115 09:34:56.366]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0115 09:34:56.367]     check_env(env, self.command, *args)
W0115 09:34:56.367]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0115 09:34:56.367]     subprocess.check_call(cmd, env=env)
W0115 09:34:56.367]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0115 09:34:56.367]     raise CalledProcessError(retcode, cmd)
W0115 09:34:56.368] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=test-f6cc3be82f', '--gcp-network=test-f6cc3be82f', '--check-leaked-resources', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gke-environment=test', '--image-family=pipeline-2', '--image-project=ubuntu-os-gke-cloud-devel', '--gcp-node-image=custom', '--extract=ci/k8s-beta', '--gcp-project-type=gpu-project', '--timeout=180m', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-k80,count=2', '--gcp-zone=us-west1-b')' returned non-zero exit status 1
E0115 09:34:56.382] Command failed
I0115 09:34:56.382] process 268 exited with code 1 after 3.9m
E0115 09:34:56.382] FAIL: ci-kubernetes-e2e-gke-ubuntu2-k8sbeta-gpu
I0115 09:34:56.382] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0115 09:34:56.991] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0115 09:34:57.057] process 1389 exited with code 0 after 0.0m
I0115 09:34:57.057] Call:  gcloud config get-value account
I0115 09:34:57.453] process 1402 exited with code 0 after 0.0m
I0115 09:34:57.453] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0115 09:34:57.453] Upload result and artifacts...
I0115 09:34:57.453] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sbeta-gpu/1217378537409875969
I0115 09:34:57.454] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sbeta-gpu/1217378537409875969/artifacts
W0115 09:34:58.616] CommandException: One or more URLs matched no objects.
E0115 09:34:58.780] Command failed
I0115 09:34:58.780] process 1415 exited with code 1 after 0.0m
W0115 09:34:58.780] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sbeta-gpu/1217378537409875969/artifacts not exist yet
I0115 09:34:58.781] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sbeta-gpu/1217378537409875969/artifacts
I0115 09:35:00.804] process 1560 exited with code 0 after 0.0m
I0115 09:35:00.804] Call:  git rev-parse HEAD
W0115 09:35:00.811] fatal: not a git repository (or any of the parent directories): .git
E0115 09:35:00.811] Command failed
I0115 09:35:00.811] process 2087 exited with code 128 after 0.0m
I0115 09:35:00.811] Call:  git rev-parse HEAD
I0115 09:35:00.818] process 2088 exited with code 0 after 0.0m
I0115 09:35:00.819] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sbeta-gpu/jobResultsCache.json
I0115 09:35:02.172] process 2089 exited with code 0 after 0.0m
I0115 09:35:02.173] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sbeta-gpu/jobResultsCache.json#1579073728630224'
... skipping 8 lines ...