This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-01-15 21:31
Elapsed6m7s
Revision
Buildergke-prow-default-pool-cf4891d4-r8nq
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/cb842f36-df81-4c8c-b6de-5b98bb593bf4/targets/test'}}
pod3385d923-37de-11ea-8f3e-66e48c863062
resultstorehttps://source.cloud.google.com/results/invocations/cb842f36-df81-4c8c-b6de-5b98bb593bf4/targets/test
infra-commitf120f37b9
job-versionv1.17.2-beta.0
pod3385d923-37de-11ea-8f3e-66e48c863062
revisionv1.17.2-beta.0

Test Failures


Up 50s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-jkns-e2e-gce-gpus-1-7 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-f6cc3be82f --image-family=pipeline-2 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.17.2-beta.0 test-f6cc3be82f: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0115 21:31:14.036] process 47 exited with code 0 after 0.0m
I0115 21:31:14.036] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0115 21:31:14.036] Root: /workspace
I0115 21:31:14.037] cd to /workspace
I0115 21:31:14.037] Configure environment...
I0115 21:31:14.037] Call:  git show -s --format=format:%ct HEAD
W0115 21:31:14.042] fatal: not a git repository (or any of the parent directories): .git
I0115 21:31:14.043] process 60 exited with code 128 after 0.0m
W0115 21:31:14.043] Unable to print commit date for HEAD
I0115 21:31:14.043] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0115 21:31:14.908] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0115 21:31:15.272] process 61 exited with code 0 after 0.0m
I0115 21:31:15.273] Call:  gcloud config get-value account
... skipping 438 lines ...
W0115 21:36:24.937] 2020/01/15 21:36:24 process.go:153: Running: gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-jkns-e2e-gce-gpus-1-7 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-f6cc3be82f --image-family=pipeline-2 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.17.2-beta.0 test-f6cc3be82f
W0115 21:36:25.651] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W0115 21:36:25.651] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W0115 21:36:25.652] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0115 21:36:25.652] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0115 21:36:25.652] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W0115 21:36:29.975] ERROR: (gcloud.container.clusters.create) ResponseError: code=400, message=Failure in zone us-west1-b due to tight resource constraints. You can either try again later or create another node pool in another zone and migrate workloads. (See https://cloud.google.com/kubernetes-engine/docs/tutorials/migrating-node-pool) Recommended alternative zone: us-west1-c).
W0115 21:36:30.083] 2020/01/15 21:36:30 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-jkns-e2e-gce-gpus-1-7 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-f6cc3be82f --image-family=pipeline-2 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.17.2-beta.0 test-f6cc3be82f' finished in 5.144761015s
W0115 21:36:32.988] 2020/01/15 21:36:32 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0115 21:36:58.851] 2020/01/15 21:36:58 main.go:316: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-jkns-e2e-gce-gpus-1-7 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-f6cc3be82f --image-family=pipeline-2 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.17.2-beta.0 test-f6cc3be82f: exit status 1
W0115 21:36:58.878] Traceback (most recent call last):
W0115 21:36:58.878]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W0115 21:36:58.878]     main(parse_args())
W0115 21:36:58.878]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W0115 21:36:58.879]     mode.start(runner_args)
W0115 21:36:58.879]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0115 21:36:58.879]     check_env(env, self.command, *args)
W0115 21:36:58.879]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0115 21:36:58.880]     subprocess.check_call(cmd, env=env)
W0115 21:36:58.880]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0115 21:36:58.880]     raise CalledProcessError(retcode, cmd)
W0115 21:36:58.881] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=test-f6cc3be82f', '--gcp-network=test-f6cc3be82f', '--check-leaked-resources', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gke-environment=test', '--image-family=pipeline-2', '--image-project=ubuntu-os-gke-cloud-devel', '--gcp-node-image=custom', '--extract=ci/k8s-beta', '--gcp-project-type=gpu-project', '--timeout=180m', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-k80,count=2', '--gcp-zone=us-west1-b')' returned non-zero exit status 1
E0115 21:36:58.881] Command failed
I0115 21:36:58.881] process 268 exited with code 1 after 5.7m
E0115 21:36:58.881] FAIL: ci-kubernetes-e2e-gke-ubuntu2-k8sbeta-gpu
I0115 21:36:58.882] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0115 21:36:59.626] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0115 21:36:59.704] process 2589 exited with code 0 after 0.0m
I0115 21:36:59.704] Call:  gcloud config get-value account
I0115 21:37:00.275] process 2602 exited with code 0 after 0.0m
I0115 21:37:00.276] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0115 21:37:00.276] Upload result and artifacts...
I0115 21:37:00.276] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sbeta-gpu/1217559724589846530
I0115 21:37:00.276] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sbeta-gpu/1217559724589846530/artifacts
W0115 21:37:01.744] CommandException: One or more URLs matched no objects.
E0115 21:37:01.991] Command failed
I0115 21:37:01.992] process 2615 exited with code 1 after 0.0m
W0115 21:37:01.992] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sbeta-gpu/1217559724589846530/artifacts not exist yet
I0115 21:37:01.992] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sbeta-gpu/1217559724589846530/artifacts
I0115 21:37:04.935] process 2760 exited with code 0 after 0.0m
I0115 21:37:04.936] Call:  git rev-parse HEAD
W0115 21:37:04.946] fatal: not a git repository (or any of the parent directories): .git
E0115 21:37:04.946] Command failed
I0115 21:37:04.947] process 3287 exited with code 128 after 0.0m
I0115 21:37:04.947] Call:  git rev-parse HEAD
I0115 21:37:04.953] process 3288 exited with code 0 after 0.0m
I0115 21:37:04.953] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sbeta-gpu/jobResultsCache.json
I0115 21:37:06.657] process 3289 exited with code 0 after 0.0m
I0115 21:37:06.658] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sbeta-gpu/jobResultsCache.json#1579116869013429'
... skipping 8 lines ...