This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-01-16 09:30
Elapsed4m2s
Revision
Buildergke-prow-default-pool-cf4891d4-nxt5
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/6a9b3e0f-66e4-46e6-888f-fd407fb37677/targets/test'}}
podc935cd96-3842-11ea-8f3e-66e48c863062
resultstorehttps://source.cloud.google.com/results/invocations/6a9b3e0f-66e4-46e6-888f-fd407fb37677/targets/test
infra-commita9b921ef5
job-versionv1.17.2-beta.0
podc935cd96-3842-11ea-8f3e-66e48c863062
revisionv1.17.2-beta.0

Test Failures


Up 45s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-jkns-e2e-gce-gpus-1-7 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-f6cc3be82f --image-family=pipeline-2 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.17.2-beta.0 test-f6cc3be82f: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0116 09:30:52.644] process 47 exited with code 0 after 0.0m
I0116 09:30:52.644] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0116 09:30:52.644] Root: /workspace
I0116 09:30:52.644] cd to /workspace
I0116 09:30:52.645] Configure environment...
I0116 09:30:52.645] Call:  git show -s --format=format:%ct HEAD
W0116 09:30:52.652] fatal: not a git repository (or any of the parent directories): .git
I0116 09:30:52.652] process 60 exited with code 128 after 0.0m
W0116 09:30:52.653] Unable to print commit date for HEAD
I0116 09:30:52.653] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0116 09:30:53.330] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0116 09:30:53.710] process 61 exited with code 0 after 0.0m
I0116 09:30:53.711] Call:  gcloud config get-value account
... skipping 426 lines ...
W0116 09:34:11.361] 2020/01/16 09:34:11 process.go:153: Running: gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-jkns-e2e-gce-gpus-1-7 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-f6cc3be82f --image-family=pipeline-2 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.17.2-beta.0 test-f6cc3be82f
W0116 09:34:11.968] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W0116 09:34:11.969] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W0116 09:34:11.969] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0116 09:34:11.969] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0116 09:34:11.969] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W0116 09:34:15.865] ERROR: (gcloud.container.clusters.create) ResponseError: code=400, message=Failure in zone us-west1-b due to tight resource constraints. You can either try again later or create another node pool in another zone and migrate workloads. (See https://cloud.google.com/kubernetes-engine/docs/tutorials/migrating-node-pool) Recommended alternative zone: us-west1-c).
W0116 09:34:15.964] 2020/01/16 09:34:15 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-jkns-e2e-gce-gpus-1-7 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-f6cc3be82f --image-family=pipeline-2 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.17.2-beta.0 test-f6cc3be82f' finished in 4.602540568s
W0116 09:34:18.374] 2020/01/16 09:34:18 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0116 09:34:43.479] 2020/01/16 09:34:43 main.go:316: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-jkns-e2e-gce-gpus-1-7 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-f6cc3be82f --image-family=pipeline-2 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.17.2-beta.0 test-f6cc3be82f: exit status 1
W0116 09:34:43.488] Traceback (most recent call last):
W0116 09:34:43.488]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W0116 09:34:43.488]     main(parse_args())
W0116 09:34:43.489]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W0116 09:34:43.489]     mode.start(runner_args)
W0116 09:34:43.489]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0116 09:34:43.489]     check_env(env, self.command, *args)
W0116 09:34:43.489]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0116 09:34:43.489]     subprocess.check_call(cmd, env=env)
W0116 09:34:43.489]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0116 09:34:43.490]     raise CalledProcessError(retcode, cmd)
W0116 09:34:43.490] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=test-f6cc3be82f', '--gcp-network=test-f6cc3be82f', '--check-leaked-resources', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gke-environment=test', '--image-family=pipeline-2', '--image-project=ubuntu-os-gke-cloud-devel', '--gcp-node-image=custom', '--extract=ci/k8s-beta', '--gcp-project-type=gpu-project', '--timeout=180m', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-k80,count=2', '--gcp-zone=us-west1-b')' returned non-zero exit status 1
E0116 09:34:43.501] Command failed
I0116 09:34:43.501] process 268 exited with code 1 after 3.8m
E0116 09:34:43.501] FAIL: ci-kubernetes-e2e-gke-ubuntu2-k8sbeta-gpu
I0116 09:34:43.502] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0116 09:34:44.252] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0116 09:34:44.324] process 1389 exited with code 0 after 0.0m
I0116 09:34:44.325] Call:  gcloud config get-value account
I0116 09:34:44.812] process 1402 exited with code 0 after 0.0m
I0116 09:34:44.812] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0116 09:34:44.812] Upload result and artifacts...
I0116 09:34:44.812] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sbeta-gpu/1217740917117554692
I0116 09:34:44.813] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sbeta-gpu/1217740917117554692/artifacts
W0116 09:34:46.086] CommandException: One or more URLs matched no objects.
E0116 09:34:46.265] Command failed
I0116 09:34:46.265] process 1415 exited with code 1 after 0.0m
W0116 09:34:46.266] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sbeta-gpu/1217740917117554692/artifacts not exist yet
I0116 09:34:46.266] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sbeta-gpu/1217740917117554692/artifacts
I0116 09:34:48.159] process 1560 exited with code 0 after 0.0m
I0116 09:34:48.159] Call:  git rev-parse HEAD
W0116 09:34:48.172] fatal: not a git repository (or any of the parent directories): .git
E0116 09:34:48.173] Command failed
I0116 09:34:48.173] process 2087 exited with code 128 after 0.0m
I0116 09:34:48.173] Call:  git rev-parse HEAD
I0116 09:34:48.191] process 2088 exited with code 0 after 0.0m
I0116 09:34:48.192] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sbeta-gpu/jobResultsCache.json
I0116 09:34:50.119] process 2089 exited with code 0 after 0.0m
I0116 09:34:50.119] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sbeta-gpu/jobResultsCache.json#1579160052270718'
... skipping 8 lines ...