This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-01-16 13:30
Elapsed2m50s
Revision
Buildergke-prow-default-pool-cf4891d4-jbj5
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/0cad3741-c7c6-4a55-b550-b096d0be010f/targets/test'}}
pod4ff97601-3864-11ea-8f3e-66e48c863062
resultstorehttps://source.cloud.google.com/results/invocations/0cad3741-c7c6-4a55-b550-b096d0be010f/targets/test
infra-commita9b921ef5
job-versionv1.17.2-beta.0
pod4ff97601-3864-11ea-8f3e-66e48c863062
revisionv1.17.2-beta.0

Test Failures


Up 55s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-jkns-e2e-gce-gpus-beta --zone=us-west1-b --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-f6cc3be82f --image-family=pipeline-2 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.17.2-beta.0 test-f6cc3be82f: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0116 13:30:47.762] process 47 exited with code 0 after 0.0m
I0116 13:30:47.762] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0116 13:30:47.762] Root: /workspace
I0116 13:30:47.762] cd to /workspace
I0116 13:30:47.763] Configure environment...
I0116 13:30:47.763] Call:  git show -s --format=format:%ct HEAD
W0116 13:30:47.766] fatal: not a git repository (or any of the parent directories): .git
I0116 13:30:47.766] process 60 exited with code 128 after 0.0m
W0116 13:30:47.767] Unable to print commit date for HEAD
I0116 13:30:47.767] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0116 13:30:48.299] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0116 13:30:48.432] process 61 exited with code 0 after 0.0m
I0116 13:30:48.432] Call:  gcloud config get-value account
... skipping 426 lines ...
W0116 13:33:21.530] 2020/01/16 13:33:21 process.go:153: Running: gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-jkns-e2e-gce-gpus-beta --zone=us-west1-b --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-f6cc3be82f --image-family=pipeline-2 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.17.2-beta.0 test-f6cc3be82f
W0116 13:33:21.986] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W0116 13:33:21.987] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W0116 13:33:21.987] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0116 13:33:21.987] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0116 13:33:21.988] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W0116 13:33:27.087] ERROR: (gcloud.container.clusters.create) ResponseError: code=400, message=Failure in zone us-west1-b due to tight resource constraints. You can either try again later or create another node pool in another zone and migrate workloads. (See https://cloud.google.com/kubernetes-engine/docs/tutorials/migrating-node-pool) Recommended alternative zone: us-west1-c).
W0116 13:33:27.140] 2020/01/16 13:33:27 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-jkns-e2e-gce-gpus-beta --zone=us-west1-b --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-f6cc3be82f --image-family=pipeline-2 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.17.2-beta.0 test-f6cc3be82f' finished in 5.628077603s
W0116 13:33:28.844] 2020/01/16 13:33:28 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0116 13:33:30.141] 2020/01/16 13:33:30 main.go:316: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-jkns-e2e-gce-gpus-beta --zone=us-west1-b --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-f6cc3be82f --image-family=pipeline-2 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.17.2-beta.0 test-f6cc3be82f: exit status 1
W0116 13:33:30.145] Traceback (most recent call last):
W0116 13:33:30.146]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W0116 13:33:30.146]     main(parse_args())
W0116 13:33:30.146]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W0116 13:33:30.146]     mode.start(runner_args)
W0116 13:33:30.147]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0116 13:33:30.147]     check_env(env, self.command, *args)
W0116 13:33:30.147]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0116 13:33:30.147]     subprocess.check_call(cmd, env=env)
W0116 13:33:30.147]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0116 13:33:30.147]     raise CalledProcessError(retcode, cmd)
W0116 13:33:30.148] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=test-f6cc3be82f', '--gcp-network=test-f6cc3be82f', '--check-leaked-resources', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gke-environment=test', '--image-family=pipeline-2', '--image-project=ubuntu-os-gke-cloud-devel', '--gcp-node-image=custom', '--extract=ci/k8s-beta', '--gcp-project-type=gpu-project', '--timeout=180m', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-k80,count=2', '--gcp-zone=us-west1-b')' returned non-zero exit status 1
E0116 13:33:30.155] Command failed
I0116 13:33:30.156] process 268 exited with code 1 after 2.7m
E0116 13:33:30.156] FAIL: ci-kubernetes-e2e-gke-ubuntu2-k8sbeta-gpu
I0116 13:33:30.156] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0116 13:33:30.656] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0116 13:33:30.706] process 1391 exited with code 0 after 0.0m
I0116 13:33:30.706] Call:  gcloud config get-value account
I0116 13:33:31.027] process 1404 exited with code 0 after 0.0m
I0116 13:33:31.027] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0116 13:33:31.028] Upload result and artifacts...
I0116 13:33:31.028] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sbeta-gpu/1217801315430699009
I0116 13:33:31.028] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sbeta-gpu/1217801315430699009/artifacts
W0116 13:33:31.846] CommandException: One or more URLs matched no objects.
E0116 13:33:31.964] Command failed
I0116 13:33:31.964] process 1417 exited with code 1 after 0.0m
W0116 13:33:31.964] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sbeta-gpu/1217801315430699009/artifacts not exist yet
I0116 13:33:31.964] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sbeta-gpu/1217801315430699009/artifacts
I0116 13:33:33.500] process 1562 exited with code 0 after 0.0m
I0116 13:33:33.501] Call:  git rev-parse HEAD
W0116 13:33:33.504] fatal: not a git repository (or any of the parent directories): .git
E0116 13:33:33.505] Command failed
I0116 13:33:33.505] process 2089 exited with code 128 after 0.0m
I0116 13:33:33.505] Call:  git rev-parse HEAD
I0116 13:33:33.509] process 2090 exited with code 0 after 0.0m
I0116 13:33:33.510] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sbeta-gpu/jobResultsCache.json
I0116 13:33:34.548] process 2091 exited with code 0 after 0.0m
I0116 13:33:34.549] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sbeta-gpu/jobResultsCache.json#1579174444364128'
... skipping 8 lines ...