This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-01-11 20:31
Elapsed3m5s
Revision
Buildergke-prow-default-pool-cf4891d4-dttk
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/b275538e-5756-4f65-9cfc-28c06f0c5bec/targets/test'}}
pod3549b19c-34b1-11ea-9fef-d200904e1a96
resultstorehttps://source.cloud.google.com/results/invocations/b275538e-5756-4f65-9cfc-28c06f0c5bec/targets/test
infra-commitb82ca85d5
job-versionv1.15.8-beta.1.30+14ede42c4fe699
pod3549b19c-34b1-11ea-9fef-d200904e1a96
revisionv1.15.8-beta.1.30+14ede42c4fe699

Test Failures


Up 56s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-jkns-e2e-gke-plugin-gpus --zone=us-west1-b --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-6049ef264c --image-family=pipeline-2 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.15.8-beta.1.30+14ede42c4fe699 test-6049ef264c: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0111 20:31:12.158] process 47 exited with code 0 after 0.0m
I0111 20:31:12.158] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0111 20:31:12.158] Root: /workspace
I0111 20:31:12.159] cd to /workspace
I0111 20:31:12.159] Configure environment...
I0111 20:31:12.159] Call:  git show -s --format=format:%ct HEAD
W0111 20:31:12.163] fatal: not a git repository (or any of the parent directories): .git
I0111 20:31:12.163] process 60 exited with code 128 after 0.0m
W0111 20:31:12.163] Unable to print commit date for HEAD
I0111 20:31:12.164] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0111 20:31:12.685] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0111 20:31:13.004] process 61 exited with code 0 after 0.0m
I0111 20:31:13.004] Call:  gcloud config get-value account
... skipping 426 lines ...
W0111 20:33:59.575] 2020/01/11 20:33:59 process.go:153: Running: gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-jkns-e2e-gke-plugin-gpus --zone=us-west1-b --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-6049ef264c --image-family=pipeline-2 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.15.8-beta.1.30+14ede42c4fe699 test-6049ef264c
W0111 20:34:00.014] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W0111 20:34:00.015] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W0111 20:34:00.015] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0111 20:34:00.015] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0111 20:34:00.015] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W0111 20:34:05.191] ERROR: (gcloud.container.clusters.create) ResponseError: code=400, message=Failure in zone us-west1-b due to tight resource constraints. You can either try again later or create another node pool in another zone and migrate workloads. (See https://cloud.google.com/kubernetes-engine/docs/tutorials/migrating-node-pool) Recommended alternative zone: us-west1-c).
W0111 20:34:05.240] 2020/01/11 20:34:05 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-jkns-e2e-gke-plugin-gpus --zone=us-west1-b --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-6049ef264c --image-family=pipeline-2 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.15.8-beta.1.30+14ede42c4fe699 test-6049ef264c' finished in 5.687456098s
W0111 20:34:06.708] 2020/01/11 20:34:06 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0111 20:34:10.314] 2020/01/11 20:34:10 main.go:316: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-jkns-e2e-gke-plugin-gpus --zone=us-west1-b --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-6049ef264c --image-family=pipeline-2 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.15.8-beta.1.30+14ede42c4fe699 test-6049ef264c: exit status 1
W0111 20:34:10.317] Traceback (most recent call last):
W0111 20:34:10.317]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W0111 20:34:10.317]     main(parse_args())
W0111 20:34:10.318]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W0111 20:34:10.318]     mode.start(runner_args)
W0111 20:34:10.318]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0111 20:34:10.318]     check_env(env, self.command, *args)
W0111 20:34:10.318]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0111 20:34:10.318]     subprocess.check_call(cmd, env=env)
W0111 20:34:10.319]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0111 20:34:10.319]     raise CalledProcessError(retcode, cmd)
W0111 20:34:10.319] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=test-6049ef264c', '--gcp-network=test-6049ef264c', '--check-leaked-resources', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gke-environment=test', '--image-family=pipeline-2', '--image-project=ubuntu-os-gke-cloud-devel', '--gcp-node-image=custom', '--extract=ci/k8s-stable2', '--gcp-project-type=gpu-project', '--timeout=180m', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-k80,count=2', '--gcp-zone=us-west1-b')' returned non-zero exit status 1
E0111 20:34:10.327] Command failed
I0111 20:34:10.328] process 268 exited with code 1 after 2.9m
E0111 20:34:10.328] FAIL: ci-kubernetes-e2e-gke-ubuntu2-k8sstable2-gpu
I0111 20:34:10.328] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0111 20:34:10.794] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0111 20:34:10.850] process 1389 exited with code 0 after 0.0m
I0111 20:34:10.850] Call:  gcloud config get-value account
I0111 20:34:11.168] process 1402 exited with code 0 after 0.0m
I0111 20:34:11.168] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0111 20:34:11.168] Upload result and artifacts...
I0111 20:34:11.168] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sstable2-gpu/1216095163340820480
I0111 20:34:11.169] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sstable2-gpu/1216095163340820480/artifacts
W0111 20:34:11.965] CommandException: One or more URLs matched no objects.
E0111 20:34:12.069] Command failed
I0111 20:34:12.069] process 1415 exited with code 1 after 0.0m
W0111 20:34:12.069] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sstable2-gpu/1216095163340820480/artifacts not exist yet
I0111 20:34:12.069] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sstable2-gpu/1216095163340820480/artifacts
I0111 20:34:13.482] process 1560 exited with code 0 after 0.0m
I0111 20:34:13.483] Call:  git rev-parse HEAD
W0111 20:34:13.486] fatal: not a git repository (or any of the parent directories): .git
E0111 20:34:13.487] Command failed
I0111 20:34:13.487] process 2087 exited with code 128 after 0.0m
I0111 20:34:13.487] Call:  git rev-parse HEAD
I0111 20:34:13.491] process 2088 exited with code 0 after 0.0m
I0111 20:34:13.491] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sstable2-gpu/jobResultsCache.json
I0111 20:34:14.384] process 2089 exited with code 0 after 0.0m
I0111 20:34:14.385] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sstable2-gpu/jobResultsCache.json#1578753253181723'
... skipping 8 lines ...