This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-01-09 07:01
Elapsed4m47s
Revision
Buildergke-prow-default-pool-cf4891d4-4c7x
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/ae761702-ec08-48fd-bb3d-f2234f8bdecf/targets/test'}}
podaf973368-32ad-11ea-9709-02f27a93e62e
resultstorehttps://source.cloud.google.com/results/invocations/ae761702-ec08-48fd-bb3d-f2234f8bdecf/targets/test
infra-commit4a88c259d
job-versionv1.14.11-beta.1
podaf973368-32ad-11ea-9709-02f27a93e62e
revisionv1.14.11-beta.1

Test Failures


Up 1m0s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-gke-gpu-boskos-02 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-5561de90af --image-family=pipeline-2 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.14.11-beta.1 test-5561de90af: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0109 07:01:17.717] process 47 exited with code 0 after 0.0m
I0109 07:01:17.717] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0109 07:01:17.718] Root: /workspace
I0109 07:01:17.718] cd to /workspace
I0109 07:01:17.718] Configure environment...
I0109 07:01:17.718] Call:  git show -s --format=format:%ct HEAD
W0109 07:01:17.722] fatal: not a git repository (or any of the parent directories): .git
I0109 07:01:17.723] process 60 exited with code 128 after 0.0m
W0109 07:01:17.723] Unable to print commit date for HEAD
I0109 07:01:17.724] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0109 07:01:18.389] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0109 07:01:18.579] process 61 exited with code 0 after 0.0m
I0109 07:01:18.579] Call:  gcloud config get-value account
... skipping 426 lines ...
W0109 07:05:31.018] 2020/01/09 07:05:31 process.go:153: Running: gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-gke-gpu-boskos-02 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-5561de90af --image-family=pipeline-2 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.14.11-beta.1 test-5561de90af
W0109 07:05:31.592] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W0109 07:05:31.593] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W0109 07:05:31.593] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0109 07:05:31.594] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0109 07:05:31.594] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W0109 07:05:35.750] ERROR: (gcloud.container.clusters.create) ResponseError: code=400, message=Failure in zone us-west1-b due to tight resource constraints. You can either try again later or create another node pool in another zone and migrate workloads. (See https://cloud.google.com/kubernetes-engine/docs/tutorials/migrating-node-pool) Recommended alternative zone: us-west1-c).
W0109 07:05:35.819] 2020/01/09 07:05:35 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-gke-gpu-boskos-02 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-5561de90af --image-family=pipeline-2 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.14.11-beta.1 test-5561de90af' finished in 4.801833597s
W0109 07:05:37.580] 2020/01/09 07:05:37 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0109 07:05:55.597] 2020/01/09 07:05:55 main.go:316: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-gke-gpu-boskos-02 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-5561de90af --image-family=pipeline-2 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.14.11-beta.1 test-5561de90af: exit status 1
W0109 07:05:55.601] Traceback (most recent call last):
W0109 07:05:55.602]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W0109 07:05:55.602]     main(parse_args())
W0109 07:05:55.602]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W0109 07:05:55.602]     mode.start(runner_args)
W0109 07:05:55.602]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0109 07:05:55.602]     check_env(env, self.command, *args)
W0109 07:05:55.603]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0109 07:05:55.603]     subprocess.check_call(cmd, env=env)
W0109 07:05:55.603]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0109 07:05:55.603]     raise CalledProcessError(retcode, cmd)
W0109 07:05:55.604] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=test-5561de90af', '--gcp-network=test-5561de90af', '--check-leaked-resources', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gke-environment=test', '--image-family=pipeline-2', '--image-project=ubuntu-os-gke-cloud-devel', '--gcp-node-image=custom', '--extract=ci/k8s-stable3', '--gcp-project-type=gpu-project', '--timeout=180m', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-k80,count=2', '--gcp-zone=us-west1-b')' returned non-zero exit status 1
E0109 07:05:55.615] Command failed
I0109 07:05:55.615] process 268 exited with code 1 after 4.6m
E0109 07:05:55.615] FAIL: ci-kubernetes-e2e-gke-ubuntu2-k8sstable3-gpu
I0109 07:05:55.616] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0109 07:05:56.190] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0109 07:05:56.261] process 1389 exited with code 0 after 0.0m
I0109 07:05:56.262] Call:  gcloud config get-value account
I0109 07:05:56.638] process 1402 exited with code 0 after 0.0m
I0109 07:05:56.639] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0109 07:05:56.639] Upload result and artifacts...
I0109 07:05:56.639] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sstable3-gpu/1215166520263446529
I0109 07:05:56.640] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sstable3-gpu/1215166520263446529/artifacts
W0109 07:05:57.620] CommandException: One or more URLs matched no objects.
E0109 07:05:57.767] Command failed
I0109 07:05:57.767] process 1415 exited with code 1 after 0.0m
W0109 07:05:57.767] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sstable3-gpu/1215166520263446529/artifacts not exist yet
I0109 07:05:57.768] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sstable3-gpu/1215166520263446529/artifacts
I0109 07:05:59.518] process 1560 exited with code 0 after 0.0m
I0109 07:05:59.518] Call:  git rev-parse HEAD
W0109 07:05:59.523] fatal: not a git repository (or any of the parent directories): .git
E0109 07:05:59.523] Command failed
I0109 07:05:59.523] process 2087 exited with code 128 after 0.0m
I0109 07:05:59.523] Call:  git rev-parse HEAD
I0109 07:05:59.528] process 2088 exited with code 0 after 0.0m
I0109 07:05:59.528] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sstable3-gpu/jobResultsCache.json
I0109 07:06:00.728] process 2089 exited with code 0 after 0.0m
I0109 07:06:00.729] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sstable3-gpu/jobResultsCache.json#1578531874528422'
... skipping 8 lines ...