This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-01-10 01:01
Elapsed2m54s
Revision
Buildergke-prow-default-pool-cf4891d4-mb35
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/4c4538d8-58a0-4a18-9186-c8f8cdd81c03/targets/test'}}
poda13652d5-3344-11ea-a4dc-8213d962824c
resultstorehttps://source.cloud.google.com/results/invocations/4c4538d8-58a0-4a18-9186-c8f8cdd81c03/targets/test
infra-commitc31728321
job-versionv1.14.11-beta.1
poda13652d5-3344-11ea-a4dc-8213d962824c
revisionv1.14.11-beta.1

Test Failures


Up 49s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-jkns-e2e-gke-gpus-beta --zone=us-west1-b --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-5561de90af --image-family=pipeline-2 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.14.11-beta.1 test-5561de90af: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0110 01:01:34.434] process 47 exited with code 0 after 0.0m
I0110 01:01:34.435] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0110 01:01:34.435] Root: /workspace
I0110 01:01:34.435] cd to /workspace
I0110 01:01:34.435] Configure environment...
I0110 01:01:34.435] Call:  git show -s --format=format:%ct HEAD
W0110 01:01:34.439] fatal: not a git repository (or any of the parent directories): .git
I0110 01:01:34.439] process 60 exited with code 128 after 0.0m
W0110 01:01:34.439] Unable to print commit date for HEAD
I0110 01:01:34.439] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0110 01:01:34.889] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0110 01:01:35.228] process 61 exited with code 0 after 0.0m
I0110 01:01:35.228] Call:  gcloud config get-value account
... skipping 426 lines ...
W0110 01:03:58.806] 2020/01/10 01:03:58 process.go:153: Running: gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-jkns-e2e-gke-gpus-beta --zone=us-west1-b --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-5561de90af --image-family=pipeline-2 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.14.11-beta.1 test-5561de90af
W0110 01:03:59.123] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W0110 01:03:59.124] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W0110 01:03:59.124] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0110 01:03:59.125] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0110 01:03:59.125] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W0110 01:04:03.273] ERROR: (gcloud.container.clusters.create) ResponseError: code=400, message=Failure in zone us-west1-b due to tight resource constraints. You can either try again later or create another node pool in another zone and migrate workloads. (See https://cloud.google.com/kubernetes-engine/docs/tutorials/migrating-node-pool) Recommended alternative zone: us-west1-a).
W0110 01:04:03.312] 2020/01/10 01:04:03 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-jkns-e2e-gke-gpus-beta --zone=us-west1-b --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-5561de90af --image-family=pipeline-2 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.14.11-beta.1 test-5561de90af' finished in 4.548368946s
W0110 01:04:04.760] 2020/01/10 01:04:04 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0110 01:04:21.336] 2020/01/10 01:04:21 main.go:316: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-jkns-e2e-gke-gpus-beta --zone=us-west1-b --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-5561de90af --image-family=pipeline-2 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.14.11-beta.1 test-5561de90af: exit status 1
W0110 01:04:21.339] Traceback (most recent call last):
W0110 01:04:21.339]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W0110 01:04:21.339]     main(parse_args())
W0110 01:04:21.339]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W0110 01:04:21.340]     mode.start(runner_args)
W0110 01:04:21.340]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0110 01:04:21.340]     check_env(env, self.command, *args)
W0110 01:04:21.340]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0110 01:04:21.340]     subprocess.check_call(cmd, env=env)
W0110 01:04:21.340]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0110 01:04:21.341]     raise CalledProcessError(retcode, cmd)
W0110 01:04:21.341] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=test-5561de90af', '--gcp-network=test-5561de90af', '--check-leaked-resources', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gke-environment=test', '--image-family=pipeline-2', '--image-project=ubuntu-os-gke-cloud-devel', '--gcp-node-image=custom', '--extract=ci/k8s-stable3', '--gcp-project-type=gpu-project', '--timeout=180m', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-k80,count=2', '--gcp-zone=us-west1-b')' returned non-zero exit status 1
E0110 01:04:21.347] Command failed
I0110 01:04:21.348] process 268 exited with code 1 after 2.7m
E0110 01:04:21.348] FAIL: ci-kubernetes-e2e-gke-ubuntu2-k8sstable3-gpu
I0110 01:04:21.348] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0110 01:04:21.795] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0110 01:04:21.838] process 1392 exited with code 0 after 0.0m
I0110 01:04:21.838] Call:  gcloud config get-value account
I0110 01:04:22.100] process 1405 exited with code 0 after 0.0m
I0110 01:04:22.101] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0110 01:04:22.101] Upload result and artifacts...
I0110 01:04:22.101] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sstable3-gpu/1215438445392957440
I0110 01:04:22.101] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sstable3-gpu/1215438445392957440/artifacts
W0110 01:04:22.853] CommandException: One or more URLs matched no objects.
E0110 01:04:22.963] Command failed
I0110 01:04:22.963] process 1418 exited with code 1 after 0.0m
W0110 01:04:22.963] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sstable3-gpu/1215438445392957440/artifacts not exist yet
I0110 01:04:22.964] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sstable3-gpu/1215438445392957440/artifacts
I0110 01:04:24.348] process 1563 exited with code 0 after 0.0m
I0110 01:04:24.348] Call:  git rev-parse HEAD
W0110 01:04:24.352] fatal: not a git repository (or any of the parent directories): .git
E0110 01:04:24.352] Command failed
I0110 01:04:24.352] process 2090 exited with code 128 after 0.0m
I0110 01:04:24.352] Call:  git rev-parse HEAD
I0110 01:04:24.355] process 2091 exited with code 0 after 0.0m
I0110 01:04:24.356] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sstable3-gpu/jobResultsCache.json
I0110 01:04:25.247] process 2092 exited with code 0 after 0.0m
I0110 01:04:25.248] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sstable3-gpu/jobResultsCache.json#1578596780984924'
... skipping 8 lines ...