This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-01-10 13:01
Elapsed3m21s
Revision
Buildergke-prow-default-pool-cf4891d4-r4zq
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/ad7d8733-4d6b-4e7b-9b37-a3a481450626/targets/test'}}
pod35fe1375-33a9-11ea-a4dc-8213d962824c
resultstorehttps://source.cloud.google.com/results/invocations/ad7d8733-4d6b-4e7b-9b37-a3a481450626/targets/test
infra-commit1856252e3
job-versionv1.14.11-beta.1
pod35fe1375-33a9-11ea-a4dc-8213d962824c
revisionv1.14.11-beta.1

Test Failures


Up 55s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-gke-gpu-boskos-06 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-5561de90af --image-family=pipeline-2 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.14.11-beta.1 test-5561de90af: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0110 13:01:38.484] process 47 exited with code 0 after 0.0m
I0110 13:01:38.485] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0110 13:01:38.485] Root: /workspace
I0110 13:01:38.485] cd to /workspace
I0110 13:01:38.485] Configure environment...
I0110 13:01:38.486] Call:  git show -s --format=format:%ct HEAD
W0110 13:01:38.489] fatal: not a git repository (or any of the parent directories): .git
I0110 13:01:38.490] process 60 exited with code 128 after 0.0m
W0110 13:01:38.490] Unable to print commit date for HEAD
I0110 13:01:38.490] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0110 13:01:39.078] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0110 13:01:39.413] process 61 exited with code 0 after 0.0m
I0110 13:01:39.413] Call:  gcloud config get-value account
... skipping 426 lines ...
W0110 13:04:28.086] 2020/01/10 13:04:28 process.go:153: Running: gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-gke-gpu-boskos-06 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-5561de90af --image-family=pipeline-2 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.14.11-beta.1 test-5561de90af
W0110 13:04:28.702] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W0110 13:04:28.703] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W0110 13:04:28.703] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0110 13:04:28.703] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0110 13:04:28.703] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W0110 13:04:32.914] ERROR: (gcloud.container.clusters.create) ResponseError: code=400, message=Failure in zone us-west1-b due to tight resource constraints. You can either try again later or create another node pool in another zone and migrate workloads. (See https://cloud.google.com/kubernetes-engine/docs/tutorials/migrating-node-pool) Recommended alternative zone: us-west1-c).
W0110 13:04:32.998] 2020/01/10 13:04:32 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-gke-gpu-boskos-06 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-5561de90af --image-family=pipeline-2 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.14.11-beta.1 test-5561de90af' finished in 4.91164129s
W0110 13:04:35.686] 2020/01/10 13:04:35 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0110 13:04:49.753] 2020/01/10 13:04:49 main.go:316: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-gke-gpu-boskos-06 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-5561de90af --image-family=pipeline-2 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.14.11-beta.1 test-5561de90af: exit status 1
W0110 13:04:49.758] Traceback (most recent call last):
W0110 13:04:49.758]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W0110 13:04:49.758]     main(parse_args())
W0110 13:04:49.759]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W0110 13:04:49.759]     mode.start(runner_args)
W0110 13:04:49.759]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0110 13:04:49.759]     check_env(env, self.command, *args)
W0110 13:04:49.759]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0110 13:04:49.759]     subprocess.check_call(cmd, env=env)
W0110 13:04:49.759]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0110 13:04:49.760]     raise CalledProcessError(retcode, cmd)
W0110 13:04:49.761] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=test-5561de90af', '--gcp-network=test-5561de90af', '--check-leaked-resources', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gke-environment=test', '--image-family=pipeline-2', '--image-project=ubuntu-os-gke-cloud-devel', '--gcp-node-image=custom', '--extract=ci/k8s-stable3', '--gcp-project-type=gpu-project', '--timeout=180m', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-k80,count=2', '--gcp-zone=us-west1-b')' returned non-zero exit status 1
E0110 13:04:49.772] Command failed
I0110 13:04:49.772] process 268 exited with code 1 after 3.1m
E0110 13:04:49.772] FAIL: ci-kubernetes-e2e-gke-ubuntu2-k8sstable3-gpu
I0110 13:04:49.773] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0110 13:04:50.366] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0110 13:04:50.446] process 1391 exited with code 0 after 0.0m
I0110 13:04:50.446] Call:  gcloud config get-value account
I0110 13:04:50.845] process 1404 exited with code 0 after 0.0m
I0110 13:04:50.845] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0110 13:04:50.846] Upload result and artifacts...
I0110 13:04:50.846] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sstable3-gpu/1215619641112530946
I0110 13:04:50.846] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sstable3-gpu/1215619641112530946/artifacts
W0110 13:04:51.840] CommandException: One or more URLs matched no objects.
E0110 13:04:52.002] Command failed
I0110 13:04:52.003] process 1417 exited with code 1 after 0.0m
W0110 13:04:52.003] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sstable3-gpu/1215619641112530946/artifacts not exist yet
I0110 13:04:52.003] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sstable3-gpu/1215619641112530946/artifacts
I0110 13:04:53.921] process 1562 exited with code 0 after 0.0m
I0110 13:04:53.922] Call:  git rev-parse HEAD
W0110 13:04:53.926] fatal: not a git repository (or any of the parent directories): .git
E0110 13:04:53.926] Command failed
I0110 13:04:53.927] process 2089 exited with code 128 after 0.0m
I0110 13:04:53.927] Call:  git rev-parse HEAD
I0110 13:04:53.931] process 2090 exited with code 0 after 0.0m
I0110 13:04:53.931] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sstable3-gpu/jobResultsCache.json
I0110 13:04:55.061] process 2091 exited with code 0 after 0.0m
I0110 13:04:55.062] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sstable3-gpu/jobResultsCache.json#1578639879260616'
... skipping 8 lines ...