This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-01-10 19:01
Elapsed3m39s
Revision
Buildergke-prow-default-pool-cf4891d4-7vfm
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/ac64cdd4-a81c-4775-a01a-244384ef7d2e/targets/test'}}
pod81793e05-33db-11ea-a4dc-8213d962824c
resultstorehttps://source.cloud.google.com/results/invocations/ac64cdd4-a81c-4775-a01a-244384ef7d2e/targets/test
infra-commit68549e3e3
job-versionv1.14.11-beta.1
pod81793e05-33db-11ea-a4dc-8213d962824c
revisionv1.14.11-beta.1

Test Failures


Up 49s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-gke-gpu-boskos-05 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-5561de90af --image-family=pipeline-2 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.14.11-beta.1 test-5561de90af: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0110 19:01:38.520] process 47 exited with code 0 after 0.0m
I0110 19:01:38.521] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0110 19:01:38.521] Root: /workspace
I0110 19:01:38.521] cd to /workspace
I0110 19:01:38.521] Configure environment...
I0110 19:01:38.522] Call:  git show -s --format=format:%ct HEAD
W0110 19:01:38.525] fatal: not a git repository (or any of the parent directories): .git
I0110 19:01:38.526] process 60 exited with code 128 after 0.0m
W0110 19:01:38.526] Unable to print commit date for HEAD
I0110 19:01:38.526] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0110 19:01:39.006] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0110 19:01:39.327] process 61 exited with code 0 after 0.0m
I0110 19:01:39.327] Call:  gcloud config get-value account
... skipping 426 lines ...
W0110 19:04:42.409] 2020/01/10 19:04:42 process.go:153: Running: gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-gke-gpu-boskos-05 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-5561de90af --image-family=pipeline-2 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.14.11-beta.1 test-5561de90af
W0110 19:04:42.995] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W0110 19:04:42.995] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W0110 19:04:42.995] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0110 19:04:42.996] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0110 19:04:42.996] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W0110 19:04:47.237] ERROR: (gcloud.container.clusters.create) ResponseError: code=400, message=Failure in zone us-west1-b due to tight resource constraints. You can either try again later or create another node pool in another zone and migrate workloads. (See https://cloud.google.com/kubernetes-engine/docs/tutorials/migrating-node-pool) Recommended alternative zone: us-west1-c).
W0110 19:04:47.276] 2020/01/10 19:04:47 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-gke-gpu-boskos-05 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-5561de90af --image-family=pipeline-2 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.14.11-beta.1 test-5561de90af' finished in 4.874591396s
W0110 19:04:49.025] 2020/01/10 19:04:49 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0110 19:05:08.412] 2020/01/10 19:05:08 main.go:316: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-gke-gpu-boskos-05 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-5561de90af --image-family=pipeline-2 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.14.11-beta.1 test-5561de90af: exit status 1
W0110 19:05:08.415] Traceback (most recent call last):
W0110 19:05:08.415]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W0110 19:05:08.415]     main(parse_args())
W0110 19:05:08.416]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W0110 19:05:08.416]     mode.start(runner_args)
W0110 19:05:08.416]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0110 19:05:08.416]     check_env(env, self.command, *args)
W0110 19:05:08.416]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0110 19:05:08.416]     subprocess.check_call(cmd, env=env)
W0110 19:05:08.417]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0110 19:05:08.417]     raise CalledProcessError(retcode, cmd)
W0110 19:05:08.417] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=test-5561de90af', '--gcp-network=test-5561de90af', '--check-leaked-resources', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gke-environment=test', '--image-family=pipeline-2', '--image-project=ubuntu-os-gke-cloud-devel', '--gcp-node-image=custom', '--extract=ci/k8s-stable3', '--gcp-project-type=gpu-project', '--timeout=180m', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-k80,count=2', '--gcp-zone=us-west1-b')' returned non-zero exit status 1
E0110 19:05:08.424] Command failed
I0110 19:05:08.424] process 268 exited with code 1 after 3.5m
E0110 19:05:08.424] FAIL: ci-kubernetes-e2e-gke-ubuntu2-k8sstable3-gpu
I0110 19:05:08.424] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0110 19:05:08.965] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0110 19:05:09.012] process 1388 exited with code 0 after 0.0m
I0110 19:05:09.013] Call:  gcloud config get-value account
I0110 19:05:09.370] process 1401 exited with code 0 after 0.0m
I0110 19:05:09.371] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0110 19:05:09.371] Upload result and artifacts...
I0110 19:05:09.371] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sstable3-gpu/1215710238754213896
I0110 19:05:09.372] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sstable3-gpu/1215710238754213896/artifacts
W0110 19:05:10.390] CommandException: One or more URLs matched no objects.
E0110 19:05:10.498] Command failed
I0110 19:05:10.498] process 1414 exited with code 1 after 0.0m
W0110 19:05:10.498] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sstable3-gpu/1215710238754213896/artifacts not exist yet
I0110 19:05:10.498] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sstable3-gpu/1215710238754213896/artifacts
I0110 19:05:12.470] process 1559 exited with code 0 after 0.0m
I0110 19:05:12.471] Call:  git rev-parse HEAD
W0110 19:05:12.478] fatal: not a git repository (or any of the parent directories): .git
E0110 19:05:12.479] Command failed
I0110 19:05:12.479] process 2086 exited with code 128 after 0.0m
I0110 19:05:12.479] Call:  git rev-parse HEAD
I0110 19:05:12.484] process 2087 exited with code 0 after 0.0m
I0110 19:05:12.485] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sstable3-gpu/jobResultsCache.json
I0110 19:05:13.541] process 2088 exited with code 0 after 0.0m
I0110 19:05:13.542] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sstable3-gpu/jobResultsCache.json#1578661497649830'
... skipping 8 lines ...