This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-01-11 01:01
Elapsed4m11s
Revision
Buildergke-prow-default-pool-cf4891d4-2xkj
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/1f589dd2-aa2c-45e4-82d0-71280e4d0c65/targets/test'}}
podc35650c2-340d-11ea-9fef-d200904e1a96
resultstorehttps://source.cloud.google.com/results/invocations/1f589dd2-aa2c-45e4-82d0-71280e4d0c65/targets/test
infra-commit561dc2e96
job-versionv1.14.11-beta.1
podc35650c2-340d-11ea-9fef-d200904e1a96
revisionv1.14.11-beta.1

Test Failures


Up 51s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-jkns-e2e-gke-gpus-beta --zone=us-west1-b --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-5561de90af --image-family=pipeline-2 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.14.11-beta.1 test-5561de90af: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0111 01:01:17.355] process 47 exited with code 0 after 0.0m
I0111 01:01:17.355] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0111 01:01:17.356] Root: /workspace
I0111 01:01:17.356] cd to /workspace
I0111 01:01:17.356] Configure environment...
I0111 01:01:17.356] Call:  git show -s --format=format:%ct HEAD
W0111 01:01:17.362] fatal: not a git repository (or any of the parent directories): .git
I0111 01:01:17.363] process 60 exited with code 128 after 0.0m
W0111 01:01:17.363] Unable to print commit date for HEAD
I0111 01:01:17.363] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0111 01:01:18.007] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0111 01:01:18.376] process 61 exited with code 0 after 0.0m
I0111 01:01:18.376] Call:  gcloud config get-value account
... skipping 426 lines ...
W0111 01:04:40.468] 2020/01/11 01:04:40 process.go:153: Running: gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-jkns-e2e-gke-gpus-beta --zone=us-west1-b --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-5561de90af --image-family=pipeline-2 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.14.11-beta.1 test-5561de90af
W0111 01:04:41.037] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W0111 01:04:41.037] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W0111 01:04:41.037] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0111 01:04:41.038] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0111 01:04:41.038] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W0111 01:04:46.115] ERROR: (gcloud.container.clusters.create) ResponseError: code=400, message=Failure in zone us-west1-b due to tight resource constraints. You can either try again later or create another node pool in another zone and migrate workloads. (See https://cloud.google.com/kubernetes-engine/docs/tutorials/migrating-node-pool) Recommended alternative zone: us-west1-c).
W0111 01:04:46.189] 2020/01/11 01:04:46 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-jkns-e2e-gke-gpus-beta --zone=us-west1-b --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-5561de90af --image-family=pipeline-2 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.14.11-beta.1 test-5561de90af' finished in 5.720364526s
W0111 01:04:48.125] 2020/01/11 01:04:48 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0111 01:05:19.454] 2020/01/11 01:05:19 main.go:316: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-jkns-e2e-gke-gpus-beta --zone=us-west1-b --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-5561de90af --image-family=pipeline-2 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.14.11-beta.1 test-5561de90af: exit status 1
W0111 01:05:19.459] Traceback (most recent call last):
W0111 01:05:19.459]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W0111 01:05:19.460]     main(parse_args())
W0111 01:05:19.460]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W0111 01:05:19.460]     mode.start(runner_args)
W0111 01:05:19.460]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0111 01:05:19.460]     check_env(env, self.command, *args)
W0111 01:05:19.461]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0111 01:05:19.461]     subprocess.check_call(cmd, env=env)
W0111 01:05:19.461]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0111 01:05:19.461]     raise CalledProcessError(retcode, cmd)
W0111 01:05:19.462] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=test-5561de90af', '--gcp-network=test-5561de90af', '--check-leaked-resources', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gke-environment=test', '--image-family=pipeline-2', '--image-project=ubuntu-os-gke-cloud-devel', '--gcp-node-image=custom', '--extract=ci/k8s-stable3', '--gcp-project-type=gpu-project', '--timeout=180m', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-k80,count=2', '--gcp-zone=us-west1-b')' returned non-zero exit status 1
E0111 01:05:19.472] Command failed
I0111 01:05:19.473] process 268 exited with code 1 after 4.0m
E0111 01:05:19.473] FAIL: ci-kubernetes-e2e-gke-ubuntu2-k8sstable3-gpu
I0111 01:05:19.473] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0111 01:05:20.088] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0111 01:05:20.163] process 1390 exited with code 0 after 0.0m
I0111 01:05:20.163] Call:  gcloud config get-value account
I0111 01:05:20.605] process 1403 exited with code 0 after 0.0m
I0111 01:05:20.606] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0111 01:05:20.606] Upload result and artifacts...
I0111 01:05:20.606] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sstable3-gpu/1215800732771422211
I0111 01:05:20.607] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sstable3-gpu/1215800732771422211/artifacts
W0111 01:05:21.723] CommandException: One or more URLs matched no objects.
E0111 01:05:21.889] Command failed
I0111 01:05:21.890] process 1416 exited with code 1 after 0.0m
W0111 01:05:21.890] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sstable3-gpu/1215800732771422211/artifacts not exist yet
I0111 01:05:21.890] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sstable3-gpu/1215800732771422211/artifacts
I0111 01:05:23.714] process 1561 exited with code 0 after 0.0m
I0111 01:05:23.715] Call:  git rev-parse HEAD
W0111 01:05:23.720] fatal: not a git repository (or any of the parent directories): .git
E0111 01:05:23.721] Command failed
I0111 01:05:23.721] process 2088 exited with code 128 after 0.0m
I0111 01:05:23.721] Call:  git rev-parse HEAD
I0111 01:05:23.727] process 2089 exited with code 0 after 0.0m
I0111 01:05:23.727] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sstable3-gpu/jobResultsCache.json
I0111 01:05:24.913] process 2090 exited with code 0 after 0.0m
I0111 01:05:24.914] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sstable3-gpu/jobResultsCache.json#1578683115863977'
... skipping 8 lines ...