This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-01-11 19:01
Elapsed3m4s
Revision
Buildergke-prow-default-pool-cf4891d4-q0h1
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/b0f52842-5a24-4e3e-ad98-b98d05909c38/targets/test'}}
poda296f28f-34a4-11ea-9fef-d200904e1a96
resultstorehttps://source.cloud.google.com/results/invocations/b0f52842-5a24-4e3e-ad98-b98d05909c38/targets/test
infra-commitb82ca85d5
job-versionv1.14.11-beta.1
poda296f28f-34a4-11ea-9fef-d200904e1a96
revisionv1.14.11-beta.1

Test Failures


Up 55s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-gke-gpu-boskos-08 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-5561de90af --image-family=pipeline-2 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.14.11-beta.1 test-5561de90af: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0111 19:01:10.366] process 47 exited with code 0 after 0.0m
I0111 19:01:10.366] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0111 19:01:10.366] Root: /workspace
I0111 19:01:10.367] cd to /workspace
I0111 19:01:10.367] Configure environment...
I0111 19:01:10.367] Call:  git show -s --format=format:%ct HEAD
W0111 19:01:10.371] fatal: not a git repository (or any of the parent directories): .git
I0111 19:01:10.371] process 60 exited with code 128 after 0.0m
W0111 19:01:10.371] Unable to print commit date for HEAD
I0111 19:01:10.372] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0111 19:01:10.917] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0111 19:01:11.268] process 61 exited with code 0 after 0.0m
I0111 19:01:11.268] Call:  gcloud config get-value account
... skipping 426 lines ...
W0111 19:03:48.131] 2020/01/11 19:03:48 process.go:153: Running: gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-gke-gpu-boskos-08 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-5561de90af --image-family=pipeline-2 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.14.11-beta.1 test-5561de90af
W0111 19:03:48.601] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W0111 19:03:48.602] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W0111 19:03:48.602] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0111 19:03:48.603] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0111 19:03:48.603] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W0111 19:03:53.655] ERROR: (gcloud.container.clusters.create) ResponseError: code=400, message=Failure in zone us-west1-b due to tight resource constraints. You can either try again later or create another node pool in another zone and migrate workloads. (See https://cloud.google.com/kubernetes-engine/docs/tutorials/migrating-node-pool) Recommended alternative zone: us-west1-c).
W0111 19:03:53.703] 2020/01/11 19:03:53 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-gke-gpu-boskos-08 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-5561de90af --image-family=pipeline-2 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.14.11-beta.1 test-5561de90af' finished in 5.594400994s
W0111 19:03:55.429] 2020/01/11 19:03:55 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0111 19:04:06.133] 2020/01/11 19:04:06 main.go:316: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-gke-gpu-boskos-08 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-5561de90af --image-family=pipeline-2 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.14.11-beta.1 test-5561de90af: exit status 1
W0111 19:04:06.137] Traceback (most recent call last):
W0111 19:04:06.137]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W0111 19:04:06.138]     main(parse_args())
W0111 19:04:06.138]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W0111 19:04:06.138]     mode.start(runner_args)
W0111 19:04:06.138]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0111 19:04:06.138]     check_env(env, self.command, *args)
W0111 19:04:06.139]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0111 19:04:06.139]     subprocess.check_call(cmd, env=env)
W0111 19:04:06.139]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0111 19:04:06.139]     raise CalledProcessError(retcode, cmd)
W0111 19:04:06.140] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=test-5561de90af', '--gcp-network=test-5561de90af', '--check-leaked-resources', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gke-environment=test', '--image-family=pipeline-2', '--image-project=ubuntu-os-gke-cloud-devel', '--gcp-node-image=custom', '--extract=ci/k8s-stable3', '--gcp-project-type=gpu-project', '--timeout=180m', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-k80,count=2', '--gcp-zone=us-west1-b')' returned non-zero exit status 1
E0111 19:04:06.148] Command failed
I0111 19:04:06.149] process 268 exited with code 1 after 2.9m
E0111 19:04:06.149] FAIL: ci-kubernetes-e2e-gke-ubuntu2-k8sstable3-gpu
I0111 19:04:06.149] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0111 19:04:06.678] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0111 19:04:06.733] process 1392 exited with code 0 after 0.0m
I0111 19:04:06.733] Call:  gcloud config get-value account
I0111 19:04:07.078] process 1405 exited with code 0 after 0.0m
I0111 19:04:07.079] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0111 19:04:07.079] Upload result and artifacts...
I0111 19:04:07.079] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sstable3-gpu/1216072515101659137
I0111 19:04:07.079] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sstable3-gpu/1216072515101659137/artifacts
W0111 19:04:07.963] CommandException: One or more URLs matched no objects.
E0111 19:04:08.083] Command failed
I0111 19:04:08.083] process 1418 exited with code 1 after 0.0m
W0111 19:04:08.083] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sstable3-gpu/1216072515101659137/artifacts not exist yet
I0111 19:04:08.083] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sstable3-gpu/1216072515101659137/artifacts
I0111 19:04:09.909] process 1563 exited with code 0 after 0.0m
I0111 19:04:09.910] Call:  git rev-parse HEAD
W0111 19:04:09.914] fatal: not a git repository (or any of the parent directories): .git
E0111 19:04:09.915] Command failed
I0111 19:04:09.915] process 2090 exited with code 128 after 0.0m
I0111 19:04:09.915] Call:  git rev-parse HEAD
I0111 19:04:09.919] process 2091 exited with code 0 after 0.0m
I0111 19:04:09.920] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sstable3-gpu/jobResultsCache.json
I0111 19:04:10.970] process 2092 exited with code 0 after 0.0m
I0111 19:04:10.971] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sstable3-gpu/jobResultsCache.json#1578747916276861'
... skipping 8 lines ...