This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-01-13 07:01
Elapsed4m0s
Revision
Buildergke-prow-default-pool-cf4891d4-j7n5
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/645d83f8-7021-48a5-964b-b7bc1a50f907/targets/test'}}
pod60cbe10b-35d2-11ea-9fef-d200904e1a96
resultstorehttps://source.cloud.google.com/results/invocations/645d83f8-7021-48a5-964b-b7bc1a50f907/targets/test
infra-commit5b37d6c80
job-versionv1.14.11-beta.1
pod60cbe10b-35d2-11ea-9fef-d200904e1a96
revisionv1.14.11-beta.1

Test Failures


Up 51s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-jkns-e2e-gke-plugin-gpus --zone=us-west1-b --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-5561de90af --image-family=pipeline-2 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.14.11-beta.1 test-5561de90af: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0113 07:01:14.238] process 47 exited with code 0 after 0.0m
I0113 07:01:14.238] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0113 07:01:14.238] Root: /workspace
I0113 07:01:14.239] cd to /workspace
I0113 07:01:14.239] Configure environment...
I0113 07:01:14.239] Call:  git show -s --format=format:%ct HEAD
W0113 07:01:14.248] fatal: not a git repository (or any of the parent directories): .git
I0113 07:01:14.250] process 60 exited with code 128 after 0.0m
W0113 07:01:14.250] Unable to print commit date for HEAD
I0113 07:01:14.251] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0113 07:01:15.036] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0113 07:01:15.379] process 61 exited with code 0 after 0.0m
I0113 07:01:15.380] Call:  gcloud config get-value account
... skipping 426 lines ...
W0113 07:04:47.139] 2020/01/13 07:04:47 process.go:153: Running: gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-jkns-e2e-gke-plugin-gpus --zone=us-west1-b --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-5561de90af --image-family=pipeline-2 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.14.11-beta.1 test-5561de90af
W0113 07:04:47.828] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W0113 07:04:47.829] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W0113 07:04:47.829] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0113 07:04:47.829] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0113 07:04:47.829] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W0113 07:04:52.846] ERROR: (gcloud.container.clusters.create) ResponseError: code=400, message=Failure in zone us-west1-b due to tight resource constraints. You can either try again later or create another node pool in another zone and migrate workloads. (See https://cloud.google.com/kubernetes-engine/docs/tutorials/migrating-node-pool) Recommended alternative zone: us-west1-a).
W0113 07:04:52.929] 2020/01/13 07:04:52 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-jkns-e2e-gke-plugin-gpus --zone=us-west1-b --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-5561de90af --image-family=pipeline-2 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.14.11-beta.1 test-5561de90af' finished in 5.789922149s
W0113 07:04:55.444] 2020/01/13 07:04:55 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0113 07:04:57.368] 2020/01/13 07:04:57 main.go:316: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-jkns-e2e-gke-plugin-gpus --zone=us-west1-b --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-5561de90af --image-family=pipeline-2 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.14.11-beta.1 test-5561de90af: exit status 1
W0113 07:04:57.392] Traceback (most recent call last):
W0113 07:04:57.392]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W0113 07:04:57.392]     main(parse_args())
W0113 07:04:57.392]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W0113 07:04:57.393]     mode.start(runner_args)
W0113 07:04:57.393]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0113 07:04:57.393]     check_env(env, self.command, *args)
W0113 07:04:57.393]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0113 07:04:57.394]     subprocess.check_call(cmd, env=env)
W0113 07:04:57.394]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0113 07:04:57.394]     raise CalledProcessError(retcode, cmd)
W0113 07:04:57.395] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=test-5561de90af', '--gcp-network=test-5561de90af', '--check-leaked-resources', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gke-environment=test', '--image-family=pipeline-2', '--image-project=ubuntu-os-gke-cloud-devel', '--gcp-node-image=custom', '--extract=ci/k8s-stable3', '--gcp-project-type=gpu-project', '--timeout=180m', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-k80,count=2', '--gcp-zone=us-west1-b')' returned non-zero exit status 1
E0113 07:04:57.402] Command failed
I0113 07:04:57.403] process 268 exited with code 1 after 3.7m
E0113 07:04:57.403] FAIL: ci-kubernetes-e2e-gke-ubuntu2-k8sstable3-gpu
I0113 07:04:57.403] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0113 07:04:58.461] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0113 07:04:58.577] process 1387 exited with code 0 after 0.0m
I0113 07:04:58.578] Call:  gcloud config get-value account
I0113 07:04:59.283] process 1400 exited with code 0 after 0.0m
I0113 07:04:59.283] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0113 07:04:59.283] Upload result and artifacts...
I0113 07:04:59.283] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sstable3-gpu/1216616085365723138
I0113 07:04:59.284] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sstable3-gpu/1216616085365723138/artifacts
W0113 07:05:01.417] CommandException: One or more URLs matched no objects.
E0113 07:05:01.721] Command failed
I0113 07:05:01.721] process 1413 exited with code 1 after 0.0m
W0113 07:05:01.721] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sstable3-gpu/1216616085365723138/artifacts not exist yet
I0113 07:05:01.722] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sstable3-gpu/1216616085365723138/artifacts
I0113 07:05:05.265] process 1558 exited with code 0 after 0.1m
I0113 07:05:05.266] Call:  git rev-parse HEAD
W0113 07:05:05.274] fatal: not a git repository (or any of the parent directories): .git
E0113 07:05:05.275] Command failed
I0113 07:05:05.276] process 2085 exited with code 128 after 0.0m
I0113 07:05:05.277] Call:  git rev-parse HEAD
I0113 07:05:05.292] process 2086 exited with code 0 after 0.0m
I0113 07:05:05.293] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sstable3-gpu/jobResultsCache.json
I0113 07:05:07.600] process 2087 exited with code 0 after 0.0m
I0113 07:05:07.601] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sstable3-gpu/jobResultsCache.json#1578877420451267'
... skipping 8 lines ...