This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-01-14 19:01
Elapsed4m29s
Revision
Buildergke-prow-default-pool-cf4891d4-6sc2
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/2e8df4e5-77a4-4433-a907-c9930f0734a8/targets/test'}}
pod2473aa52-3700-11ea-9f20-3687633bf296
resultstorehttps://source.cloud.google.com/results/invocations/2e8df4e5-77a4-4433-a907-c9930f0734a8/targets/test
infra-commit46f5c0669
job-versionv1.14.11-beta.1
pod2473aa52-3700-11ea-9f20-3687633bf296
revisionv1.14.11-beta.1

Test Failures


Up 52s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-gke-gpu-boskos-09 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-5561de90af --image-family=pipeline-2 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.14.11-beta.1 test-5561de90af: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0114 19:01:39.373] process 47 exited with code 0 after 0.0m
I0114 19:01:39.374] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0114 19:01:39.374] Root: /workspace
I0114 19:01:39.374] cd to /workspace
I0114 19:01:39.374] Configure environment...
I0114 19:01:39.375] Call:  git show -s --format=format:%ct HEAD
W0114 19:01:39.389] fatal: not a git repository (or any of the parent directories): .git
I0114 19:01:39.389] process 60 exited with code 128 after 0.0m
W0114 19:01:39.390] Unable to print commit date for HEAD
I0114 19:01:39.390] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0114 19:01:40.744] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0114 19:01:41.237] process 61 exited with code 0 after 0.0m
I0114 19:01:41.237] Call:  gcloud config get-value account
... skipping 426 lines ...
W0114 19:05:33.193] 2020/01/14 19:05:33 process.go:153: Running: gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-gke-gpu-boskos-09 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-5561de90af --image-family=pipeline-2 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.14.11-beta.1 test-5561de90af
W0114 19:05:34.177] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W0114 19:05:34.178] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W0114 19:05:34.178] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0114 19:05:34.178] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0114 19:05:34.178] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W0114 19:05:38.785] ERROR: (gcloud.container.clusters.create) ResponseError: code=400, message=Failure in zone us-west1-b due to tight resource constraints. You can either try again later or create another node pool in another zone and migrate workloads. (See https://cloud.google.com/kubernetes-engine/docs/tutorials/migrating-node-pool) Recommended alternative zone: us-west1-c).
W0114 19:05:38.866] 2020/01/14 19:05:38 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-gke-gpu-boskos-09 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-5561de90af --image-family=pipeline-2 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.14.11-beta.1 test-5561de90af' finished in 5.680541529s
W0114 19:05:42.360] 2020/01/14 19:05:42 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0114 19:05:48.897] 2020/01/14 19:05:48 main.go:316: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-gke-gpu-boskos-09 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-5561de90af --image-family=pipeline-2 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.14.11-beta.1 test-5561de90af: exit status 1
W0114 19:05:48.902] Traceback (most recent call last):
W0114 19:05:48.902]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W0114 19:05:48.904]     main(parse_args())
W0114 19:05:48.904]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W0114 19:05:48.905]     mode.start(runner_args)
W0114 19:05:48.905]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0114 19:05:48.905]     check_env(env, self.command, *args)
W0114 19:05:48.905]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0114 19:05:48.905]     subprocess.check_call(cmd, env=env)
W0114 19:05:48.905]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0114 19:05:48.905]     raise CalledProcessError(retcode, cmd)
W0114 19:05:48.906] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=test-5561de90af', '--gcp-network=test-5561de90af', '--check-leaked-resources', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gke-environment=test', '--image-family=pipeline-2', '--image-project=ubuntu-os-gke-cloud-devel', '--gcp-node-image=custom', '--extract=ci/k8s-stable3', '--gcp-project-type=gpu-project', '--timeout=180m', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-k80,count=2', '--gcp-zone=us-west1-b')' returned non-zero exit status 1
E0114 19:05:48.922] Command failed
I0114 19:05:48.922] process 268 exited with code 1 after 4.1m
E0114 19:05:48.922] FAIL: ci-kubernetes-e2e-gke-ubuntu2-k8sstable3-gpu
I0114 19:05:48.922] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0114 19:05:50.239] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0114 19:05:50.501] process 1389 exited with code 0 after 0.0m
I0114 19:05:50.501] Call:  gcloud config get-value account
I0114 19:05:51.356] process 1402 exited with code 0 after 0.0m
I0114 19:05:51.356] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0114 19:05:51.356] Upload result and artifacts...
I0114 19:05:51.357] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sstable3-gpu/1217159699057610752
I0114 19:05:51.357] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sstable3-gpu/1217159699057610752/artifacts
W0114 19:05:53.377] CommandException: One or more URLs matched no objects.
E0114 19:05:53.801] Command failed
I0114 19:05:53.801] process 1415 exited with code 1 after 0.0m
W0114 19:05:53.802] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sstable3-gpu/1217159699057610752/artifacts not exist yet
I0114 19:05:53.802] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sstable3-gpu/1217159699057610752/artifacts
I0114 19:05:58.021] process 1560 exited with code 0 after 0.1m
I0114 19:05:58.022] Call:  git rev-parse HEAD
W0114 19:05:58.034] fatal: not a git repository (or any of the parent directories): .git
E0114 19:05:58.041] Command failed
I0114 19:05:58.041] process 2087 exited with code 128 after 0.0m
I0114 19:05:58.042] Call:  git rev-parse HEAD
I0114 19:05:58.071] process 2088 exited with code 0 after 0.0m
I0114 19:05:58.072] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sstable3-gpu/jobResultsCache.json
I0114 19:06:00.469] process 2089 exited with code 0 after 0.0m
I0114 19:06:00.470] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sstable3-gpu/jobResultsCache.json#1579007092923965'
... skipping 8 lines ...