This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-01-15 13:00
Elapsed3m20s
Revision
Buildergke-prow-default-pool-cf4891d4-t4sm
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/4d3eff48-8700-4f86-be00-17f7d00c9446/targets/test'}}
podf243304f-3796-11ea-8603-da2f7a5855b4
resultstorehttps://source.cloud.google.com/results/invocations/4d3eff48-8700-4f86-be00-17f7d00c9446/targets/test
infra-commitff065cbb3
job-versionv1.14.11-beta.1
podf243304f-3796-11ea-8603-da2f7a5855b4
revisionv1.14.11-beta.1

Test Failures


Up 50s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-gke-gpu-boskos-05 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-5561de90af --image-family=pipeline-2 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.14.11-beta.1 test-5561de90af: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0115 13:00:54.495] process 48 exited with code 0 after 0.0m
I0115 13:00:54.495] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0115 13:00:54.495] Root: /workspace
I0115 13:00:54.495] cd to /workspace
I0115 13:00:54.496] Configure environment...
I0115 13:00:54.496] Call:  git show -s --format=format:%ct HEAD
W0115 13:00:54.502] fatal: not a git repository (or any of the parent directories): .git
I0115 13:00:54.502] process 61 exited with code 128 after 0.0m
W0115 13:00:54.502] Unable to print commit date for HEAD
I0115 13:00:54.503] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0115 13:00:55.159] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0115 13:00:55.500] process 62 exited with code 0 after 0.0m
I0115 13:00:55.501] Call:  gcloud config get-value account
... skipping 426 lines ...
W0115 13:03:54.166] 2020/01/15 13:03:54 process.go:153: Running: gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-gke-gpu-boskos-05 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-5561de90af --image-family=pipeline-2 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.14.11-beta.1 test-5561de90af
W0115 13:03:54.791] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W0115 13:03:54.792] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W0115 13:03:54.792] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0115 13:03:54.792] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0115 13:03:54.792] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W0115 13:03:59.186] ERROR: (gcloud.container.clusters.create) ResponseError: code=400, message=Failure in zone us-west1-b due to tight resource constraints. You can either try again later or create another node pool in another zone and migrate workloads. (See https://cloud.google.com/kubernetes-engine/docs/tutorials/migrating-node-pool) Recommended alternative zone: us-west1-c).
W0115 13:03:59.255] 2020/01/15 13:03:59 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-gke-gpu-boskos-05 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-5561de90af --image-family=pipeline-2 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.14.11-beta.1 test-5561de90af' finished in 5.090993985s
W0115 13:04:01.160] 2020/01/15 13:04:01 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0115 13:04:04.852] 2020/01/15 13:04:04 main.go:316: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-gke-gpu-boskos-05 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-5561de90af --image-family=pipeline-2 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.14.11-beta.1 test-5561de90af: exit status 1
W0115 13:04:04.862] Traceback (most recent call last):
W0115 13:04:04.862]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W0115 13:04:04.863]     main(parse_args())
W0115 13:04:04.863]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W0115 13:04:04.863]     mode.start(runner_args)
W0115 13:04:04.863]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0115 13:04:04.863]     check_env(env, self.command, *args)
W0115 13:04:04.864]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0115 13:04:04.864]     subprocess.check_call(cmd, env=env)
W0115 13:04:04.864]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0115 13:04:04.864]     raise CalledProcessError(retcode, cmd)
W0115 13:04:04.865] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=test-5561de90af', '--gcp-network=test-5561de90af', '--check-leaked-resources', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gke-environment=test', '--image-family=pipeline-2', '--image-project=ubuntu-os-gke-cloud-devel', '--gcp-node-image=custom', '--extract=ci/k8s-stable3', '--gcp-project-type=gpu-project', '--timeout=180m', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-k80,count=2', '--gcp-zone=us-west1-b')' returned non-zero exit status 1
E0115 13:04:04.876] Command failed
I0115 13:04:04.876] process 269 exited with code 1 after 3.1m
E0115 13:04:04.877] FAIL: ci-kubernetes-e2e-gke-ubuntu2-k8sstable3-gpu
I0115 13:04:04.877] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0115 13:04:05.485] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0115 13:04:05.564] process 1390 exited with code 0 after 0.0m
I0115 13:04:05.564] Call:  gcloud config get-value account
I0115 13:04:05.966] process 1403 exited with code 0 after 0.0m
I0115 13:04:05.966] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0115 13:04:05.967] Upload result and artifacts...
I0115 13:04:05.967] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sstable3-gpu/1217431389020884993
I0115 13:04:05.968] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sstable3-gpu/1217431389020884993/artifacts
W0115 13:04:07.071] CommandException: One or more URLs matched no objects.
E0115 13:04:07.270] Command failed
I0115 13:04:07.270] process 1416 exited with code 1 after 0.0m
W0115 13:04:07.270] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sstable3-gpu/1217431389020884993/artifacts not exist yet
I0115 13:04:07.270] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sstable3-gpu/1217431389020884993/artifacts
I0115 13:04:09.443] process 1561 exited with code 0 after 0.0m
I0115 13:04:09.444] Call:  git rev-parse HEAD
W0115 13:04:09.448] fatal: not a git repository (or any of the parent directories): .git
E0115 13:04:09.449] Command failed
I0115 13:04:09.450] process 2088 exited with code 128 after 0.0m
I0115 13:04:09.450] Call:  git rev-parse HEAD
I0115 13:04:09.456] process 2089 exited with code 0 after 0.0m
I0115 13:04:09.456] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sstable3-gpu/jobResultsCache.json
I0115 13:04:10.657] process 2090 exited with code 0 after 0.0m
I0115 13:04:10.658] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sstable3-gpu/jobResultsCache.json#1579071811614524'
... skipping 8 lines ...