This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-01-16 19:00
Elapsed3m27s
Revision
Buildergke-prow-default-pool-cf4891d4-mzhc
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/1ef6dd13-d770-40f9-a40f-04f61a15e750/targets/test'}}
pod69a57672-3892-11ea-8f3e-66e48c863062
resultstorehttps://source.cloud.google.com/results/invocations/1ef6dd13-d770-40f9-a40f-04f61a15e750/targets/test
infra-commit52fe941d7
job-versionv1.14.11-beta.1
pod69a57672-3892-11ea-8f3e-66e48c863062
revisionv1.14.11-beta.1

Test Failures


Up 55s

error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-gke-gpu-boskos-03 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-5561de90af --image-family=pipeline-2 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.14.11-beta.1 test-5561de90af: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0116 19:00:52.316] process 47 exited with code 0 after 0.0m
I0116 19:00:52.316] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0116 19:00:52.317] Root: /workspace
I0116 19:00:52.317] cd to /workspace
I0116 19:00:52.317] Configure environment...
I0116 19:00:52.318] Call:  git show -s --format=format:%ct HEAD
W0116 19:00:52.322] fatal: not a git repository (or any of the parent directories): .git
I0116 19:00:52.323] process 60 exited with code 128 after 0.0m
W0116 19:00:52.323] Unable to print commit date for HEAD
I0116 19:00:52.323] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0116 19:00:52.918] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0116 19:00:53.253] process 61 exited with code 0 after 0.0m
I0116 19:00:53.253] Call:  gcloud config get-value account
... skipping 426 lines ...
W0116 19:04:00.455] 2020/01/16 19:04:00 process.go:153: Running: gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-gke-gpu-boskos-03 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-5561de90af --image-family=pipeline-2 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.14.11-beta.1 test-5561de90af
W0116 19:04:00.923] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W0116 19:04:00.924] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W0116 19:04:00.924] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0116 19:04:00.924] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0116 19:04:00.924] Machines with GPUs have certain limitations which may affect your workflow. Learn more at https://cloud.google.com/kubernetes-engine/docs/how-to/gpus
W0116 19:04:05.979] ERROR: (gcloud.container.clusters.create) ResponseError: code=400, message=Failure in zone us-west1-b due to tight resource constraints. You can either try again later or create another node pool in another zone and migrate workloads. (See https://cloud.google.com/kubernetes-engine/docs/tutorials/migrating-node-pool) Recommended alternative zone: us-west1-c).
W0116 19:04:06.041] 2020/01/16 19:04:06 process.go:155: Step 'gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-gke-gpu-boskos-03 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-5561de90af --image-family=pipeline-2 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.14.11-beta.1 test-5561de90af' finished in 5.601344288s
W0116 19:04:07.825] 2020/01/16 19:04:07 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0116 19:04:10.202] 2020/01/16 19:04:10 main.go:316: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --accelerator=type=nvidia-tesla-k80,count=2 --project=k8s-gke-gpu-boskos-03 --zone=us-west1-b --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-5561de90af --image-family=pipeline-2 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.14.11-beta.1 test-5561de90af: exit status 1
W0116 19:04:10.207] Traceback (most recent call last):
W0116 19:04:10.207]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W0116 19:04:10.208]     main(parse_args())
W0116 19:04:10.208]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W0116 19:04:10.208]     mode.start(runner_args)
W0116 19:04:10.208]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0116 19:04:10.208]     check_env(env, self.command, *args)
W0116 19:04:10.209]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0116 19:04:10.209]     subprocess.check_call(cmd, env=env)
W0116 19:04:10.209]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0116 19:04:10.209]     raise CalledProcessError(retcode, cmd)
W0116 19:04:10.210] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=test-5561de90af', '--gcp-network=test-5561de90af', '--check-leaked-resources', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gke-environment=test', '--image-family=pipeline-2', '--image-project=ubuntu-os-gke-cloud-devel', '--gcp-node-image=custom', '--extract=ci/k8s-stable3', '--gcp-project-type=gpu-project', '--timeout=180m', '--test_args=--ginkgo.focus=\\[Feature:GPUDevicePlugin\\] --minStartupPods=8', '--gke-create-command=container clusters create --accelerator=type=nvidia-tesla-k80,count=2', '--gcp-zone=us-west1-b')' returned non-zero exit status 1
E0116 19:04:10.219] Command failed
I0116 19:04:10.219] process 268 exited with code 1 after 3.2m
E0116 19:04:10.220] FAIL: ci-kubernetes-e2e-gke-ubuntu2-k8sstable3-gpu
I0116 19:04:10.220] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0116 19:04:11.155] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0116 19:04:11.218] process 1387 exited with code 0 after 0.0m
I0116 19:04:11.218] Call:  gcloud config get-value account
I0116 19:04:11.592] process 1400 exited with code 0 after 0.0m
I0116 19:04:11.592] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0116 19:04:11.592] Upload result and artifacts...
I0116 19:04:11.593] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sstable3-gpu/1217884363392290819
I0116 19:04:11.593] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sstable3-gpu/1217884363392290819/artifacts
W0116 19:04:12.582] CommandException: One or more URLs matched no objects.
E0116 19:04:12.733] Command failed
I0116 19:04:12.733] process 1413 exited with code 1 after 0.0m
W0116 19:04:12.733] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sstable3-gpu/1217884363392290819/artifacts not exist yet
I0116 19:04:12.734] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sstable3-gpu/1217884363392290819/artifacts
I0116 19:04:14.383] process 1558 exited with code 0 after 0.0m
I0116 19:04:14.384] Call:  git rev-parse HEAD
W0116 19:04:14.389] fatal: not a git repository (or any of the parent directories): .git
E0116 19:04:14.389] Command failed
I0116 19:04:14.389] process 2085 exited with code 128 after 0.0m
I0116 19:04:14.390] Call:  git rev-parse HEAD
I0116 19:04:14.396] process 2086 exited with code 0 after 0.0m
I0116 19:04:14.396] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sstable3-gpu/jobResultsCache.json
I0116 19:04:15.407] process 2087 exited with code 0 after 0.0m
I0116 19:04:15.408] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sstable3-gpu/jobResultsCache.json#1579179866876898'
... skipping 8 lines ...