This job view page is being replaced by Spyglass soon. Check out the new job view.
ResultFAILURE
Tests 1 failed / 6 succeeded
Started2020-01-09 22:13
Elapsed5m56s
Revision
Buildergke-prow-default-pool-cf4891d4-ptlr
links{u'resultstore': {u'url': u'https://source.cloud.google.com/results/invocations/20d72c2d-0ba3-4e1c-82b9-61dd2fed3946/targets/test'}}
pod28d1dc05-332d-11ea-a4dc-8213d962824c
resultstorehttps://source.cloud.google.com/results/invocations/20d72c2d-0ba3-4e1c-82b9-61dd2fed3946/targets/test
infra-commitdd307d2a7
job-versionv1.14.11-beta.1
pod28d1dc05-332d-11ea-a4dc-8213d962824c
revisionv1.14.11-beta.1

Test Failures


Up 45s

error creating cluster: error during gcloud container clusters create --quiet --project=k8s-jkns-e2e-gci-gke-prod --zone=us-west1-b --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-9120335ea7 --image-family=pipeline-2 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.14.11-beta.1 test-9120335ea7: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 6 Passed Tests

Error lines from build-log.txt

... skipping 15 lines ...
I0109 22:13:42.855] process 48 exited with code 0 after 0.0m
I0109 22:13:42.856] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0109 22:13:42.856] Root: /workspace
I0109 22:13:42.856] cd to /workspace
I0109 22:13:42.856] Configure environment...
I0109 22:13:42.857] Call:  git show -s --format=format:%ct HEAD
W0109 22:13:42.861] fatal: not a git repository (or any of the parent directories): .git
I0109 22:13:42.861] process 61 exited with code 128 after 0.0m
W0109 22:13:42.861] Unable to print commit date for HEAD
I0109 22:13:42.861] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0109 22:13:43.425] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0109 22:13:43.756] process 62 exited with code 0 after 0.0m
I0109 22:13:43.756] Call:  gcloud config get-value account
... skipping 420 lines ...
W0109 22:17:44.220] 2020/01/09 22:17:44 process.go:155: Step 'gcloud compute networks create test-9120335ea7 --project=k8s-jkns-e2e-gci-gke-prod --subnet-mode=auto' finished in 43.539554405s
W0109 22:17:44.220] 2020/01/09 22:17:44 process.go:153: Running: gcloud container clusters create --quiet --project=k8s-jkns-e2e-gci-gke-prod --zone=us-west1-b --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-9120335ea7 --image-family=pipeline-2 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.14.11-beta.1 test-9120335ea7
W0109 22:17:44.690] WARNING: Currently VPC-native is not the default mode during cluster creation. In the future, this will become the default mode and can be disabled using `--no-enable-ip-alias` flag. Use `--[no-]enable-ip-alias` flag to suppress this warning.
W0109 22:17:44.691] WARNING: Starting in 1.12, default node pools in new clusters will have their legacy Compute Engine instance metadata endpoints disabled by default. To create a cluster with legacy instance metadata endpoints disabled in the default node pool, run `clusters create` with the flag `--metadata disable-legacy-endpoints=true`.
W0109 22:17:44.691] WARNING: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s). 
W0109 22:17:44.692] This will disable the autorepair feature for nodes. Please see https://cloud.google.com/kubernetes-engine/docs/node-auto-repair for more information on node autorepairs.
W0109 22:17:45.695] ERROR: (gcloud.container.clusters.create) ResponseError: code=400, message=Error resolving image from image family "pipeline-2" in project "ubuntu-os-gke-cloud-devel": ROBOT_ERROR: Kubernetes Engine API is not enabled for this project. Please ensure it is enabled in Google Cloud Console and try again: visit https://console.cloud.google.com/apis/api/test-container.sandbox.googleapis.com/overview?project=k8s-jkns-e2e-gci-gke-prod to do so.
W0109 22:17:45.744] 2020/01/09 22:17:45 process.go:155: Step 'gcloud container clusters create --quiet --project=k8s-jkns-e2e-gci-gke-prod --zone=us-west1-b --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-9120335ea7 --image-family=pipeline-2 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.14.11-beta.1 test-9120335ea7' finished in 1.527517099s
W0109 22:17:47.396] 2020/01/09 22:17:47 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0109 22:19:23.915] 2020/01/09 22:19:23 main.go:316: Something went wrong: starting e2e cluster: error creating cluster: error during gcloud container clusters create --quiet --project=k8s-jkns-e2e-gci-gke-prod --zone=us-west1-b --machine-type=n1-standard-2 --image-type=custom --num-nodes=3 --network=test-9120335ea7 --image-family=pipeline-2 --image-project=ubuntu-os-gke-cloud-devel --no-enable-autoupgrade --cluster-version=1.14.11-beta.1 test-9120335ea7: exit status 1
W0109 22:19:23.948] Traceback (most recent call last):
W0109 22:19:23.948]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 778, in <module>
W0109 22:19:23.948]     main(parse_args())
W0109 22:19:23.949]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 626, in main
W0109 22:19:23.949]     mode.start(runner_args)
W0109 22:19:23.949]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 262, in start
W0109 22:19:23.949]     check_env(env, self.command, *args)
W0109 22:19:23.949]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0109 22:19:23.949]     subprocess.check_call(cmd, env=env)
W0109 22:19:23.949]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0109 22:19:23.950]     raise CalledProcessError(retcode, cmd)
W0109 22:19:23.950] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=gke', '--provider=gke', '--cluster=test-9120335ea7', '--gcp-network=test-9120335ea7', '--check-leaked-resources', '--gcp-zone=us-west1-b', '--gcp-cloud-sdk=gs://cloud-sdk-testing/ci/staging', '--gke-environment=test', '--image-family=pipeline-2', '--image-project=ubuntu-os-gke-cloud-devel', '--gcp-node-image=custom', '--extract=ci/k8s-stable3', '--timeout=660m', '--test_args=--ginkgo.focus=\\[Serial\\]|\\[Disruptive\\] --ginkgo.skip=\\[Flaky\\]|\\[Feature:.+\\] --minStartupPods=8', '--ginkgo-parallel=1')' returned non-zero exit status 1
E0109 22:19:23.951] Command failed
I0109 22:19:23.951] process 269 exited with code 1 after 5.6m
E0109 22:19:23.951] FAIL: ci-kubernetes-e2e-gke-ubuntu2-k8sstable3-serial
I0109 22:19:23.952] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0109 22:19:24.762] Activated service account credentials for: [pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com]
I0109 22:19:24.838] process 1378 exited with code 0 after 0.0m
I0109 22:19:24.838] Call:  gcloud config get-value account
I0109 22:19:25.472] process 1391 exited with code 0 after 0.0m
I0109 22:19:25.472] Will upload results to gs://kubernetes-jenkins/logs using pr-kubekins@kubernetes-jenkins-pull.iam.gserviceaccount.com
I0109 22:19:25.473] Upload result and artifacts...
I0109 22:19:25.473] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sstable3-serial/1215396168033374210
I0109 22:19:25.473] Call:  gsutil ls gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sstable3-serial/1215396168033374210/artifacts
W0109 22:19:27.237] CommandException: One or more URLs matched no objects.
E0109 22:19:27.553] Command failed
I0109 22:19:27.553] process 1404 exited with code 1 after 0.0m
W0109 22:19:27.554] Remote dir gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sstable3-serial/1215396168033374210/artifacts not exist yet
I0109 22:19:27.554] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sstable3-serial/1215396168033374210/artifacts
I0109 22:19:30.911] process 1549 exited with code 0 after 0.1m
I0109 22:19:30.912] Call:  git rev-parse HEAD
W0109 22:19:30.919] fatal: not a git repository (or any of the parent directories): .git
E0109 22:19:30.920] Command failed
I0109 22:19:30.920] process 2076 exited with code 128 after 0.0m
I0109 22:19:30.920] Call:  git rev-parse HEAD
I0109 22:19:30.927] process 2077 exited with code 0 after 0.0m
I0109 22:19:30.928] Call:  gsutil stat gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sstable3-serial/jobResultsCache.json
I0109 22:19:32.627] process 2078 exited with code 0 after 0.0m
I0109 22:19:32.628] Call:  gsutil -q cat 'gs://kubernetes-jenkins/logs/ci-kubernetes-e2e-gke-ubuntu2-k8sstable3-serial/jobResultsCache.json#1578586593823593'
... skipping 8 lines ...