This job view page is being replaced by Spyglass soon. Check out the new job view.
PRnilo19: Cherry pick of #100690: azure: fix node public IP not able to fetch issues from IMDS
ResultFAILURE
Tests 1 failed / 7 succeeded
Started2021-04-08 07:19
Elapsed4m28s
Revision
Builderbc1c3785-983a-11eb-8183-b6e7cc39868b
Refs release-1.19:64c9b22d
100911:c880b256
infra-commitaf94cbbfa
job-versionv1.19.10-rc.0.47+3f1b64ac466ff2
kubetest-version
repok8s.io/kubernetes
repo-commit3f1b64ac466ff23cffca91525269a566a1f649d8
repos{u'k8s.io/kubernetes': u'release-1.19:64c9b22df7ee3ea19ee34a0a08f85157ed0426d7,100911:c880b25645ade7cbc4819b843e844427ba89a845'}
revisionv1.19.10-rc.0.47+3f1b64ac466ff2

Test Failures


Node Tests 2m57s

error during go run /go/src/k8s.io/kubernetes/test/e2e_node/runner/remote/run_remote.go --cleanup --logtostderr --vmodule=*=4 --ssh-env=gce --results-dir=/workspace/_artifacts --project=k8s-infra-e2e-boskos-118 --zone=us-west1-b --ssh-user=prow --ssh-key=/workspace/.ssh/google_compute_engine --ginkgo-flags=--nodes=8 --focus="\[NodeConformance\]" --skip="\[Flaky\]|\[Slow\]|\[Serial\]" --test_args=--kubelet-flags="--cgroups-per-qos=true --cgroup-root=/" --test-timeout=1h5m0s --image-config-file=/workspace/test-infra/jobs/e2e_node/image-config.yaml: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 7 Passed Tests

Error lines from build-log.txt

... skipping 254 lines ...
W0408 07:22:49.108] !!! [0408 07:22:49]  2: /go/src/k8s.io/kubernetes/hack/lib/golang.sh:863 kube::golang::build_binaries_for_platform(...)
W0408 07:22:49.110] !!! [0408 07:22:49]  3: hack/make-rules/build.sh:27 kube::golang::build_binaries(...)
W0408 07:22:49.114] !!! [0408 07:22:49] Call tree:
W0408 07:22:49.116] !!! [0408 07:22:49]  1: hack/make-rules/build.sh:27 kube::golang::build_binaries(...)
W0408 07:22:49.121] !!! [0408 07:22:49] Call tree:
W0408 07:22:49.123] !!! [0408 07:22:49]  1: hack/make-rules/build.sh:27 kube::golang::build_binaries(...)
W0408 07:22:49.123] make: *** [Makefile:93: all] Error 1
I0408 07:22:49.223] make: Leaving directory '/go/src/k8s.io/kubernetes'
W0408 07:22:49.559] I0408 07:22:49.559688    4879 run_remote.go:761] Deleting instance "tmp-node-e2e-6cbd7cc8-ubuntu-gke-2004-1-20-v20210401"
I0408 07:22:50.051] 
I0408 07:22:50.052] >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
I0408 07:22:50.052] >                              START TEST                                >
I0408 07:22:50.052] >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
I0408 07:22:50.052] Start Test Suite on Host 
I0408 07:22:50.052] 
I0408 07:22:50.052] Failure Finished Test Suite on Host 
I0408 07:22:50.053] unable to create test archive: failed to setup test package "/tmp/node-e2e-archive346495509": failed to build the dependencies: failed to build go packages exit status 2
I0408 07:22:50.053] <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
I0408 07:22:50.053] <                              FINISH TEST                               <
I0408 07:22:50.053] <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
I0408 07:22:50.053] 
W0408 07:23:30.750] I0408 07:23:30.750719    4879 run_remote.go:761] Deleting instance "tmp-node-e2e-6cbd7cc8-cos-81-12871-1245-19"
I0408 07:23:31.214] 
I0408 07:23:31.214] >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
I0408 07:23:31.214] >                              START TEST                                >
I0408 07:23:31.214] >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
I0408 07:23:31.214] Start Test Suite on Host 
I0408 07:23:31.215] 
I0408 07:23:31.215] Failure Finished Test Suite on Host 
I0408 07:23:31.215] unable to create test archive: failed to setup test package "/tmp/node-e2e-archive346495509": failed to build the dependencies: failed to build go packages exit status 2
I0408 07:23:31.215] <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
I0408 07:23:31.215] <                              FINISH TEST                               <
I0408 07:23:31.215] <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
I0408 07:23:31.215] 
W0408 07:23:50.478] I0408 07:23:50.478156    4879 run_remote.go:761] Deleting instance "tmp-node-e2e-6cbd7cc8-cos-85-13310-1209-24"
I0408 07:23:50.913] 
I0408 07:23:50.914] >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
I0408 07:23:50.914] >                              START TEST                                >
I0408 07:23:50.914] >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
I0408 07:23:50.914] Start Test Suite on Host 
I0408 07:23:50.914] 
I0408 07:23:50.914] Failure Finished Test Suite on Host 
I0408 07:23:50.915] unable to create test archive: failed to setup test package "/tmp/node-e2e-archive346495509": failed to build the dependencies: failed to build go packages exit status 2
I0408 07:23:50.915] <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
I0408 07:23:50.915] <                              FINISH TEST                               <
I0408 07:23:50.916] <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
I0408 07:23:50.916] 
I0408 07:23:50.916] Failure: 3 errors encountered.
W0408 07:23:51.016] exit status 1
... skipping 6 lines ...
I0408 07:23:51.204] Sourcing kube-util.sh
I0408 07:23:51.204] Detecting project
I0408 07:23:51.204] Project: k8s-infra-e2e-boskos-118
I0408 07:23:51.204] Network Project: k8s-infra-e2e-boskos-118
I0408 07:23:51.204] Zone: us-west1-b
I0408 07:23:51.204] Dumping logs from master locally to '/workspace/_artifacts'
W0408 07:23:51.989] ERROR: (gcloud.compute.addresses.describe) Could not fetch resource:
W0408 07:23:51.990]  - The resource 'projects/k8s-infra-e2e-boskos-118/regions/us-west1/addresses/bootstrap-e2e-master-ip' was not found
W0408 07:23:51.990] 
W0408 07:23:52.139] Could not detect Kubernetes master node.  Make sure you've launched a cluster with 'kube-up.sh'
I0408 07:23:52.240] Master not detected. Is the cluster up?
I0408 07:23:52.241] Dumping logs from nodes locally to '/workspace/_artifacts'
I0408 07:23:52.241] Detecting nodes in the cluster
... skipping 4 lines ...
W0408 07:23:56.118] NODE_NAMES=
W0408 07:23:56.118] 2021/04/08 07:23:56 process.go:155: Step './cluster/log-dump/log-dump.sh /workspace/_artifacts' finished in 5.073172586s
W0408 07:23:56.118] 2021/04/08 07:23:56 node.go:53: Noop - Node Down()
W0408 07:23:56.119] 2021/04/08 07:23:56 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0408 07:23:56.119] 2021/04/08 07:23:56 process.go:153: Running: bash -c . hack/lib/version.sh && KUBE_ROOT=. kube::version::get_version_vars && echo "${KUBE_GIT_VERSION-}"
W0408 07:23:56.288] 2021/04/08 07:23:56 process.go:155: Step 'bash -c . hack/lib/version.sh && KUBE_ROOT=. kube::version::get_version_vars && echo "${KUBE_GIT_VERSION-}"' finished in 169.4635ms
W0408 07:23:56.301] 2021/04/08 07:23:56 main.go:327: Something went wrong: encountered 1 errors: [error during go run /go/src/k8s.io/kubernetes/test/e2e_node/runner/remote/run_remote.go --cleanup --logtostderr --vmodule=*=4 --ssh-env=gce --results-dir=/workspace/_artifacts --project=k8s-infra-e2e-boskos-118 --zone=us-west1-b --ssh-user=prow --ssh-key=/workspace/.ssh/google_compute_engine --ginkgo-flags=--nodes=8 --focus="\[NodeConformance\]" --skip="\[Flaky\]|\[Slow\]|\[Serial\]" --test_args=--kubelet-flags="--cgroups-per-qos=true --cgroup-root=/" --test-timeout=1h5m0s --image-config-file=/workspace/test-infra/jobs/e2e_node/image-config.yaml: exit status 1]
W0408 07:23:56.303] Traceback (most recent call last):
W0408 07:23:56.303]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 723, in <module>
W0408 07:23:56.303]     main(parse_args())
W0408 07:23:56.303]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 569, in main
W0408 07:23:56.304]     mode.start(runner_args)
W0408 07:23:56.304]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 228, in start
W0408 07:23:56.304]     check_env(env, self.command, *args)
W0408 07:23:56.304]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0408 07:23:56.304]     subprocess.check_call(cmd, env=env)
W0408 07:23:56.304]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0408 07:23:56.304]     raise CalledProcessError(retcode, cmd)
W0408 07:23:56.305] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=node', '--provider=gce', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--gcp-zone=us-west1-b', '--node-test-args=--kubelet-flags="--cgroups-per-qos=true --cgroup-root=/"', '--node-tests=true', '--test_args=--nodes=8 --focus="\\[NodeConformance\\]" --skip="\\[Flaky\\]|\\[Slow\\]|\\[Serial\\]"', '--timeout=65m', '--node-args=--image-config-file=/workspace/test-infra/jobs/e2e_node/image-config.yaml')' returned non-zero exit status 1
E0408 07:23:56.312] Command failed
I0408 07:23:56.312] process 561 exited with code 1 after 3.1m
E0408 07:23:56.312] FAIL: pull-kubernetes-node-e2e
I0408 07:23:56.312] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0408 07:23:56.833] Activated service account credentials for: [prow-build@k8s-infra-prow-build.iam.gserviceaccount.com]
I0408 07:23:56.920] process 11356 exited with code 0 after 0.0m
I0408 07:23:56.921] Call:  gcloud config get-value account
I0408 07:23:57.385] process 11369 exited with code 0 after 0.0m
I0408 07:23:57.385] Will upload results to gs://kubernetes-jenkins/pr-logs using prow-build@k8s-infra-prow-build.iam.gserviceaccount.com
I0408 07:23:57.386] Upload result and artifacts...
I0408 07:23:57.386] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/pr-logs/pull/100911/pull-kubernetes-node-e2e/1380057654197489664
I0408 07:23:57.386] Call:  gsutil ls gs://kubernetes-jenkins/pr-logs/pull/100911/pull-kubernetes-node-e2e/1380057654197489664/artifacts
W0408 07:23:58.256] CommandException: One or more URLs matched no objects.
E0408 07:23:58.426] Command failed
I0408 07:23:58.426] process 11382 exited with code 1 after 0.0m
W0408 07:23:58.427] Remote dir gs://kubernetes-jenkins/pr-logs/pull/100911/pull-kubernetes-node-e2e/1380057654197489664/artifacts not exist yet
I0408 07:23:58.427] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/pr-logs/pull/100911/pull-kubernetes-node-e2e/1380057654197489664/artifacts
I0408 07:23:59.973] process 11529 exited with code 0 after 0.0m
I0408 07:23:59.974] Call:  git rev-parse HEAD
I0408 07:23:59.978] process 12079 exited with code 0 after 0.0m
... skipping 20 lines ...