This job view page is being replaced by Spyglass soon. Check out the new job view.
PRnilo19: Automated cherry pick of #105777: fix: do not delete the lb that does not exist
ResultFAILURE
Tests 1 failed / 7 succeeded
Started2022-01-13 01:33
Elapsed4m2s
Revision
Buildercc920447-7410-11ec-a8af-520c1b79f1c2
Refs release-1.20:aaef1f46
106067:6e789e05
infra-commit095618ea1
job-versionv1.20.15-rc.0.15+dcc5b7794f2a52
kubetest-version
repok8s.io/kubernetes
repo-commitdcc5b7794f2a5221855c9e9f326cc840488d110d
repos{u'k8s.io/kubernetes': u'release-1.20:aaef1f46ef84a2d7bd71364165655e05219f2606,106067:6e789e05eeaa7ae49cf8ae2e15ed3b609b40be75'}
revisionv1.20.15-rc.0.15+dcc5b7794f2a52

Test Failures


kubetest Node Tests 2m28s

error during go run /go/src/k8s.io/kubernetes/test/e2e_node/runner/remote/run_remote.go --cleanup --logtostderr --vmodule=*=4 --ssh-env=gce --results-dir=/workspace/_artifacts --project=k8s-infra-e2e-boskos-043 --zone=us-west1-b --ssh-user=prow --ssh-key=/workspace/.ssh/google_compute_engine --ginkgo-flags=--nodes=8 --focus="\[NodeConformance\]" --skip="\[Flaky\]|\[Slow\]|\[Serial\]" --test_args=--kubelet-flags="--cgroups-per-qos=true --cgroup-root=/" --test-timeout=1h5m0s --image-config-file=/workspace/test-infra/jobs/e2e_node/image-config.yaml: exit status 1
				from junit_runner.xml

Filter through log files | View test history on testgrid


Show 7 Passed Tests

Error lines from build-log.txt

... skipping 256 lines ...
W0113 01:36:45.534] !!! [0113 01:36:45]  2: /go/src/k8s.io/kubernetes/hack/lib/golang.sh:864 kube::golang::build_binaries_for_platform(...)
W0113 01:36:45.536] !!! [0113 01:36:45]  3: hack/make-rules/build.sh:27 kube::golang::build_binaries(...)
W0113 01:36:45.540] !!! [0113 01:36:45] Call tree:
W0113 01:36:45.542] !!! [0113 01:36:45]  1: hack/make-rules/build.sh:27 kube::golang::build_binaries(...)
W0113 01:36:45.547] !!! [0113 01:36:45] Call tree:
W0113 01:36:45.549] !!! [0113 01:36:45]  1: hack/make-rules/build.sh:27 kube::golang::build_binaries(...)
W0113 01:36:45.549] make: *** [Makefile:93: all] Error 1
I0113 01:36:45.650] make: Leaving directory '/go/src/k8s.io/kubernetes'
W0113 01:36:45.750] I0113 01:36:45.705524    5577 run_remote.go:761] Deleting instance "tmp-node-e2e-12f99bc7-ubuntu-gke-2004-1-20-v20210401"
I0113 01:36:46.115] 
I0113 01:36:46.115] >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
I0113 01:36:46.115] >                              START TEST                                >
I0113 01:36:46.116] >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
I0113 01:36:46.116] Start Test Suite on Host 
I0113 01:36:46.116] 
I0113 01:36:46.116] Failure Finished Test Suite on Host 
I0113 01:36:46.116] unable to create test archive: failed to setup test package "/tmp/node-e2e-archive464611255": failed to build the dependencies: failed to build go packages exit status 2
I0113 01:36:46.116] <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
I0113 01:36:46.117] <                              FINISH TEST                               <
I0113 01:36:46.117] <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
I0113 01:36:46.117] 
W0113 01:37:08.031] I0113 01:37:08.031081    5577 run_remote.go:761] Deleting instance "tmp-node-e2e-12f99bc7-cos-89-16108-534-41"
I0113 01:37:08.408] 
I0113 01:37:08.409] >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
I0113 01:37:08.409] >                              START TEST                                >
I0113 01:37:08.409] >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
I0113 01:37:08.409] Start Test Suite on Host 
I0113 01:37:08.409] 
I0113 01:37:08.409] Failure Finished Test Suite on Host 
I0113 01:37:08.410] unable to create test archive: failed to setup test package "/tmp/node-e2e-archive464611255": failed to build the dependencies: failed to build go packages exit status 2
I0113 01:37:08.410] <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
I0113 01:37:08.410] <                              FINISH TEST                               <
I0113 01:37:08.410] <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
I0113 01:37:08.410] 
W0113 01:37:15.692] I0113 01:37:15.691914    5577 run_remote.go:761] Deleting instance "tmp-node-e2e-12f99bc7-cos-93-16623-39-40"
I0113 01:37:16.179] 
I0113 01:37:16.179] >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
I0113 01:37:16.179] >                              START TEST                                >
I0113 01:37:16.179] >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
I0113 01:37:16.180] Start Test Suite on Host 
I0113 01:37:16.180] 
I0113 01:37:16.180] Failure Finished Test Suite on Host 
I0113 01:37:16.180] unable to create test archive: failed to setup test package "/tmp/node-e2e-archive464611255": failed to build the dependencies: failed to build go packages exit status 2
I0113 01:37:16.180] <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
I0113 01:37:16.180] <                              FINISH TEST                               <
I0113 01:37:16.181] <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
I0113 01:37:16.181] 
I0113 01:37:16.181] Failure: 3 errors encountered.
W0113 01:37:16.281] exit status 1
... skipping 11 lines ...
I0113 01:37:16.502] Sourcing kube-util.sh
I0113 01:37:16.502] Detecting project
I0113 01:37:16.503] Project: k8s-infra-e2e-boskos-043
I0113 01:37:16.503] Network Project: k8s-infra-e2e-boskos-043
I0113 01:37:16.503] Zone: us-west1-b
I0113 01:37:16.503] Dumping logs from master locally to '/workspace/_artifacts'
W0113 01:37:17.256] ERROR: (gcloud.compute.addresses.describe) Could not fetch resource:
W0113 01:37:17.256]  - The resource 'projects/k8s-infra-e2e-boskos-043/regions/us-west1/addresses/bootstrap-e2e-master-ip' was not found
W0113 01:37:17.256] 
W0113 01:37:17.376] Could not detect Kubernetes master node.  Make sure you've launched a cluster with 'kube-up.sh'
I0113 01:37:17.476] Master not detected. Is the cluster up?
I0113 01:37:17.477] Dumping logs from nodes locally to '/workspace/_artifacts'
I0113 01:37:17.477] Detecting nodes in the cluster
... skipping 4 lines ...
W0113 01:37:21.286] NODE_NAMES=
W0113 01:37:21.288] 2022/01/13 01:37:21 process.go:155: Step './cluster/log-dump/log-dump.sh /workspace/_artifacts' finished in 4.954905108s
W0113 01:37:21.288] 2022/01/13 01:37:21 node.go:53: Noop - Node Down()
W0113 01:37:21.289] 2022/01/13 01:37:21 process.go:96: Saved XML output to /workspace/_artifacts/junit_runner.xml.
W0113 01:37:21.289] 2022/01/13 01:37:21 process.go:153: Running: bash -c . hack/lib/version.sh && KUBE_ROOT=. kube::version::get_version_vars && echo "${KUBE_GIT_VERSION-}"
W0113 01:37:21.452] 2022/01/13 01:37:21 process.go:155: Step 'bash -c . hack/lib/version.sh && KUBE_ROOT=. kube::version::get_version_vars && echo "${KUBE_GIT_VERSION-}"' finished in 163.661255ms
W0113 01:37:21.463] 2022/01/13 01:37:21 main.go:331: Something went wrong: encountered 1 errors: [error during go run /go/src/k8s.io/kubernetes/test/e2e_node/runner/remote/run_remote.go --cleanup --logtostderr --vmodule=*=4 --ssh-env=gce --results-dir=/workspace/_artifacts --project=k8s-infra-e2e-boskos-043 --zone=us-west1-b --ssh-user=prow --ssh-key=/workspace/.ssh/google_compute_engine --ginkgo-flags=--nodes=8 --focus="\[NodeConformance\]" --skip="\[Flaky\]|\[Slow\]|\[Serial\]" --test_args=--kubelet-flags="--cgroups-per-qos=true --cgroup-root=/" --test-timeout=1h5m0s --image-config-file=/workspace/test-infra/jobs/e2e_node/image-config.yaml: exit status 1]
W0113 01:37:21.465] Traceback (most recent call last):
W0113 01:37:21.466]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 723, in <module>
W0113 01:37:21.466]     main(parse_args())
W0113 01:37:21.466]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 569, in main
W0113 01:37:21.466]     mode.start(runner_args)
W0113 01:37:21.466]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 228, in start
W0113 01:37:21.466]     check_env(env, self.command, *args)
W0113 01:37:21.467]   File "/workspace/./test-infra/jenkins/../scenarios/kubernetes_e2e.py", line 111, in check_env
W0113 01:37:21.467]     subprocess.check_call(cmd, env=env)
W0113 01:37:21.467]   File "/usr/lib/python2.7/subprocess.py", line 190, in check_call
W0113 01:37:21.467]     raise CalledProcessError(retcode, cmd)
W0113 01:37:21.468] subprocess.CalledProcessError: Command '('kubetest', '--dump=/workspace/_artifacts', '--gcp-service-account=/etc/service-account/service-account.json', '--up', '--down', '--test', '--deployment=node', '--provider=gce', '--cluster=bootstrap-e2e', '--gcp-network=bootstrap-e2e', '--gcp-zone=us-west1-b', '--node-test-args=--kubelet-flags="--cgroups-per-qos=true --cgroup-root=/"', '--node-tests=true', '--test_args=--nodes=8 --focus="\\[NodeConformance\\]" --skip="\\[Flaky\\]|\\[Slow\\]|\\[Serial\\]"', '--timeout=65m', '--node-args=--image-config-file=/workspace/test-infra/jobs/e2e_node/image-config.yaml')' returned non-zero exit status 1
E0113 01:37:21.474] Command failed
I0113 01:37:21.474] process 528 exited with code 1 after 2.6m
E0113 01:37:21.474] FAIL: pull-kubernetes-node-e2e
I0113 01:37:21.474] Call:  gcloud auth activate-service-account --key-file=/etc/service-account/service-account.json
W0113 01:37:22.101] Activated service account credentials for: [prow-build@k8s-infra-prow-build.iam.gserviceaccount.com]
I0113 01:37:22.191] process 12256 exited with code 0 after 0.0m
I0113 01:37:22.191] Call:  gcloud config get-value account
I0113 01:37:22.726] process 12269 exited with code 0 after 0.0m
I0113 01:37:22.726] Will upload results to gs://kubernetes-jenkins/pr-logs using prow-build@k8s-infra-prow-build.iam.gserviceaccount.com
I0113 01:37:22.726] Upload result and artifacts...
I0113 01:37:22.727] Gubernator results at https://gubernator.k8s.io/build/kubernetes-jenkins/pr-logs/pull/106067/pull-kubernetes-node-e2e/1481439201965641728
I0113 01:37:22.727] Call:  gsutil ls gs://kubernetes-jenkins/pr-logs/pull/106067/pull-kubernetes-node-e2e/1481439201965641728/artifacts
W0113 01:37:23.608] CommandException: One or more URLs matched no objects.
E0113 01:37:23.749] Command failed
I0113 01:37:23.750] process 12282 exited with code 1 after 0.0m
W0113 01:37:23.750] Remote dir gs://kubernetes-jenkins/pr-logs/pull/106067/pull-kubernetes-node-e2e/1481439201965641728/artifacts not exist yet
I0113 01:37:23.750] Call:  gsutil -m -q -o GSUtil:use_magicfile=True cp -r -c -z log,txt,xml /workspace/_artifacts gs://kubernetes-jenkins/pr-logs/pull/106067/pull-kubernetes-node-e2e/1481439201965641728/artifacts
I0113 01:37:25.278] process 12421 exited with code 0 after 0.0m
I0113 01:37:25.278] Call:  git rev-parse HEAD
I0113 01:37:25.281] process 12939 exited with code 0 after 0.0m
... skipping 21 lines ...