This job view page is being replaced by Spyglass soon. Check out the new job view.
PRboddumanohar: feat: blobfuse proxy
ResultFAILURE
Tests 0 failed / 0 succeeded
Started2021-03-02 08:39
Elapsed9m54s
Revision83d61e58099f67f5e0d8321ebbbb5e773cc456d8
Refs 356

No Test Failures!


Error lines from build-log.txt

... skipping 67 lines ...
Preparing to install helm into /usr/local/bin
helm installed into /usr/local/bin/helm
kubectl apply -f ./deploy/blobfuse-proxy/blobfuse-proxy.yaml
daemonset.apps/csi-blobfuse-proxy created
# Only build and push the image if it does not exist in the registry
docker pull k8sprow.azurecr.io/blob-csi:e2e-a1ecbfe0b32ac0d35eff6af75b0a49af07918dbf || make blob-container push
Error response from daemon: manifest for k8sprow.azurecr.io/blob-csi:e2e-a1ecbfe0b32ac0d35eff6af75b0a49af07918dbf not found: manifest unknown: manifest tagged by "e2e-a1ecbfe0b32ac0d35eff6af75b0a49af07918dbf" is not found
make[2]: Entering directory '/home/prow/go/src/sigs.k8s.io/blob-csi-driver'
docker buildx rm container-builder || true
error: no builder "container-builder" found
docker buildx create --use --name=container-builder
container-builder
docker buildx build --no-cache --build-arg LDFLAGS="-X sigs.k8s.io/blob-csi-driver/pkg/blob.driverVersion=e2e-a1ecbfe0b32ac0d35eff6af75b0a49af07918dbf -X sigs.k8s.io/blob-csi-driver/pkg/blob.gitCommit=a1ecbfe0b32ac0d35eff6af75b0a49af07918dbf -X sigs.k8s.io/blob-csi-driver/pkg/blob.buildDate=2021-03-02T08:45:55Z -s -w -extldflags '-static'" -t k8sprow.azurecr.io/blob-csi:e2e-a1ecbfe0b32ac0d35eff6af75b0a49af07918dbf -f ./pkg/blobplugin/Dockerfile --platform="linux/amd64" --push .
#1 [internal] booting buildkit
#1 sha256:2ad254f89e214836bd179b1fd462f04786e5c6804346fcf3b02ddb45cf4006fe
#1 pulling image moby/buildkit:buildx-stable-1
... skipping 115 lines ...
#13 5.520 Reading state information...
#13 5.702 The following additional packages will be installed:
#13 5.702   cmake-data libarchive13 libblkid1 libc-dev-bin libc6-dev libcom-err2
#13 5.702   libcurl3-gnutls libcurl4 libdpkg-perl libevent-2.1-6 libexpat1 libfuse2
#13 5.702   libgdbm-compat4 libgdbm6 libglib2.0-0 libgmp-dev libgmpxx4ldbl
#13 5.702   libgnutls-dane0 libgnutls-openssl27 libgnutls30 libgnutlsxx28
#13 5.702   libgpg-error-dev libgssapi-krb5-2 libicu63 libidn2-dev libjsoncpp1
#13 5.702   libk5crypto3 libkeyutils1 libkrb5-3 libkrb5support0 libldap-2.4-2
#13 5.703   libldap-common libmount1 libncurses6 libncursesw6 libnghttp2-14
#13 5.703   libp11-kit-dev libp11-kit0 libpcre16-3 libpcre2-8-0 libpcre3-dev libpcre32-3
#13 5.703   libpcrecpp0v5 libperl5.28 libprocps7 libpsl5 librhash0 librtmp1 libsasl2-2
#13 5.703   libsasl2-modules-db libselinux1-dev libsepol1-dev libssh2-1 libssl1.1
#13 5.703   libtasn1-6-dev libtinfo6 libunbound8 libuuid1 libuv1 libxml2 linux-libc-dev
... skipping 14 lines ...
#13 6.307 The following NEW packages will be installed:
#13 6.308   ca-certificates cmake cmake-data libarchive13 libblkid1 libc-dev-bin
#13 6.308   libc6-dev libcom-err2 libcurl3-gnutls libcurl4 libcurl4-gnutls-dev
#13 6.308   libdpkg-perl libevent-2.1-6 libexpat1 libfuse-dev libfuse2 libgcrypt20-dev
#13 6.309   libgdbm-compat4 libgdbm6 libglib2.0-0 libgmp-dev libgmpxx4ldbl
#13 6.309   libgnutls-dane0 libgnutls-openssl27 libgnutls28-dev libgnutlsxx28
#13 6.309   libgpg-error-dev libgssapi-krb5-2 libicu63 libidn2-dev libjsoncpp1
#13 6.309   libk5crypto3 libkeyutils1 libkrb5-3 libkrb5support0 libldap-2.4-2
#13 6.309   libldap-common libmount1 libncurses6 libncursesw6 libnghttp2-14
#13 6.309   libp11-kit-dev libpcre16-3 libpcre2-8-0 libpcre3-dev libpcre32-3
#13 6.309   libpcrecpp0v5 libperl5.28 libprocps7 libpsl5 librhash0 librtmp1 libsasl2-2
#13 6.309   libsasl2-modules-db libselinux1-dev libsepol1-dev libssh2-1 libssl1.1
#13 6.309   libtasn1-6-dev libtinfo6 libunbound8 libuuid1 libuv1 libxml2 linux-libc-dev
... skipping 60 lines ...
#13 7.281 Get:54 http://deb.debian.org/debian buster/main amd64 libpcre16-3 amd64 2:8.39-12 [259 kB]
#13 7.286 Get:55 http://deb.debian.org/debian buster/main amd64 libpcre32-3 amd64 2:8.39-12 [250 kB]
#13 7.293 Get:56 http://deb.debian.org/debian buster/main amd64 libpcrecpp0v5 amd64 2:8.39-12 [152 kB]
#13 7.296 Get:57 http://deb.debian.org/debian buster/main amd64 libpcre3-dev amd64 2:8.39-12 [650 kB]
#13 7.310 Get:58 http://deb.debian.org/debian buster/main amd64 libselinux1-dev amd64 2.8-1+b1 [169 kB]
#13 7.315 Get:59 http://deb.debian.org/debian buster/main amd64 libfuse-dev amd64 2.9.9-1+deb10u1 [152 kB]
#13 7.317 Get:60 http://deb.debian.org/debian buster/main amd64 libgpg-error-dev amd64 1.35-1 [124 kB]
#13 7.320 Get:61 http://deb.debian.org/debian buster/main amd64 libgcrypt20-dev amd64 1.8.4-5 [608 kB]
#13 7.335 Get:62 http://deb.debian.org/debian buster/main amd64 libmount1 amd64 2.33.1-0.1 [207 kB]
#13 7.340 Get:63 http://deb.debian.org/debian buster/main amd64 libglib2.0-0 amd64 2.58.3-2+deb10u2 [1258 kB]
#13 7.371 Get:64 http://deb.debian.org/debian buster/main amd64 libgmpxx4ldbl amd64 2:6.1.2+dfsg-4 [22.9 kB]
#13 7.372 Get:65 http://deb.debian.org/debian buster/main amd64 libgmp-dev amd64 2:6.1.2+dfsg-4 [628 kB]
#13 7.386 Get:66 http://deb.debian.org/debian buster/main amd64 libunbound8 amd64 1.9.0-2+deb10u2 [462 kB]
... skipping 186 lines ...
#13 17.79 Selecting previously unselected package libselinux1-dev:amd64.
#13 17.79 Preparing to unpack .../50-libselinux1-dev_2.8-1+b1_amd64.deb ...
#13 17.80 Unpacking libselinux1-dev:amd64 (2.8-1+b1) ...
#13 17.87 Selecting previously unselected package libfuse-dev.
#13 17.87 Preparing to unpack .../51-libfuse-dev_2.9.9-1+deb10u1_amd64.deb ...
#13 17.88 Unpacking libfuse-dev (2.9.9-1+deb10u1) ...
#13 17.96 Selecting previously unselected package libgpg-error-dev.

#13 17.96 Preparing to unpack .../52-libgpg-error-dev_1.35-1_amd64.deb ...

#13 17.96 Unpacking libgpg-error-dev (1.35-1) ...

#13 18.06 Selecting previously unselected package libgcrypt20-dev.
#13 18.06 Preparing to unpack .../53-libgcrypt20-dev_1.8.4-5_amd64.deb ...
#13 18.07 Unpacking libgcrypt20-dev (1.8.4-5) ...
#13 18.20 Selecting previously unselected package libmount1:amd64.
#13 18.21 Preparing to unpack .../54-libmount1_2.33.1-0.1_amd64.deb ...
#13 18.21 Unpacking libmount1:amd64 (2.33.1-0.1) ...
... skipping 60 lines ...
#13 20.01 Setting up libldap-common (2.4.47+dfsg-3+deb10u6) ...
#13 20.03 Setting up libicu63:amd64 (63.1-6+deb10u1) ...
#13 20.04 Setting up libkrb5support0:amd64 (1.17-3+deb10u1) ...
#13 20.06 Setting up libsasl2-modules-db:amd64 (2.1.27+dfsg-1+deb10u1) ...
#13 20.07 Setting up libgmpxx4ldbl:amd64 (2:6.1.2+dfsg-4) ...
#13 20.09 Setting up libuv1:amd64 (1.24.1-1) ...
#13 20.10 Setting up libgpg-error-dev (1.35-1) ...

#13 20.12 Setting up librtmp1:amd64 (2.4+20151223.gitfa8646d.1-2) ...
#13 20.13 Setting up libpcre32-3:amd64 (2:8.39-12) ...
#13 20.14 Setting up libuuid1:amd64 (2.33.1-0.1) ...
#13 20.16 Setting up libgnutlsxx28:amd64 (3.6.7-4+deb10u6) ...
#13 20.17 Setting up libpcre2-8-0:amd64 (10.32-5) ...
#13 20.19 Setting up libk5crypto3:amd64 (1.17-3+deb10u1) ...
... skipping 395 lines ...
#16 9.077 Setting up libpython-stdlib:amd64 (2.7.16-1) ...
#16 9.093 Setting up python (2.7.16-1) ...
#16 9.118 Setting up libdevmapper1.02.1:amd64 (2:1.02.155-3) ...
#16 9.134 Setting up dmsetup (2:1.02.155-3) ...
#16 9.153 Setting up nfs-common (1:1.3.4-2.5+deb10u1) ...
#16 9.181 /var/lib/dpkg/info/nfs-common.postinst: 7: /var/lib/dpkg/info/nfs-common.postinst: ucf: not found
#16 9.182 dpkg: error processing package nfs-common (--configure):

#16 9.182  installed nfs-common package post-installation script subprocess returned error exit status 127

#16 9.182 dpkg: dependency problems prevent configuration of nfs-kernel-server:
#16 9.182  nfs-kernel-server depends on nfs-common (= 1:1.3.4-2.5+deb10u1); however:
#16 9.182   Package nfs-common is not configured yet.
#16 9.182 
#16 9.182 dpkg: error processing package nfs-kernel-server (--configure):

#16 9.182  dependency problems - leaving unconfigured
#16 9.183 Processing triggers for libc-bin (2.28-10) ...
#16 9.222 Errors were encountered while processing:
#16 9.222  nfs-common
#16 9.222  nfs-kernel-server
#16 9.242 E: Sub-process /usr/bin/dpkg returned an error code (1)
#16 DONE 9.4s

#17 exporting to image
#17 sha256:e8c613e07b0b7ff33893b694f7759a10d42e180f2b4dc349fb57dc6b71dcab00
#17 exporting layers
#17 exporting layers 11.6s done
... skipping 690 lines ...
        - name: csi-resizer
          image: "mcr.microsoft.com/oss/kubernetes-csi/csi-resizer:v1.1.0"
          args:
            - "-csi-address=$(ADDRESS)"
            - "-v=2"
            - "-leader-election"
            - '-handle-volume-inuse-error=false'
          env:
            - name: ADDRESS
              value: /csi/csi.sock
          imagePullPolicy: IfNotPresent
          volumeMounts:
            - name: socket-dir
... skipping 54 lines ...
Git Commit: N/A
Go Version: go1.15.8
Platform: linux/amd64

Streaming logs below:
STEP: Building a namespace api object, basename blob
W0302 08:48:54.330729   12357 azure_config.go:51] Failed to get cloud-config from secret: failed to get secret azure-cloud-provider: secrets "azure-cloud-provider" not found, skip initializing from secret
I0302 08:48:54.331882   12357 driver.go:80] Enabling controller service capability: CREATE_DELETE_VOLUME
I0302 08:48:54.331907   12357 driver.go:80] Enabling controller service capability: EXPAND_VOLUME
I0302 08:48:54.331916   12357 driver.go:99] Enabling volume access mode: SINGLE_NODE_WRITER
I0302 08:48:54.331923   12357 driver.go:99] Enabling volume access mode: SINGLE_NODE_READER_ONLY
I0302 08:48:54.331928   12357 driver.go:99] Enabling volume access mode: MULTI_NODE_READER_ONLY
I0302 08:48:54.331933   12357 driver.go:99] Enabling volume access mode: MULTI_NODE_SINGLE_WRITER
... skipping 26 lines ...
Mar  2 08:49:11.481: INFO: PersistentVolumeClaim pvc-h7znb found but phase is Pending instead of Bound.
Mar  2 08:49:13.516: INFO: PersistentVolumeClaim pvc-h7znb found and phase=Bound (18.329868577s)
STEP: checking the PVC
STEP: validating provisioned PV
STEP: checking the PV
STEP: deploying the pod
STEP: checking that the pods command exits with no error
Mar  2 08:49:13.613: INFO: Waiting up to 15m0s for pod "blob-volume-tester-7nl5t" in namespace "blob-8287" to be "Succeeded or Failed"
Mar  2 08:49:13.646: INFO: Pod "blob-volume-tester-7nl5t": Phase="Pending", Reason="", readiness=false. Elapsed: 32.189705ms
Mar  2 08:49:15.679: INFO: Pod "blob-volume-tester-7nl5t": Phase="Pending", Reason="", readiness=false. Elapsed: 2.06525723s
Mar  2 08:49:17.712: INFO: Pod "blob-volume-tester-7nl5t": Phase="Succeeded", Reason="", readiness=false. Elapsed: 4.098201238s
STEP: Saw pod success
Mar  2 08:49:17.712: INFO: Pod "blob-volume-tester-7nl5t" satisfied condition "Succeeded or Failed"
Mar  2 08:49:17.712: INFO: deleting Pod "blob-8287"/"blob-volume-tester-7nl5t"
Mar  2 08:49:17.797: INFO: Pod blob-volume-tester-7nl5t has the following logs: hello world

STEP: Deleting pod blob-volume-tester-7nl5t in namespace blob-8287
Mar  2 08:49:17.834: INFO: deleting PVC "blob-8287"/"pvc-h7znb"
Mar  2 08:49:17.834: INFO: Deleting PersistentVolumeClaim "pvc-h7znb"
... skipping 49 lines ...
STEP: deploying the deployment
Mar  2 08:49:42.272: INFO: deployment status: v1.DeploymentStatus{ObservedGeneration:1, Replicas:1, UpdatedReplicas:1, ReadyReplicas:0, AvailableReplicas:0, UnavailableReplicas:1, Conditions:[]v1.DeploymentCondition{v1.DeploymentCondition{Type:"Available", Status:"False", LastUpdateTime:v1.Time{Time:time.Time{wall:0x0, ext:63750271782, loc:(*time.Location)(0x2f4ab60)}}, LastTransitionTime:v1.Time{Time:time.Time{wall:0x0, ext:63750271782, loc:(*time.Location)(0x2f4ab60)}}, Reason:"MinimumReplicasUnavailable", Message:"Deployment does not have minimum availability."}, v1.DeploymentCondition{Type:"Progressing", Status:"True", LastUpdateTime:v1.Time{Time:time.Time{wall:0x0, ext:63750271782, loc:(*time.Location)(0x2f4ab60)}}, LastTransitionTime:v1.Time{Time:time.Time{wall:0x0, ext:63750271782, loc:(*time.Location)(0x2f4ab60)}}, Reason:"ReplicaSetUpdated", Message:"ReplicaSet \"blob-volume-tester-fdq7j-54594c5d4\" is progressing."}}, CollisionCount:(*int32)(nil)}
STEP: checking that the pod is running
STEP: deleting the pod for deployment
Mar  2 08:49:44.437: INFO: Deleting pod "blob-volume-tester-fdq7j-54594c5d4-krhfd" in namespace "blob-3090"
Mar  2 08:49:44.471: INFO: Waiting for pod "blob-volume-tester-fdq7j-54594c5d4-krhfd" in namespace "blob-3090" to be fully deleted
{"component":"entrypoint","file":"prow/entrypoint/run.go:169","func":"k8s.io/test-infra/prow/entrypoint.Options.ExecuteProcess","level":"error","msg":"Entrypoint received interrupt: terminated","severity":"error","time":"2021-03-02T08:49:53Z"}